Составить программу на языке СиСоздайте функцию, которая принимает в качестве аргумента массив значений и возвращает наибольший элемент в массиве?

Информатика | 5 - 9 классы

Составить программу на языке Си

Создайте функцию, которая принимает в качестве аргумента массив значений и возвращает наибольший элемент в массиве.

Ответить на вопрос
Ответы (2)
Паньтюша 1 дек. 2020 г., 13:36:18

#include

int n = 10 ;

int max(int x[n]) { int m = x[0] ; for (int i = 1 ; im) m = x[i] ; } return m ;

}

int main()

{ int a[n] ; srand (time(NULL)) ; for (int i = 0 ; i.

Zulinazoya 1 дек. 2020 г., 13:36:20

#include

#include

int compare(void * a, void * b) { int va = * (int * )a ; int vb = * (int * )b ; if(va = = vb) return 0 ; return va < vb ?

- 1 : 1 ;

}

int max_index(void * base, int n, int width, int ( * compare)(void * a, void * b)) { int i, j = 0 ; char max[width] ; memcpy(max, base, width) ; for(i = 1 ; i < n ; i + + ) { if( compare(base + i * width, max) > 0) { memcpy(max, base + i * width, width) ; j = i ; } } return j ;

}

int main() { int n ; scanf("%d", &n) ; int a[n] ; for(int i = 0 ; i < n ; i + + ) scanf("%d", &a[i]) ; printf("%d \ n", a[max_index(a, n, sizeof(int), compare)]) ;

}.

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

TheTwinS 10 апр. 2020 г., 01:39:24 | 10 - 11 классы

Необходимо создать программу на Turbo Pascal с функцией(задание описано далее)Написать функцию, которая возвращает максимальное из двух целых чисел, полученных в качестве аргумента?

Необходимо создать программу на Turbo Pascal с функцией(задание описано далее)

Написать функцию, которая возвращает максимальное из двух целых чисел, полученных в качестве аргумента.

Пожалуйста помогите.

Drdr0984 15 дек. 2020 г., 04:50:15 | 5 - 9 классы

Написать программу на языке си + + Дан массив из 10 целочисленных элементов?

Написать программу на языке си + + Дан массив из 10 целочисленных элементов.

Посчитать сумму всех элементов массива.

Valeriywwwco 12 мар. 2020 г., 12:56:28 | 10 - 11 классы

Написать программу на языке Си + + В целочисленном массиве В (4, 3) заменить все его элементы их квадратами?

Написать программу на языке Си + + В целочисленном массиве В (4, 3) заменить все его элементы их квадратами.

4yBAK4 28 окт. 2020 г., 14:55:27 | 5 - 9 классы

Дан целочисленный массив из 10 элементов?

Дан целочисленный массив из 10 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести номер первого элемента массива, который делится на 3.

Гарантируется, что в исходном массиве есть хотя бы один такой элемент.

Программу я написал, но выводит все значения, а мне нужно первое.

DaryverRUZ 8 нояб. 2020 г., 18:37:35 | 10 - 11 классы

№1. Дан массив из 30 - ти элементов?

№1. Дан массив из 30 - ти элементов.

Каждый элемент может принимать целочисленные значения от - 100 до 100.

Напишите программу, которая позволит подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива.

№2. Дан массив из 40 элементов.

Каждый элемент может принимать целочисленные значения от 0 до 200.

Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива.

Lara123123 20 дек. 2020 г., 09:19:35 | 10 - 11 классы

Составить программу, находящую наибольший элемент массива и его номер?

Составить программу, находящую наибольший элемент массива и его номер.

333Aliya333 30 июн. 2020 г., 23:14:34 | 5 - 9 классы

Написать функцию bsearch, которая принимает на вход отсортированный по неубыванию массив целых чисел и целое число x?

Написать функцию bsearch, которая принимает на вход отсортированный по неубыванию массив целых чисел и целое число x.

В качестве результата функция должна возвращать индекс первого элемента массива, строго большего x.

В Вашей реализации функция может принимать любое количество любых параметров, только 2 этих параметра обязательны.

При использовании Вашей функции должна быть возможность определить, существует ответ или нет.

В качестве решения пришлите ссылку на репозиторий с программой на языке C с примером использования функции.

Thanking 19 нояб. 2020 г., 17:34:55 | 5 - 9 классы

Составить программу поиска элементов массива, значение которых совпадает с индексом?

Составить программу поиска элементов массива, значение которых совпадает с индексом.

Vikavolkovp 26 дек. 2020 г., 03:02:30 | 5 - 9 классы

1)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком?

1)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.

2)Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения первой половины элементов увеличенных в 2 раза, а второй половины элементом уменьшенных в 2 раза.

На этой странице сайта вы найдете ответы на вопрос Составить программу на языке СиСоздайте функцию, которая принимает в качестве аргумента массив значений и возвращает наибольший элемент в массиве?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.