Даны координаты двух противоположных вершин прямоугольника : (x1, y1), (x2, y2)?

Информатика | 5 - 9 классы

Даны координаты двух противоположных вершин прямоугольника : (x1, y1), (x2, y2).

Стороны прямоугольника параллельны осям координат.

Найти периметр и площадь прямоугольника.

Ответить на вопрос
Ответы (1)
Tomich1 9 дек. 2020 г., 04:22:41

Program pryamougolnik ;

var x1, x2, y1, y2, a, b, s, p : real ;

begin

write ('Введите координату х1 = ') ;

readln (x1) ;

write ('Введите координату y1 = ') ;

readln (y1) ;

write ('Введите координату х2 = ') ;

readln (x2) ;

write ('Введите координату y2 = ') ;

readln (y2) ;

a : = abs(x2 - x1) ;

b : = abs(y2 - y1) ;

p : = (a + b) * 2 ;

s : = a * b ;

writeln ('Периметр прямоугольника P = ', p) ;

writeln ('Площадь прямоугольника S = ', s) ;

end.

Lena23351 26 апр. 2020 г., 18:38:03 | 10 - 11 классы

VBA excel Задана точка на плоскости и два прямоугольника со сторонами параллельными осям координат?

VBA excel Задана точка на плоскости и два прямоугольника со сторонами параллельными осям координат.

Определить, принадлежит ли точка только первому прямоугольнику, только второму или сразу обоим.

Балан2002 12 окт. 2020 г., 05:19:33 | 5 - 9 классы

Даны стороны прямоугольника?

Даны стороны прямоугольника.

Вычислить его периметр и площадь.

Vadka12 22 дек. 2020 г., 17:09:01 | 10 - 11 классы

1)Стороны прямоугольника параллельны осям координат?

1)Стороны прямоугольника параллельны осям координат.

Одна из вершин имеет координаты (0, 0), координаты противоположной вершины задаются с клавиатуры.

Вычислите площадь прямоугольника.

2)С клавиатуры вводится натуральное число.

Если оно кратно двум, напишите "четное число", иначе напишите "нечетное число".

Kalyusya 2 июн. 2020 г., 08:16:06 | 10 - 11 классы

Нужно написать программу на языке Паскаль?

Нужно написать программу на языке Паскаль!

Задание : известен периметр прямоугольника и одна сторона из его сторон.

Найти площадь прямоугольника?

Nysty567890 25 апр. 2020 г., 22:28:48 | 10 - 11 классы

Напишиет программу которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон?

Напишиет программу которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон.

Arishakarimova 3 авг. 2020 г., 21:36:47 | 10 - 11 классы

Делать в Паскале?

Делать в Паскале.

Даны стороны прямоугольника.

Найти его площадь и периметр.

София555555 11 июн. 2020 г., 19:43:41 | 10 - 11 классы

Даны стороны прямоугольника?

Даны стороны прямоугольника.

Найти его площадь и периметр.

Esprit523 30 окт. 2020 г., 13:02:16 | 5 - 9 классы

Прямоугольник со стороной а и в, найти периметр?

Прямоугольник со стороной а и в, найти периметр.

Kabakova2003 20 сент. 2020 г., 07:05:20 | 5 - 9 классы

C + + или паскаль?

C + + или паскаль.

Нужно решение (Динамическое программирование) Найдите количество невырожденных прямоугольников со сторонами, параллельными осям координат, вершины которых лежат в точках с целыми координатами внутри или на границе прямоугольника, противоположные углы которого находятся в точках (0, 0) и (W, Н).

Входные данные Входной файл INPUT.

TXT содержит два натуральных числа W и Н, не превосходящих 1000.

Выходные данные В выходной файл OUTPUT.

TXT выведите ответ на задачу.

Аня1097 31 дек. 2020 г., 15:21:21 | 5 - 9 классы

Напишите программу , которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон?

Напишите программу , которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон.

На этой странице вы найдете ответ на вопрос Даны координаты двух противоположных вершин прямоугольника : (x1, y1), (x2, y2)?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.