Нужна помощь?

Информатика | 5 - 9 классы

Нужна помощь!

1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10.

Все его элементы уменьшить на число 20.

2. дан массив состоящий из 8 вещественных чисел.

Все элементы с четными номерами уменьшить на 1, с нечетными - увеличить на 1.

Ответить на вопрос
Ответы (1)
NikoliNidberg 14 июн. 2021 г., 04:15:40

1)

var

mas : array [1.

5] of integer ;

i : integer ;

begin

for i : = 1 to 5 do

read(mas[i]) ;

for i : = 1 to 5 do begin

mas[i] : = mas[i] - 20 ;

write(mas[i], ' ') ;

end ;

end.

2)

var

mas : array [1.

8] of real ;

i : integer ;

begin

for i : = 1 to 8 do

read(mas[i]) ;

for i : = 1 to 8 do begin

if i mod 2 = 0 then

write(mas[i] - 1, ' ')

else

write(mas[i] + 1, ' ')

end ;

end.

Иштитпополивотп 10 июл. 2021 г., 06:04:20 | 10 - 11 классы

Задачи по Pascal помогите1)Дан массив из конечного числа элементов вывести все отрицательныеэлементы?

Задачи по Pascal помогите

1)Дан массив из конечного числа элементов вывести все отрицательные

элементы.

2)Дан одномерный массив найти все четные элементы массива.

3)Дано n целых чисел найти произведение элементов одномерного массива.

4)Упорядочить данную последовательность по убыванию элементы вводятся с клавиатуры 5)Массив задан датчиком случайных чисел на интервале от - 31 до 45 сформировать новый массив b состоящий из нечетных элементов массива a.

Муъмин 7 июл. 2021 г., 22:24:43 | 5 - 9 классы

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов?

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов.

2. Дан массив из N элементов.

Найти сумму элементов с четными номерами и отдельно – с нечетными номерами.

Карина8класс 4 мая 2021 г., 02:13:40 | 5 - 9 классы

Дан массив из, состоящий из 9 вещественных чисел?

Дан массив из, состоящий из 9 вещественных чисел.

Все элементы массива с четными номерами заменить на их абсолютную величину.

ДОБРО11 18 июл. 2021 г., 01:18:56 | 5 - 9 классы

Дан массив состоящий из 8 вещественных чисел?

Дан массив состоящий из 8 вещественных чисел.

Все элементы с чётными номерами уменьшить на 1 с нечетными - увеличить 1.

Месси228 16 мар. 2021 г., 15:33:15 | 5 - 9 классы

Дан массив, состоящий из 8 случайных целых чисел - 5 до 10, Все его элементы уменьшить на число (а)( число "а" введите с клавиатуры)?

Дан массив, состоящий из 8 случайных целых чисел - 5 до 10, Все его элементы уменьшить на число (а)( число "а" введите с клавиатуры).

Slavakorobov50 20 мая 2021 г., 19:08:49 | 5 - 9 классы

Дан массив, состоящий из 12 случайных чисел от - 5 до 12?

Дан массив, состоящий из 12 случайных чисел от - 5 до 12.

Всего его элементы умножить на последний элемент.

Помогите пожалуйста.

Marina1980545 29 мар. 2021 г., 21:39:09 | 5 - 9 классы

Создать массив, состоящий из 7 вещественных чисел?

Создать массив, состоящий из 7 вещественных чисел.

Вывести на экран произведение квадратов данных чисел.

Элементы массива вводить с помощью оператора "read".

ReliZProjecT 14 мар. 2021 г., 22:19:10 | студенческий

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Нумерация элементов начинается с 0.

Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4.

).

Dkorolev 15 апр. 2021 г., 07:40:14 | студенческий

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая выводит те элементы массива, которые являются чётными числами.

Входные данные

Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).

(c + + ).

Dooood 20 апр. 2021 г., 07:55:37 | 5 - 9 классы

Дан массив из 15 элементов?

Дан массив из 15 элементов.

Все элементы с нечетными номерами удвоить, с четными - уменьшить на 1.

- TURBO PASCAL.

На этой странице находится вопрос Нужна помощь?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.