18. Даны различные действительные числа x, y, z, d?

Информатика | 5 - 9 классы

18. Даны различные действительные числа x, y, z, d.

Найти max (min (x, y), min (x, z), min (z, d)).

Cоставьте программу в Delphe7.

Ответить на вопрос
Ответы (1)
Natabuz 17 июл. 2021 г., 16:45:12

Program ex ; / / Функция для определения из двух чисел минимальное

function min(a, b : real) : real ;

begin if (a > ; b) then min : = b else min : = a

end ; / / Функция для определения из двух чисел максимальное

function max2(a, b : real) : real ;

begin if (a > ; b) then max2 : = a else max2 : = b

end ; / / Функция для определения из трех чисел максимальное

function max3(a, b, c : real) : real ;

begin / / Сначала определяем максимальное из первых двух чисел, / / затем у нас останется два числа и нам остается определить / / максимальное из них max3 : = max2(max2(a, b), c) ;

end ;

var x, y, z, d, max_int : real ;

begin writeln('Введите 4 числа') ; readln(x, y, z, d) ; max_int : = max3(min(x, y), min(x, z), min(z, d)) ; writeln(max_int) ;

end.

WildKat2005 10 июл. 2021 г., 19:05:02 | 5 - 9 классы

Дан массив из 10 вещественных чисел?

Дан массив из 10 вещественных чисел.

Найти min элемент и его номер.

Mfgasredesew 18 янв. 2021 г., 07:15:25 | 10 - 11 классы

Помогите решить ?

Помогите решить .

Даны действительные a, b, c.

Используя процедуру поиска максимума двух чисел max и минимума двух чисел min, получить : min(3a, a + b, 7c) + max(a + b, b + c) С объяснением (паскаль абс).

380964481365 19 авг. 2021 г., 01:56:09 | 10 - 11 классы

33. Даны действительные числах, у?

33. Даны действительные числах, у.

Получить : а) max (x, y) ; б) min (x, y) ; в) max (x, y) , min (x, y).

С помощью математики.

Садлархановааминат 25 апр. 2021 г., 14:04:28 | 10 - 11 классы

Даны 3 числа(а, в, с)?

Даны 3 числа(а, в, с).

Составьте программу, которая меняет местами max и min элементы.

Не массив.

Turbo99 6 февр. 2021 г., 10:13:21 | 5 - 9 классы

Написать программу, которая по заданным четырем значениям находит max(min(a, b), min(c, d))?

Написать программу, которая по заданным четырем значениям находит max(min(a, b), min(c, d)).

Trendi 3 мар. 2021 г., 06:11:35 | 10 - 11 классы

Решить в паскаль Написать программу z = min{x, y} + max(xy, x + y) и если можно блок схему?

Решить в паскаль Написать программу z = min{x, y} + max(xy, x + y) и если можно блок схему.

Pasetovmaks 4 апр. 2021 г., 02:19:06 | студенческий

Найти max{min{a, b}, min{c, d}}?

Найти max{min{a, b}, min{c, d}}.

Напишите пожалуйста программу в VBA.

Рита3834 8 мая 2021 г., 05:43:45 | 10 - 11 классы

Помогите пожалуйста по информатике, желательно все подробно?

Помогите пожалуйста по информатике, желательно все подробно.

Ну и правильно конечно)

1) Дан массив из 5 элементов.

Найти min и max элементов и их произведение.

Aselaselaselasel1 4 авг. 2021 г., 07:35:30 | 10 - 11 классы

Даны действительные числа xyz?

Даны действительные числа xyz.

Получить max( x y z ) min( x y z ).

Дайте ответ в C + + .

Nata7894 18 июл. 2021 г., 14:21:36 | 10 - 11 классы

Найти и напечать z = min{x, y} + max{xy, x + y} ?

Найти и напечать z = min{x, y} + max{xy, x + y} .

На языке С.

Вы открыли страницу вопроса 18. Даны различные действительные числа x, y, z, d?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.