Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам?

Информатика | 5 - 9 классы

Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам.

Или что - то в этом роде.

Ответить на вопрос
Ответы (1)
Огоегор 5 мая 2021 г., 09:25:39

Program corablik ;

uses Graph, Crt ;

var grDriver : integer ; grMode : integer ; ErrCode : integer ; x, y, y0, a, b : integer ; {a, b - переменные для линии моря, чтоб они не зависели от х, у}

procedure more(a, b : integer) ;

begin

moveto(0, y0) ;

setcolor(blue) ;

for a : = 0 to 680 do{слева направо рисуем синусоиду синего чвета} begin b : = y0 - round(sin(a * pi / 180) * 30) ; {30 - коэффициент масштабирования по оси Х,

чем больше, тем волна круче} lineto(a, b) ;

end ;

end ; begin grDriver : = Detect ; InitGraph(grDriver, grMode, '.

\ BGI') ; ErrCode : = GraphResult ; y0 : = 250 ; if ErrCode = grOk then begin x : = 600 ; while x> = 0 do{лучше использовать цикл while, можно менять величину шага,

что тоже влияет на скорость и частоту смены картинки} begin cleardevice ; more(a, b) ; {рисуем волну} setcolor(white) ; {устанавливаем цвет кораблика} y : = y0 - 40 - round(sin(x * pi / 180) * 30) ; {движемся по волне} MoveTo(x - 40, y + 20) ; LineTo(x - 20, y + 40) ; LineTo(x + 20, y + 40) ; LineTo(x + 40, y + 20) ; LineTo(x - 40, y + 20) ; MoveTo(x + 15, y + 20) ; LineTo(x + 15, y - 40) ; LineTo(x - 20, y + 20) ; LineTo(x + 15, y + 20) ; delay(100) ; {нормальная скорость, если модули * .

TPL не глючные как у Вас,

время должно быть в миллисекундах, а не в каких - нибудь наносекундах} x : = x - 2 ; {шаг движения} end ; end else Writeln('Graphics error : ', GraphErrorMsg(ErrCode)) ;

Settextstyle(0, 0, 3) ; {устанавливаем стиль шрифта}

cleardevice ;

setcolor(red) ;

OuttextXY(200, 240, 'Rejs zavershen!

') ; {выводим надпись}

readln ;

CloseGraph ;

end.

KarinaKarina352 17 янв. 2021 г., 04:36:52 | 5 - 9 классы

Составьте программу в системе паскаль №11?

Составьте программу в системе паскаль №11.

1971tth 4 янв. 2021 г., 01:52:04 | 5 - 9 классы

Составьте программу нахождения S круга (на языке Паскаля)?

Составьте программу нахождения S круга (на языке Паскаля).

10246328 10 февр. 2021 г., 11:56:07 | 5 - 9 классы

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль?

Составьте программу, выводящую на экран все четырехзначные числа, сумма цифр которых меньше 4 паскаль.

Veraruu 24 июл. 2021 г., 05:53:45 | 5 - 9 классы

Составьте программу по информатике которая имитирует движения голубого шарика радиуса 20 по диагонали?

Составьте программу по информатике которая имитирует движения голубого шарика радиуса 20 по диагонали.

Lizaafanaseva 14 апр. 2021 г., 00:33:24 | 5 - 9 классы

Составьте программу с циклом по представленной блок - схеме в Паскале?

Составьте программу с циклом по представленной блок - схеме в Паскале!

Alsaiapina2014 14 сент. 2021 г., 23:09:24 | 5 - 9 классы

Составьте программу, которая выводит все делители натурального числа N (в паскале)?

Составьте программу, которая выводит все делители натурального числа N (в паскале).

Рома0729 2 авг. 2021 г., 02:01:52 | 5 - 9 классы

ПАСКАЛЬ Составьте программу, определяющую длину слов" я ученик "?

ПАСКАЛЬ Составьте программу, определяющую длину слов

" я ученик ".

Пенза28122004 11 янв. 2021 г., 15:15:09 | 5 - 9 классы

Программу с ветвлением на языке Паскаль Составьте несколько?

Программу с ветвлением на языке Паскаль Составьте несколько.

Sashashabashov228 26 окт. 2021 г., 10:06:38 | 5 - 9 классы

В Паскале, подробно?

В Паскале, подробно.

Составьте программу.

RodkinSerezha 24 окт. 2021 г., 09:27:16 | 5 - 9 классы

Составьте программы на Паскаль для вычисления выражений ?

Составьте программы на Паскаль для вычисления выражений :

Вы открыли страницу вопроса Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.