Паскаль?

Информатика | 5 - 9 классы

Паскаль!

Помогите надо сделать типо введите кнопку y это завершение программы а если ввели z то продолжение, как сделать вот пример readln (c) ; until c in ['Z', 'z', 'Y', 'y'] ; if c in ['Y', 'y'] then halt ; / / остановка программы как мне написать слово продолжить где halt.

Ответить на вопрос
Ответы (1)
Mammaev131 5 июл. 2020 г., 17:51:10

/ / Данная программа вычисляет детерминант матрицы / / PascalABC.

NET 3.

2 сборка 1318 Var c : char ; Reci : array of integer ; ma : array of array of integer ; n, nc, ip : integer ; resf : real ; function minor(ip, i, n : integer ; var reci : array of integer) : real ; Var ic, j, c, ipp, icc : integer ; res : real ; b : boolean ; arf : array[1.

4] of integer ; begin b : = true ; c : = 0 ; reci[ip] : = i ; ipp : = ip + 1 ; if ipp = nc - 1 then begin for ic : = 1 to n do begin for j : = 1 to ip do if ic = reci[j] then b : = false ; if b = true then begin inc(c) ; arf[c] : = ma[ipp, ic] ; end ; b : = true ; end ; inc(ipp) ; for ic : = 1 to n do begin for j : = 1 to ip do if ic = reci[j] then b : = false ; if b = true then begin inc(c) ; arf[c] : = ma[ipp, ic] ; end ; b : = true ; end ; minor : = arf[1] * arf[4] - arf[2] * arf[3] ; end else begin for ic : = 1 to n do begin for j : = 1 to ip do if ic = reci[j] then b : = false ; if b = true then res + = ma[ipp, ic] * power( - 1, ipp + i) * minor(ipp, ic, n, reci) ; b : = true ; end ; minor : = res ; end ;

end ;

procedure start() ;

Var i, j : integer ;

begin write('Введите количество строк и столбцов : ') ; readln(n) ; ip : = 1 ; nc : = n ; setlength(Reci, n + 1) ; setlength(ma, n + 1) ; for i : = 1 to n do setlength(ma[i], n + 1) ; writeln('Введите матрицу : ') ; for i : = 1 to n do for j : = 1 to n do readln(ma[i][j]) ; for i : = 1 to n do resf + = ma[ip][i] * power( - 1, ip + i) * minor(ip, i, n, reci) ; writeln('Res : ', resf) ;

end ;

begin

repeat

readln(c) ;

until c in ['Z', 'z', 'Y', 'y'] ;

if c in ['Y', 'y'] then halt else start() ;

end.

Пример работы программы :

3 / / введено ни z, ни y, повторяем ввод

z / / продолжаем программу

Введите количество строк и столбцов : 3

Введите матрицу :

9

1

2

8

3

7

4

6

5

Res : - 183.

Allapopova196 27 апр. 2020 г., 05:52:12 | 5 - 9 классы

Напишите как сделать программу в Паскале?

Напишите как сделать программу в Паскале.

Все 2 задачи.

1вика4 15 июн. 2020 г., 06:00:57 | 5 - 9 классы

Помогите написать программу на паскале?

Помогите написать программу на паскале.

"Написать программу, которая позволяет выставлять оценку за работу в зависимости от кол - ва сделанных ошибок.

".

Asidakova 10 янв. 2020 г., 10:46:58 | 10 - 11 классы

Помогите пожалуйста срочно В паскале сделать программу 3 задание?

Помогите пожалуйста срочно В паскале сделать программу 3 задание.

Toonye 2 окт. 2020 г., 00:18:53 | 5 - 9 классы

Сделать программу в Паскале калькулятор?

Сделать программу в Паскале калькулятор?

Littlemonster29 7 июл. 2020 г., 17:39:16 | 10 - 11 классы

Написать програму для ПАСКАЛЬ на уравнение ах(в квадрате) + bx + c = 0?

Написать програму для ПАСКАЛЬ на уравнение ах(в квадрате) + bx + c = 0.

Нужна только программа, чтобы я ввела в ПАСКАЛЬ.

Markwergh 8 дек. 2020 г., 10:28:30 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Кратна ли 5 сумма его чисел.

НАДО СДЕЛАТЬ ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ(написать программу) помогите плиз.

Сыр0к 4 авг. 2020 г., 01:11:16 | 10 - 11 классы

Помогите написать программы в Паскале?

Помогите написать программы в Паскале.

Тим7644ш89 12 апр. 2020 г., 12:11:06 | 10 - 11 классы

Помогите написать программа на Паскале?

Помогите написать программа на Паскале.

ЭльвинаDji 31 дек. 2020 г., 20:42:04 | 5 - 9 классы

Сделайте программу паскаль?

Сделайте программу паскаль.

Porabote78 31 дек. 2020 г., 16:32:13 | 5 - 9 классы

Написать программу нахождение максимального и минимального значения массива?

Написать программу нахождение максимального и минимального значения массива.

Программу нужно сделать в Паскаль.

ПРОШУ ПОМОГИТЕ.

Вопрос Паскаль?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.