Дана последовательность натуральных чисел, окончанием последовательности число 0?

Информатика | 1 - 4 классы

Дана последовательность натуральных чисел, окончанием последовательности число 0.

Составить программу , котрая вычисляет сумму и среднее арифмитическое чисел кратных 3.

Ответить на вопрос
Ответы (1)
Mama12345678910 16 мар. 2020 г., 06:52:50

Var

x, s, n : integer ;

sr : real ;

begin

repeat

readln(x) ;

if (x mod 3 = 0) and (x> ; 0) then

begin

s : = s + x ;

n : = n + 1 ;

end ;

until x = 0 ;

sr : = s / n ;

writeln(sr) ;

end.

BelaGaGi 28 апр. 2020 г., 22:11:37 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6?

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел, кратных 6.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число кратное 6.

Кол - во чисел не превышает 100.

Введённые числа не привышают 300.

Программа должна ввести одно число - сумму чисел кратных 6.

Xaqi01 13 дек. 2020 г., 13:06:57 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0?

Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000.

Введенные числа не превышают 30000.

Программа должна вывести одно число : сумму всех чисел, кратных 7 и оканчивающихся на 0.

Программу надо написать в Pascal.

Делька2001год 19 нояб. 2020 г., 19:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

Rewmos 1 апр. 2020 г., 02:12:20 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

13343 18 февр. 2020 г., 06:04:01 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

Yulai 14 окт. 2020 г., 20:21:05 | 5 - 9 классы

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3?

ПОМОГИТЕ, ПОЖАЛУЙСТА, НАПИСАТЬ ПРОГРАММУ Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число – сумму чисел, кратных 3.

Миха7979 3 июн. 2020 г., 18:28:25 | 5 - 9 классы

Напишите программу пожалуйста В последовательности натуральных чисел определить сумму чисел кратных 5?

Напишите программу пожалуйста В последовательности натуральных чисел определить сумму чисел кратных 5.

Zinovevayulia19 12 апр. 2020 г., 02:42:10 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных 6?

Напишите программу которая в последовательности натуральных чисел определяет сумму чисел кратных 6.

Программа получает на вход количество чисел в последовательности а затем сами числа.

В последовательности всегда имеется число кратное 6.

Количество чисел не превышает 100.

Введенные числа не превышают 300.

Программа должна вывести одно число - сумму чисел кратных 6.

Решите пожалуйста.

SuperKayne 22 апр. 2020 г., 01:45:06 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 0?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 0.

Программа получает на вход натуральные числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Gaganovaga 4 дек. 2020 г., 10:49:58 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю.

Программа получает на вход целые числа, колличество введнных чисел неизвестно, последовательность чисел заканчиваеться числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30 000.

Программа должна вывести : количество четных чисел, кратных 9, их сумму и среднее значение по модулю.

Вы открыли страницу вопроса Дана последовательность натуральных чисел, окончанием последовательности число 0?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 1 - 4 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.