Дано трехзначное число?

Информатика | 10 - 11 классы

Дано трехзначное число.

Найдите произведение его цифр.

Использовать оператор условия или цикла запрещено.

Ответить на вопрос
Ответы (2)
Erani05062005 25 дек. 2020 г., 06:32:49

Var a, a1, a2, a3 : integer ;

begin

read(a) ;

a1 : = a div 100 ;

a2 : = (a div 10) mod 10 ;

a3 : = a mod 10 ;

writeln(a1 * a2 * a3) ;

end.

Zaval1951 25 дек. 2020 г., 06:32:53

Незнаю, можеттак :

вводх

S = х mod 10

х = х div 10

S = S * x mod 10

x = x div 10

S = S * x

или воттакскорее, вернеекороче :

ввод x

S = x mod 10 * (x div 10) mod 10 * ((x div10) div10) mod 10

вывод S

div 10 - делим число на 10 и берем целую часть (то что перед запятой, например 25 / 10 = 2, 5, ответ 2)

mod 10 - делим число на 10 и берем остаток (то что после запятой, например 23 / 10 = 2, 3, ответ 3).

Safgghh 15 мар. 2020 г., 08:40:40 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить : количество четных цифр в нем.

Составное условие и более одного неполно - го условного оператора не использовать ;

Nadyakotelniko1 18 июн. 2020 г., 11:27:42 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти среднеарифмитическое его цифр и прибавить произведение первой и последней цифры.

Galyabauer201 1 сент. 2020 г., 20:42:33 | 5 - 9 классы

Дано предложение в котором имеются буквы "с" и "т"?

Дано предложение в котором имеются буквы "с" и "т".

Определить, какая из них встречается позже (при просмотре слова слева на право).

Если таких букв несколько, то должны учитываться последние из них.

Оператор цикла с условием не использовать.

ПоЗитИв14 15 нояб. 2020 г., 02:50:59 | 10 - 11 классы

Даны четыре целых числа?

Даны четыре целых числа.

Найти сумму тех из них, которые кратны трем и больше пяти.

Оператор цикла не использовать(На Паскале).

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Sveta270 3 апр. 2020 г., 14:14:23 | 10 - 11 классы

Даны четыре целых числа?

Даны четыре целых числа.

Определить сумму тех из них, которые кратны трем.

Оператор цикла не использовать.

В паскале.

Пожалуйста, даю 20 балов.

Vladik310800 5 янв. 2020 г., 14:22:54 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найдите сумму его цифр.

10061996c 19 мая 2020 г., 02:15:28 | 10 - 11 классы

For (i = 0 ; i< ; n ; i + + ) - это : оператор цикла с предусловием оператор цикла с заданным числом повторений оператор цикла с постусловием оператор - переключатель?

For (i = 0 ; i< ; n ; i + + ) - это : оператор цикла с предусловием оператор цикла с заданным числом повторений оператор цикла с постусловием оператор - переключатель.

Sheglica 29 нояб. 2020 г., 19:36:53 | 1 - 4 классы

Составить программу, решающую следующую задачу : Дано трехзначное число?

Составить программу, решающую следующую задачу : Дано трехзначное число.

Найти произведение его первой и второй цифры.

Deaththekid666 7 дек. 2020 г., 21:11:03 | 5 - 9 классы

Помогите пожалуйста найти решение в с + + :Дано натуральное число?

Помогите пожалуйста найти решение в с + + :

Дано натуральное число.

Определить :

а) Количество четных цифр в нем .

Составное условие и более одного неполного условного оператора не использовать.

;

б)сколько раз в нем встречаются цифры 0 и 5(всего) ;

Вопрос Дано трехзначное число?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.