Задача : Факториал числа представляет собой произведение всех натуральных чисел от 1 до этого числа включительно?

Информатика | 10 - 11 классы

Задача : Факториал числа представляет собой произведение всех натуральных чисел от 1 до этого числа включительно.

Например, факториал числа 7 выглядит так :

1 * 2 * 3 * 4 * 5 * 6 * 7

Факториал числа обозначается как само число после которого следует восклицательный знак.

Например, 7.

Таким образом :

7!

= 1 * 2 * 3 * 4 * 5 * 6 * 7 = 5040

Требуется определить факториал числа, которое ввел пользователь.

Ответить на вопрос
Ответы (1)
Алиночка688 30 авг. 2020 г., 06:06:35

1)readln(n) ;

if (n = 0) then writeln('0!

= 1') else

if (n< ; 0) then writeln('Определяется только для положительных чисел') else

begin

s : = 1 ;

for i : = 1 to n do

s : = s * i ;

writeln(n, '!

= 's : 0 : 0) ;

end ;

2)function f(x : byte) : real ;

begin

if x = 0 then f : = 1

else f : = f(x - 1) * x ;

end ; 2

с помощью рекурсии, как видно.

SerjAxis 27 янв. 2020 г., 21:02:40 | 5 - 9 классы

Составить программу, вычисляющую факториал числа N с циклом "до"?

Составить программу, вычисляющую факториал числа N с циклом "до".

Nastyaepta 10 нояб. 2020 г., 01:33:15 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ?

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N !

= 1·2·{.

}· N .

Входные данные Входная строка содержит одно натуральное число N .

Выходные данные Программа должна вывести одно число – факториал введённого числа N .

Mihailpolozov 7 дек. 2020 г., 17:00:44 | 10 - 11 классы

Разработать алгоритм программы, которая вычисляет факториал введённого с клавиатуры числа?

Разработать алгоритм программы, которая вычисляет факториал введённого с клавиатуры числа.

Факториалом числа n называется произведение целых чисел от 1 до n.

Например, факториал 1 равен 1, 8!

= 1∙2∙3∙4∙5∙6∙7∙8 = 40320.

Нужна блок схема (Цикл с предусловием).

37360004672 17 мар. 2020 г., 06:38:33 | 10 - 11 классы

Найти факториал числа n тремя способами (через три разных цикла)?

Найти факториал числа n тремя способами (через три разных цикла).

Ana17 1 февр. 2020 г., 15:53:44 | 5 - 9 классы

Составить программу вычисления факториала числа N?

Составить программу вычисления факториала числа N.

Напишите на С + +.

Akbar2003 29 мар. 2020 г., 06:10:37 | 10 - 11 классы

Составить и зафиксировать в форме блок - схемы алгоритм вычисления факториала числа?

Составить и зафиксировать в форме блок - схемы алгоритм вычисления факториала числа.

Nuka83 27 июн. 2020 г., 22:23:57 | 5 - 9 классы

Не знаю, как написать, очень важно сделать эту задачу?

Не знаю, как написать, очень важно сделать эту задачу.

Помогите, пожалуйста.

Напишите программу, вычисляющую факториал числа.

Факториал числа n (обозначается n!

) - произведение всех натуральных чисел от 1 до n включительно.

Например, 5!

= 1 * 2 * 3 * 4 * 5 = 120.

Mvg75 1 сент. 2020 г., 22:44:47 | 5 - 9 классы

Используя MS Excel, вычислить факториал числа 5?

Используя MS Excel, вычислить факториал числа 5.

Jjj2002 22 сент. 2020 г., 21:06:53 | 5 - 9 классы

Реализуйте рекурсивную функцию вычисления факториала натурального числа?

Реализуйте рекурсивную функцию вычисления факториала натурального числа.

Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему.

К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.

Формат входных данных На вход ваша программа получает одно число — n (1≤n≤8)(1≤n≤8).

Формат выходных данных Выведите одно число — факториал числа n.

Zhansaya20031 11 дек. 2020 г., 19:14:02 | 10 - 11 классы

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал?

Напишите программу которая вводит с клавиатуры натуральное число n и определяет его факториал.

На этой странице находится ответ на вопрос Задача : Факториал числа представляет собой произведение всех натуральных чисел от 1 до этого числа включительно?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.