Дано 2 треугольника?

Информатика | 10 - 11 классы

Дано 2 треугольника.

Координаты вершин с клавиатуры В программе должно быть первая процедура, вторая функция.

В процедуре должно считать стороны треугольников(по формуле нахождение сторон через координаты), всё это должно быть выражено через одну переменную!

(не знаю в цикле это как то чтоб через одну переменную и по двум точкам находить все стороны треугольников) в функции периметры треугольников.

В программе сумму периметров.

Помогите плиз.

Ответить на вопрос
Ответы (2)
МАшшА 9 июл. 2020 г., 07:54:30

Var p : real ; a1, b1, c1 : real ; a2, b2, c2 : real ;

function SideLength(a1, a2, b1, b2 : real) : real ;

begin SideLength : = sqrt(sqr(a1 - b1) + sqr(a2 - b2)) ;

end ;

function Perimeter(a1, a2, b1, b2, c1, c2 : real) : real ;

var a, b, c : real ;

begin a : = SideLength(a1, a2, b1, b2) ; b : = SideLength(c1, c2, b1, b2) ; c : = SideLength(a1, a2, c1, c2) ; Perimeter : = a + b + c ;

end ;

begin writeln('Первый треугольник.

') ; readln(a1, a2, b1, b2, c1, c2) ; p : = Perimeter(a1, a2, b1, b2, c1, c2) ; writeln('Второй треугольник.

') ; readln(a1, a2, b1, b2, c1, c2) ; writeln(p + Perimeter(a1, a2, b1, b2, c1, c2)) ;

end.

Gulinaea 9 июл. 2020 г., 07:54:32

Конечно, так нормальные люди не пишут, но это ради выполнения корявых требований процедуры и функции.

/ / PascalABC.

NET 3.

1, сборка 1239 от 08.

05. 2016

type Point = record x, y : real end ;

function Len(A, B : Point) : = sqrt(sqr(B.

X - A.

X) + sqr(B.

Y - A.

Y)) ;

procedure Sides(A, B, C : Point ; var la, lb, lc : real) ;

begin la : = Len(B, C) ; lb : = Len(A, C) ; lc : = Len(A, B)

end ;

function Perim(a, b, c : real) : = a + b + c ;

begin var a, b, c : Point ; var l1, l2, l3 : real ; for var i : = 1 to 2 do begin Writeln('Вводите парами координаты каждой вершины треугольника ; ') ; Read(a.

X, a.

Y, b.

X, b.

Y, c.

X, c.

Y) ; Sides(a, b, c, l1, l2, l3) ; Writeln('Периметр треугольника ', Perim(l1, l2, l3)) end

end.

AHDPOID69 9 авг. 2020 г., 23:14:28 | 5 - 9 классы

Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный?

Напишите программу на языке Паскаль, распознающую по длинам сторон среди всех треугольников прямоугольный.

Если они прямоугольные, то должно выводится сообщение 'Это прямоугольный треугольник'.

Destrik125 8 июн. 2020 г., 06:48:14 | 10 - 11 классы

Сколько существует невырожденных треугольников периметра с целыми длинами сторон Треугольник со сторонами называется невырожденным если из отрезков длины его можно составитьВходные данные С клавиатуры?

Сколько существует невырожденных треугольников периметра с целыми длинами сторон Треугольник со сторонами называется невырожденным если из отрезков длины его можно составить

Входные данные С клавиатуры вводится число

Выходные данные Программа выводит число таких треугольников.

Рассказученика 20 авг. 2020 г., 07:24:36 | 5 - 9 классы

Даны длины а, в, с сторон некоторого треугольника?

Даны длины а, в, с сторон некоторого треугольника.

Найти медианы треугольника, сторонами которого являются медианы исходного треугольника.

PASCAL ABC Нужно написать программу, используя процедуру(ы) и функцию(ы).

Пожалуйста, помогите!

: ).

Misssukhodoeva 29 нояб. 2020 г., 12:10:28 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ В QBASIC?

ПОМОГИТЕ ПОЖАЛУЙСТА НАПИСАТЬ ПРОГРАММУ В QBASIC!

Периметр треугольника равен Р, длина одной стороны равна А, другой - В.

Найти длину третьей стороны.

Tihsunka 13 июл. 2020 г., 00:56:47 | 10 - 11 классы

Составить программу на паскале?

Составить программу на паскале.

Даны стороны двух треугольников.

Найти сумму их периметров и сумму площадей.

Определить процедуру для расчета периметра и площади треугольника по его сторонам.

Persik19 6 дек. 2020 г., 04:23:36 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Заранее, спасибо) напишите функцию, вычисляющую длину отрезка по координатам его концов.

С помощью этой функции напишите программу, вычисляющую периметр треугольника по координатам его вершин.

AnuaLogan 22 авг. 2020 г., 01:03:08 | 5 - 9 классы

ПАСКАЛЬПризнак существования треугольника : каждая его сторона должна быть меньше суммы двух других?

ПАСКАЛЬ

Признак существования треугольника : каждая его сторона должна быть меньше суммы двух других.

Написать программу, которая, получив с клавиатуры значения сторон треугольника a, b, c, ответит, можно ли построить такой треугольник жили нет.

Byblik64 12 сент. 2020 г., 16:33:19 | 5 - 9 классы

Написать программу нахождения периметра треугольника?

Написать программу нахождения периметра треугольника.

Значения сторон a = 2, b = 7, c = 4.

Zhansaya2004 27 авг. 2020 г., 20:50:11 | 10 - 11 классы

Составить программу на паскале?

Составить программу на паскале.

Заданы длины сторон трех треугольников.

Найти больший периметр.

Для вычисления периметра треугольника используйте процедуру Perimetr, для определения большего из 2 чисел - процедура max.

Valigadzhiev 16 дек. 2020 г., 14:29:14 | 5 - 9 классы

Составьте программу вычислите периметр треугольника со сторонами а, в, с?

Составьте программу вычислите периметр треугольника со сторонами а, в, с.

Вопрос Дано 2 треугольника?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.