Полное Решение пожалуйста?

Информатика | 5 - 9 классы

Полное Решение пожалуйста!

Задан массив из 7 целых чисел.

Заменить все положительные элементы данного массива на его максимальный элемент?

Ответить на вопрос
Ответы (1)
Anter22 19 мар. 2020 г., 19:15:21

Const n = 7 ;

var a : array[1.

N]of integer ; max, i : integer ;

begin / / Заполнение массива значениями в диапазоне / / от - 100 до 100 / / и одновременно находим максимальный элемент max : = - 100 ; for i : = 1 to n do begin a[i] : = random(201) - 100 ; if a[i]> ; max then max : = a[i] ; write(a[i] : 3) ; end ; writeln ; / / В цикле находим положительные и / / меняем их на максимальный элемент for i : = 1 to n do begin if a[i]> ; 0 then a[i] : = max ; write(a[i] : 3) ; end ; writeln ;

end.

Qleb 12 июн. 2020 г., 21:57:19 | 5 - 9 классы

Дан массив состоящий из 30 элементов?

Дан массив состоящий из 30 элементов.

Найти в массиве максимальный элемент, вывести его значение и номер на экран.

Отрицательный элемент массива заменить на равные по модулю положительные элементы.

Grooooyl 2 сент. 2020 г., 04:57:55 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Замените все положительные элементы данного массива его максимальным элементом.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Sahasur 13 сент. 2020 г., 00:34:00 | 10 - 11 классы

В одномерном массиве А, состоящем из 12 целых чисел, все положительные элементы заменить пятеркой?

В одномерном массиве А, состоящем из 12 целых чисел, все положительные элементы заменить пятеркой.

Kristina1009 9 дек. 2020 г., 11:37:10 | 5 - 9 классы

Задан массив из 7 целых чисел?

Задан массив из 7 целых чисел.

Заменить все положительные элементы данного массива на его максимальный элемент.

DianaKrav4enko 28 июл. 2020 г., 10:32:45 | 10 - 11 классы

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти ?

Дан массив целых чисел (n = 25), заполненный случайным образом числами из промежутка [ - 10, 50] : 1) заменить максимальный элемент массива на среднее арифметическое значение этого массива ; 2) найти сумму положительных элементов, кратных 7.

ZxDenxz225 4 февр. 2020 г., 10:24:08 | 10 - 11 классы

Дан массив целых чисел из 17 элементов?

Дан массив целых чисел из 17 элементов.

Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Ellinka21 21 мар. 2020 г., 23:25:03 | 10 - 11 классы

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные ум?

Дан числовой массив А состоящий из n элементов если отношение числа положительных элементов к числу отрицательных более 2, то все отрицательные элементы этого массива замените на 1, а положительные умножьте на максимальный элемент.

213rfe 2 сент. 2020 г., 15:06:18 | 5 - 9 классы

Решить в с + +задан массив Z(n) целых чисел?

Решить в с + +

задан массив Z(n) целых чисел.

Найти максимальный элемент массива и если это простое число - удалить все элементы равные максимальному значению.

Определить среднее арифметическое положительных элементов массива после удаления.

Упорядочить массив по убыванию модулей.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Полное Решение пожалуйста?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.