Язык PASCAL ABC Дано 50 чисел?

Информатика | 10 - 11 классы

Язык PASCAL ABC Дано 50 чисел.

Вычислить наибольшее из них.

Ответить на вопрос
Ответы (1)
Tofanich 31 дек. 2020 г., 21:58:50

Вариант №1 / / PascalABC.

NET (версия 3.

1, сборка 1210 от 29.

03. 2016)

begin / / Для теста заполним массив сл.

Числами var a : = arrrandom(50) ; a.

Println ; println('Максимальное значение', a.

Max) ;

end.

Тестовое решение :

25 78 95 85 97 57 77 49 58 26 36 57 74 24 19 94 66 33 32 43 32 7 64 24 11 2 60 45 6 40 31 19 40 53 80 67 18 26 39 23 53 63 26 18 84 11 11 72 19 79

Максимальное значение 97

Вариант №2 (с циклом for и заполнением массива с клавиатуры) / / PascalABC.

NET (версия 3.

1, сборка 1210 от 29.

03. 2016)

const n = 50 ;

var a : array[1.

N]of integer ; i, max : integer ;

begin max : = - MaxInt ; for i : = 1 to n do begin writeln('Введите ', i, ' число ') ; readln(a[i]) ; if a[i] > ; max then max : = a[i] ; end ; writeln('Максимальное ', max) ;

end.

Мир71 19 окт. 2020 г., 19:03:41 | 5 - 9 классы

Pascal ABCДаны действительные числа x, y и zвычислить max(x + y + z, xyx)?

Pascal ABC

Даны действительные числа x, y и z

вычислить max(x + y + z, xyx).

Varvaravolegova 20 мар. 2020 г., 11:10:06 | 10 - 11 классы

Pascal ABCВычислить сумму квадратов отрицательных чисел, стоящих на местах, кратных 3 ; подсчитать количество чисел, не принадлежащих промежутку [А, В)?

Pascal ABC

Вычислить сумму квадратов отрицательных чисел, стоящих на местах, кратных 3 ; подсчитать количество чисел, не принадлежащих промежутку [А, В).

Romni441r 13 февр. 2020 г., 01:10:25 | 10 - 11 классы

Минимальное число в последовательности положительных чисел?

Минимальное число в последовательности положительных чисел.

Pascal ABC.

Virus1420 1 окт. 2020 г., 07:10:54 | 5 - 9 классы

Вычислите сумму данных N натуральных чисел?

Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

В Pascal ABC.

Eslandaadiyeva 17 мая 2020 г., 17:19:06 | 5 - 9 классы

Нужно составить программу в Pascal ABC с использованием цикла?

Нужно составить программу в Pascal ABC с использованием цикла.

Условие : Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

Skripachevv 6 июн. 2020 г., 05:12:04 | 10 - 11 классы

Найдите квадрат наибольшего из чисел a b введите результат сравнения на экран pascal abc?

Найдите квадрат наибольшего из чисел a b введите результат сравнения на экран pascal abc.

Serega007ok 15 мар. 2020 г., 16:58:44 | 5 - 9 классы

Площадь трапеции на языке ABC pascal?

Площадь трапеции на языке ABC pascal.

Hikkishima 25 сент. 2020 г., 17:35:36 | 5 - 9 классы

Pascal?

Pascal.

ABC Дано случайное количество чисел, узнать сколько совершенных чисел в этом ряду (написать программу).

Timi 25 мар. 2020 г., 02:44:19 | 10 - 11 классы

Дано натуральное число N ?

Дано натуральное число N .

Определить наименьшую и наибольшую цифры данного числа (Pascal ABC).

Sakura2512 4 окт. 2020 г., 21:05:15 | 5 - 9 классы

Решить задачу на программирование в abc Pascal?

Решить задачу на программирование в abc Pascal.

Дано n чисел.

Найти сумму отрицательных чисел кратных 4.

(x от - 30000 до + 30000).

На этой странице находится вопрос Язык PASCAL ABC Дано 50 чисел?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.