Найти кол - во отрицательных чисел этого массива const n = 15 ; var a : array[1?

Информатика | 10 - 11 классы

Найти кол - во отрицательных чисел этого массива const n = 15 ; var a : array[1.

N] of integer ; i, k : integer ; begin randomize ; k : = ; for i : = 1 to n do a[i] : = random(51) - 25 ; for i : = 1 to n do write(a[i] : 4) ; writeln ; for i : = 1 to n do if a[i] then k : = ; writeln('кол - во отрицательных : ', ) ; end.

Ответить на вопрос
Ответы (1)
Amina1987729 25 янв. 2020 г., 11:51:01

For i : = 1 to n do

begin if a[i]< ; 0 then begin k = k + 1 ; end ;

end ;

writeln('кол - во отрицательных : ', k) ;

Komarik21 24 июл. 2020 г., 19:43:53 | 10 - 11 классы

Где ошибка?

Где ошибка?

Const n = 10 ; type TMas = array[1.

N] of integer ; var mas1 : TMas ; procedure ImputMas1(var masTMas : integer) ; var i : integer ; begin for i : = 1 to 10 do begin mas1[i] : = random(n) ; Write(mas1[i] : 3) ; end ; end.

Seva2703 2 мар. 2020 г., 23:56:06 | 5 - 9 классы

Составить блок схему со стрелочками к программе : Program name ; const n = 30 ; var a : array [1?

Составить блок схему со стрелочками к программе : Program name ; const n = 30 ; var a : array [1.

N] of integer ; vari, r : integer ; begin for i : = 1 to n do begin a[i] : = random (20) ; write (a[i], ' ') ; end ; r : = 0 ; for i : = 1 to n do if a[i]< ; 10 then r : = r + 1 ; writeln ; writeln ('kolichestvo chisel menshe 10 - ', r) ; end.

Прыгайзайка 17 янв. 2020 г., 13:47:28 | 5 - 9 классы

Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1?

Заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20 ; 40] : Program gh ; var A : array[ 1.

___] of integer ; i : integer ; begin for i : = 1 to __ do begin A[i] : = random(___) + ____ ; write(____) ; end ; end.

Romanmedynskii 28 дек. 2020 г., 19:30:34 | 10 - 11 классы

ПАСКАЛЬ Ошибка : " Нельзя преобразовать тип integer к array [1?

ПАСКАЛЬ Ошибка : " Нельзя преобразовать тип integer к array [1.

40] of integer" var mas : array[1.

40] of integer ; i, max, max1 : integer ; begin max : = 0 ; max1 : = 0 ; For i : = 1 to 40 do begin mas : = random(101) ; write(mas[i] : 4) ; If mas[i]> ; max then max : = mas[i] ; end ; For i : = 1 to 40 do If (mas[i]< ; > ; max) and (mas[i]> ; max1) then max1 : = mas[i] ; writeln ; writeln(max1) ; end.

Sds58 12 дек. 2020 г., 05:55:57 | 10 - 11 классы

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента?

Написать программу для решения следующей задачи : в заданной числовой последовательности найти и вывести на печать номер первого отрицательного элемента.

Если все элементы последовательности неотрицательны, то вывести ноль.

Program lab5_5 ; const n = 10 ; type x = array[1.

N] of integer ; var a : x ; i : integer ; k : integer ; begin for i : = 1 to n do begin a[i] : = - 10 + random (91) ; write (A[i] : 4) end ; writeln ; k : = 0 ; for i : = n downto 1 do if a[i]< ; 0 then begin k : = I end ; if k> ; 0 then writeln (‘Индекс отрицательного элемента = ’, k : 1) else writeln (‘В массиве нет отрицательных элементов’) ; readln ; end.

Как сделать эту программу без random чтоб работало в Pascal ABC?

Kerrigan54 3 авг. 2020 г., 16:55:50 | 10 - 11 классы

Задача по двумерному массиву?

Задача по двумерному массиву.

Создать новый одномерный массив из элементов, стоящих под главной диагональю.

Вот шапочка массива : uses crt ; type mas = array [1.

8, 1.

8] of integer ; var M : mas ; i, j : integer ; begin randomize ; for i : = 1 to 8 do begin for j : = 1 to 8 do begin M[i, j] : = random(190) - 95 ; write(M[i, j] : 4) ; end ; writeln ; end ;

Marta134 18 сент. 2020 г., 05:01:56 | 10 - 11 классы

Program pr ; var mas : array[1?

Program pr ; var mas : array[1.

10] of integer ; i, min, ind : integer ; Begin randomize ; For i : = 1 to 10 do Begin mas[i] : = Random(100) ; write(mas[i], ' ') ; End ; writeln() ; min : = mas[1] ; For i : = 1 to 10 do Begin If (min> ; mas[i]) then End ; write('Минимальный элемент массива : ', min) ; End.

Что не верно?

Вот задача : Дан одномерный массив А длиной N.

Определить, на какой позиции нахо - дится минимальный элемент массива.

Make96th 18 янв. 2020 г., 03:04:39 | 10 - 11 классы

USES Crt ; const N = 10 ; VAR A : array[1?

USES Crt ; const N = 10 ; VAR A : array[1.

N] of integer ; k : integer ; Function FUN : integer ; Var i, M : integer ; Begin writeln('Введите число M = ') ; readln(M) ; k : = 0 ; for i : = 1 to N do if A[i] FUN : = k ; End ; Procedure SOSTMAS ; Var i : integer ; Begin for i : = 1 to N do begin A[i] : = Random(199) - 100 ; write(A[i] : 5) ; end ; Writeln ; end ; BEGIN SOSTMAS ; Writeln(FUN) ; что то неправильно говорят массив.

Oksankataktash 9 нояб. 2020 г., 16:25:18 | 10 - 11 классы

Здравствуйте, что в этом коде на free pascal считает k?

Здравствуйте, что в этом коде на free pascal считает k?

Program SiberiaBoss ; var a : array[1.

100] of integer ; i, k, n : integer ; begin readln(n) ; randomize ; for i : = 1 to n + 1 do begin a[i] : = random(10) ; if a[i] < ; i then k : = k + 1 ; writeln(a[i] : 3) ; end ; writeln('Itogo ', k) ; end.

Эннита 25 дек. 2020 г., 22:31:26 | 10 - 11 классы

Найти максимальный элемент этого массива const n = 20 ; var a : array[1?

Найти максимальный элемент этого массива const n = 20 ; var a : array[1.

N] of integer ; i, max : integer ; begin randomize ; for i : = 1 to n do a[i] : = random(90) + 10 ; for i : = 1 to n do write(a[i] : 4) ; writeln ; for i : = to n do if a[i] then max : = ; writeln('max : ', ) ; end.

Вы находитесь на странице вопроса Найти кол - во отрицательных чисел этого массива const n = 15 ; var a : array[1? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.