Дана строка , содержащее слово, записанное через дефис?

Информатика | 5 - 9 классы

Дана строка , содержащее слово, записанное через дефис.

Написать программу , которая вставляет пробелы перед и после дефиса.

Помогите пожалуйста!

Ответить на вопрос
Ответы (1)
Ахарай 16 июл. 2020 г., 11:17:34

Var s : string ; i : integer ;

begin write('строка : ') ;

readln(s) ; i : = 1 ; while i< ; = length(s) do begin if s[i] = ' - ' then begin s : = copy(s, 1, i - 1) + ' ' + s[i] + ' ' + copy(s, i + 1, length(s) - i + 3) ; i : = i + 2 ; end ; i : = i + 1 ; end ; writeln('новая строка : ', s) ;

end.

Dimaivanov20031 16 дек. 2020 г., 14:05:39 | 10 - 11 классы

Программа : pascal abc?

Программа : pascal abc.

Задание : дана строка, написать программу, вставляющую после каждой точки символ пробела.

29asazeh 22 нояб. 2020 г., 15:58:20 | 10 - 11 классы

Дан текст, содержащий запятые?

Дан текст, содержащий запятые.

Написать программу, вставляющую после каждой запятой пробел.

Ирчик103 25 дек. 2020 г., 00:26:59 | 5 - 9 классы

Где ставится пробел?

Где ставится пробел?

А) До знака препинания В) до знака дефис.

Джаредуэй26 20 сент. 2020 г., 22:19:05 | 10 - 11 классы

Дан текст?

Дан текст.

Написать программу, вставляющую после каждой запятой по одному пробелу.

Идиото 4 апр. 2020 г., 08:03:45 | 10 - 11 классы

1. С клавиатуры вводится слово, распечатать все его буквы через пробел?

1. С клавиатуры вводится слово, распечатать все его буквы через пробел.

(после последней буквы пробела быть не должно).

2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

23lomakindmdo 23 сент. 2020 г., 01:42:42 | 10 - 11 классы

СРОЧНО Дана строка, содержащая два слова, разделенных знаком нижнее подчеркивание?

СРОЧНО Дана строка, содержащая два слова, разделенных знаком нижнее подчеркивание.

Написать программу, меняющую нижнее подчеркивание на запятую и вставляющую поле запятой пробел, решить в паскале.

Obuhancova 29 янв. 2020 г., 13:51:14 | 10 - 11 классы

Дана символьная строка, содержащая русские буквы, цифры и пробелы?

Дана символьная строка, содержащая русские буквы, цифры и пробелы.

Написать строку задом наперед, удалив из нее все цифры и пробелы.

Ilanovu3839sik 12 сент. 2020 г., 10:47:01 | 5 - 9 классы

Написать программу, которая выводит на экран 40 раз слово 'Хорошист' в строку через пробел?

Написать программу, которая выводит на экран 40 раз слово 'Хорошист' в строку через пробел.

GeeN 5 мая 2020 г., 06:45:41 | 10 - 11 классы

С + + Написать программу, которая проверяет, является ли квадратная матрица симметричной относительно главной диагонали?

С + + Написать программу, которая проверяет, является ли квадратная матрица симметричной относительно главной диагонали.

Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) ( 1 ≤ N ≤ 100 ).

В следующих N строках записаны строки матрицы, в каждой – по N натуральных чисел, разделённых пробелами.

Выходные данные Программа должна вывести слово 'YES', если матрица симметричная, и слово 'NO', если матрица несимметричная.

Помогите пожалуйста.

На этой странице находится вопрос Дана строка , содержащее слово, записанное через дефис?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.