Каждые выходные к Васе приходят друзья, чтобы поиграть в карты?

Информатика | 10 - 11 классы

Каждые выходные к Васе приходят друзья, чтобы поиграть в карты.

Для полноценной игры число карт в коллоде должно быть кратное количеству игроков.

У Васи есть колода из N карт.

Он решил, что для каждой новой игры он будет выбирать такое количество карт, которым не играли ранее.

В карты они играют либо в своем, либо втроём.

Помогите Васе подсчитать, какое число игр можно будет сыграть ?

Той колодой.

ФОРМАТ ВХОДНЫХ ДАННЫХ.

Задано целое число N (1 меньше или равно N меньше или равно 10 ^ 9) - количество карт в колоде.

ФОРМАТ ВЫХОДНЫХ ДАННЫХ Введите, какое число игр можно будет сыграть этой колодой Пример Input.

Txt Output.

Txt 5 3 6.

4.

Ответить на вопрос
Ответы (1)
Натаниэлька 13 февр. 2020 г., 01:50:16

Program gt ;

var n, s : longint ;

begin

readln(n) ;

s : = n div 2 + n div 3 ;

writeln(s) ;

end.

Timuk 18 мар. 2020 г., 02:36:49 | 10 - 11 классы

На столе лежит колода, состоящая из 36 карт, какое количество информации вы получили, вынув одну из них?

На столе лежит колода, состоящая из 36 карт, какое количество информации вы получили, вынув одну из них?

Milasmal 5 окт. 2020 г., 00:26:56 | 10 - 11 классы

Происходит выбор одной карты из колоды в 32 карты?

Происходит выбор одной карты из колоды в 32 карты.

Какое количество информации.

Мы получаем в зрительном Сообщение О выборе определенной карты.

Statuetka1 5 дек. 2020 г., 13:56:44 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

1. Какое количество информации несёт в себе сообщение о том, что нужная вам программа находится на одной из восьми дискет?

2. Происходит выбор одной карты из колоды в 32 карты.

А) Какое количество информации мы получим в зрительном сообщении о выборе определённой карты?

Б) Сколько информации несёт сообщение о том, что из колоды карт достали карту красной масти?

В) Сколько информации несёт сообщение и том, что из колоды достали карту бубновой масти?

World200 10 окт. 2020 г., 17:15:32 | 5 - 9 классы

Какое количество информации содержит сообщение о том, что из колоды в 32 карты достали даму треф и короля пик?

Какое количество информации содержит сообщение о том, что из колоды в 32 карты достали даму треф и короля пик?

Решить задачу для двух случаев : Карты достаются одновременно Карты достаются по очереди.

Koaredi1973 2 сент. 2020 г., 08:03:55 | 10 - 11 классы

В колоде содержится 48 карт?

В колоде содержится 48 карт.

Из колоды случайным образом вытянули карту.

Сколько информации несет сообщение о том, что вытянутая карта - туз?

AppStore123 2 авг. 2020 г., 19:55:14 | 10 - 11 классы

Какое количество бит информации несет сообщение о том что из колоды вытащена одна из 32 карт?

Какое количество бит информации несет сообщение о том что из колоды вытащена одна из 32 карт.

Alinasuper368 24 сент. 2020 г., 20:29:54 | 10 - 11 классы

В колоде 36 карт?

В колоде 36 карт.

Какова вероятность вынуть шестерку, либо восьмерку, либо десятку?

Belashov97 2 янв. 2020 г., 07:43:08 | 5 - 9 классы

Происходит выбор одной карты из колоды в 32 карты?

Происходит выбор одной карты из колоды в 32 карты.

Какое количество информации мы получаем в зрительном сообщение о выборе определенной карты?

Shmalkoalya 28 февр. 2020 г., 01:25:39 | 10 - 11 классы

ТреугольникВычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат?

Треугольник

Вычислите, в какой координатной четверти расположен треугольник, образованный прямой, заданной уравнением y = ax + b, и осями координат.

Числа a и b такие, что треугольник всегда существует.

Формат входных данных :

входной файл INPUT.

TXT содержит заданные целые числа a и b ( - 100£a, b£100)

Формат выходных данных :

Выходной файл OUTPUT.

TXT должен содержать номер четверти.

Пример

Input.

Txt

Output.

Txt

423 402 2.

Marika982 21 окт. 2020 г., 20:54:07 | 10 - 11 классы

В колоде 36 карт?

В колоде 36 карт.

Сколько информации содержится в сообщении о том, какие 3 карты вытащены?

На этой странице сайта вы найдете ответы на вопрос Каждые выходные к Васе приходят друзья, чтобы поиграть в карты?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.