Дан числовой массив А, состоящий из n натуральных чисел?

Информатика | 1 - 4 классы

Дан числовой массив А, состоящий из n натуральных чисел.

Определите количество элементов массива, которые при делении на 7 дают остаток 1, 2 или 5.

Ответить на вопрос
Ответы (1)
Nsz1003 10 авг. 2020 г., 11:46:29

Const

N = 7 ;

Var

A : array[1.

N] of integer ;

i, j : integer ;

Begin

j : = 0 ;

WriteLn('Введи массив A(N)') ;

For i : = 1 to N do

Begin

Read(A[i]) ;

if (A[i] mod 7 = 1)or(A[i] mod 7 = 2)or(A[i] mod 7 = 5) then j : = j + 1

End ;

WriteLn(j)

End.

Ariname 14 мая 2020 г., 07:02:43 | 5 - 9 классы

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива?

1. Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел, найти количество отрицательных элементов массива.

3. Дан массив целых чисел, найти количество чётных чисел в массиве.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

Darveen 19 янв. 2020 г., 21:00:01 | 5 - 9 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего).

Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные Сначала задано число N — количество элементов в массиве (1N100).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры Входные данные 5 1 1 1 1 1 Выходные данные 1.

Ангелина2003ангел 8 янв. 2020 г., 15:03:48 | 5 - 9 классы

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9?

Дан одномерный массив целых чисел состоящий из 22 двух элементов посчитать количество отрицательных элементов массива, а так же количество элементов которые делятся на 9.

Помогите отредактировать программу.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

SarymovaKaramelya 4 июл. 2020 г., 23:23:18 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

Lenor35 9 февр. 2020 г., 00:16:55 | 5 - 9 классы

Задан числовой массив, состоящий из 15 элементов?

Задан числовой массив, состоящий из 15 элементов.

Подсчитать и вывести на экран количество элементов в массиве, которые меньше его первого элемента.

ZxDenxz225 4 февр. 2020 г., 10:24:08 | 10 - 11 классы

Дан массив целых чисел из 17 элементов?

Дан массив целых чисел из 17 элементов.

Определить частное от деления суммы положительных элементов массива на модуль суммы отрицательных элементов.

Никита1258 25 июн. 2020 г., 08:39:40 | 5 - 9 классы

Задан числовой массив, состоящий из 15 элементов?

Задан числовой массив, состоящий из 15 элементов.

Подсчитать и вывести на экран количество элементов в массиве, которые меньше его первого элемента.

Izgaraeva 22 нояб. 2020 г., 06:16:43 | 10 - 11 классы

Дан массив, состоящий из целых чисел?

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитывает количество положительных чисел среди элементов массива.

Входные данные Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные Необходимо единственное число - количество положительных элементов в массиве.

Java.

Вы открыли страницу вопроса Дан числовой массив А, состоящий из n натуральных чисел?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 1 - 4 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.