Помогите, пожалуйста, по Паскалю?

Информатика | 5 - 9 классы

Помогите, пожалуйста, по Паскалю!

21. В компьютер вводятся два числа.

Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков.

Компьютер должен ответить на вопрос, правда ли, что пер - вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник.

Указание : Для этого его длина должна быть меньше суммы длин двух других отрезков.

Замечание : Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки.

Об этом – задание из 5.

5.

Ответить на вопрос
Ответы (1)
Аннетик 19 февр. 2020 г., 02:44:37

Program Pr1 ;

uses crt ;

var a, b, c : integer ;

Begin

writeln('a, b') ;

readln(a, b) ;

if a> ; b then c : = a + b

else c : = a * b ;

writeln('Задача Решена') ;

end.

2)

Program Pr1 ;

uses crt ;

var a, b, c : integer ;

Begin

writeln('a, b, c') ;

readln(a, b, c) ;

if a< ; b + c then writeln('не длинный')

else writeln('Длинный') ;

end.

Bigskill 30 нояб. 2020 г., 04:23:05 | 5 - 9 классы

Помогите решииить?

Помогите решииить!

СРОЧНОО!

По введенным с клавиатуры длинам трех отрезков определить : можно ли из них составить треугольник?

Варвара012 22 мар. 2020 г., 07:32:14 | 10 - 11 классы

Прием (ввод) информации у компьютера?

Прием (ввод) информации у компьютера.

Destrik125 8 июн. 2020 г., 06:48:14 | 10 - 11 классы

Сколько существует невырожденных треугольников периметра с целыми длинами сторон Треугольник со сторонами называется невырожденным если из отрезков длины его можно составитьВходные данные С клавиатуры?

Сколько существует невырожденных треугольников периметра с целыми длинами сторон Треугольник со сторонами называется невырожденным если из отрезков длины его можно составить

Входные данные С клавиатуры вводится число

Выходные данные Программа выводит число таких треугольников.

Shatilin99 9 апр. 2020 г., 14:02:09 | 5 - 9 классы

Написать программу в паскале : Имеется кусок ткани длинной M метров?

Написать программу в паскале : Имеется кусок ткани длинной M метров.

От него последовательно отрезаются куски равной длины.

Все данные по использованию ткани заносятся в компьютер.

Компьютер должен выдать сообщение о том, что материала не хватает, если будет затребован кусок ткани больше длины, чем имеется.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

Baiko71 3 мая 2020 г., 10:17:42 | 5 - 9 классы

Написать программу в паскале ?

Написать программу в паскале .

Вводим два числа.

Компьютер должен вывести квадратное уравнение, корнями которого являются эти два числа.

(использоват теорему виета).

Поодлтим 21 мар. 2020 г., 05:18:17 | 5 - 9 классы

Информатика 9 класс?

Информатика 9 класс.

(Задачи по Паскалю) В компьютер вводится 2 числа.

Если они не равны, то вычислить их произведение, иначе каждое число уменьшить в 2 раза.

После этого компьютер должен вывести результат и сообщение ЗАДАЧА РЕШЕНА.

Vadimmka72 6 апр. 2020 г., 19:23:48 | 10 - 11 классы

По заданным координатам отрезка АВ вычислить длину?

По заданным координатам отрезка АВ вычислить длину.

Помогите, пожауйста!

Dmdm1 11 февр. 2020 г., 17:49:56 | 1 - 4 классы

Программа принимает 3 числа и печатает да если они могут выражать длины сторон треугольника и нет в противном случаем?

Программа принимает 3 числа и печатает да если они могут выражать длины сторон треугольника и нет в противном случаем.

Подсказка : длина любой стороны треугольника не больше суммы длин двух других сторон.

Sharifov 30 окт. 2020 г., 07:50:05 | 1 - 4 классы

Устройства ввода информации в компьютер?

Устройства ввода информации в компьютер.

На странице вопроса Помогите, пожалуйста, по Паскалю? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.