Ребят, выручайте?

Информатика | 10 - 11 классы

Ребят, выручайте!

Задание по Pascal.

1. В массиве А[N] занесены натуральные числа.

Найти сумму тех элементов, которые кратны данному К.

2. В целочисленной последовательности есть нулевые элементы.

Создать массив из номеров этих элементов.

Ответить на вопрос
Ответы (1)
Lolsha1005 15 нояб. 2020 г., 09:15:03

1. var k, sum, n, i : integer ; A : array of integer ;

begin writeln('Введите размерность массива : ') ; readln(n) ; SetLength(A, n) ; writeln('Введите K : ') ; readln(k) ; writeln('Введите ', n, ' элементов массива : ') ; for i : = 0 to n - 1 do begin readln(A[i]) ; if A[i] mod k = 0 then sum : = sum + A[i] ; end ; writeln('Результат : ', sum) ;

end.

2. var c, k, n, i : integer ; B, A : array of integer ;

begin k : = 1 ; writeln('Введите размерность массива : ') ; readln(n) ; SetLength(A, n + 1) ; writeln('Введите ', n, ' элементов массива : ') ; for i : = 1 to n do begin readln(A[i]) ; if A[i] = 0 then begin inc(c) ; SetLength(B, c + 1) ; B[k] : = i ; inc(k) end ; end ; writeln('Позиции нулевых элементов : ') ; for i : = 1 to c do write(B[i] : 3) ;

end.

Combo27 24 окт. 2020 г., 15:07:29 | 10 - 11 классы

Сделать одномерный массив?

Сделать одномерный массив.

В массив A[N] занесены натуральные числа.

Найти сумму тех элементов, каторые кратны данному значению К.

Элементы массива вводить с клавиатуры.

Диана200356 19 янв. 2020 г., 19:36:48 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

(паскаль).

25irisha 6 авг. 2020 г., 21:38:45 | 5 - 9 классы

1. Дан массив натуральных чисел?

1. Дан массив натуральных чисел.

Найти сумму элементов кратных данному К.

2. В целочисленной последовательности есть нулевые элементы.

Создать массив из номеров этих элементов.

3. дана последовательность целых чисел а1, а2, .

Аn. Выяснить, какое число встречается раньш положитльно или отрицатльное.

4. Дана последоватльность действительных чисел а1, а2, .

Аn. Выяснить, будет ли она возрастающей.

SarymovaKaramelya 4 июл. 2020 г., 23:23:18 | 5 - 9 классы

Одномерные массивы?

Одномерные массивы.

Дан массив натуральных чисел, состоящий из n элементов.

Найти сумму элементов массива, кратных данному числу К.

Mint2009 19 дек. 2020 г., 18:48:29 | 10 - 11 классы

Дан одномерный массив, состоящий из 20 элементов?

Дан одномерный массив, состоящий из 20 элементов.

Найти сумму элементов массива, принадлежащих промежутку от А до В PASCAL.

Lovednal 29 апр. 2020 г., 02:02:02 | 10 - 11 классы

Pascal, Дан целочисленный массив из 30 элементов?

Pascal, Дан целочисленный массив из 30 элементов.

Как найти сумму элементов после первого положительного?

Kubaeva91 15 мая 2020 г., 21:59:40 | 10 - 11 классы

Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед нулевым элементом данного массива?

Составьте программу вычисления суммы тех элементов одномерного массива А(N), что расположены перед нулевым элементом данного массива.

Викуся200 21 июн. 2020 г., 14:13:49 | 10 - 11 классы

В целочисленной последовательности есть нулевые элементы?

В целочисленной последовательности есть нулевые элементы.

Создать массив из номеров этих элементов.

Язык программирования VBA.

Chernovdanil2 14 мар. 2020 г., 08:27:02 | 10 - 11 классы

Pascal?

Pascal.

Дан массив.

Найти сумму тех элементов , которые расположены до максимального элемента данной последовательности .

Результат сохранить в файл.

Detroid789 16 нояб. 2020 г., 11:26:48 | 5 - 9 классы

Массив из пяти элементов заполняется натуральными числами?

Массив из пяти элементов заполняется натуральными числами.

Составить программу, которая определяет сумму элементов массива, кратных трем и заканчивающихся на 7( программа Pascal).

На этой странице сайта, в категории Информатика размещен ответ на вопрос Ребят, выручайте?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.