Написать программу в Turbo pascal Найти 2 максимума из любой последовательности чисел?

Информатика | 10 - 11 классы

Написать программу в Turbo pascal Найти 2 максимума из любой последовательности чисел.

Ответить на вопрос
Ответы (1)
Марфушачка 2 дек. 2020 г., 16:30:05

Var ar : array[1.

30] of integer ;

i, max, max2, maxp, maxi : integer ;

begin ;

randomize ;

writeln('Array') ;

for i : = 1 to 30 do

begin ;

ar[i] : = random(1, 100) ;

write(ar[i] : 4) ;

end ;

for i : = 1 to 30 do

if max< ; ar[i] then

begin ;

maxp : = max ;

max : = ar[i] ;

maxi : = i ;

end ;

ar[maxi] : = maxp ;

for i : = 1 to 30 do

if max2< ; ar[i] then max2 : = ar[i] ;

writeln ;

writeln('Max1 : ', max) ;

writeln('Max2 : ', max2) ;

end.

Theayanamirin 20 февр. 2020 г., 07:21:49 | 5 - 9 классы

В среде Turbo Pascal написать программу : используя одномерный массив из 10 чисел найти сумму < ; max" и "min" элемента (входной массив вывести на экран)?

В среде Turbo Pascal написать программу : используя одномерный массив из 10 чисел найти сумму < ; max" и "min" элемента (входной массив вывести на экран).

Vovapalchikov 17 янв. 2020 г., 08:51:01 | 10 - 11 классы

Напишите программу(turbo pascal)выводящую на экран кубы чисел от 1 до 20?

Напишите программу(turbo pascal)выводящую на экран кубы чисел от 1 до 20.

Заранее спасибо)).

45прпрпрп 18 окт. 2020 г., 05:51:35 | 5 - 9 классы

Напишите программы в Turbo Pascal?

Напишите программы в Turbo Pascal.

MrSuperFlash 16 нояб. 2020 г., 10:28:48 | 1 - 4 классы

Напишите программу в Turbo Pascal?

Напишите программу в Turbo Pascal.

Спасибо!

Katjulka 24 мар. 2020 г., 07:48:20 | 5 - 9 классы

Напишите пожалуйста программу на Turbo pascal :Найти частное двух целых чисел вводимых с клавиатуры?

Напишите пожалуйста программу на Turbo pascal :

Найти частное двух целых чисел вводимых с клавиатуры.

СМАЙЛИ 24 февр. 2020 г., 20:55:10 | 10 - 11 классы

Написать программу, которая выводит изображенный ниже узор?

Написать программу, которая выводит изображенный ниже узор.

Turbo Pascal.

Kuanov07 29 мар. 2020 г., 15:17:55 | 5 - 9 классы

Написать программу вычисления суммы натуральных чисел от 1 до nTurbo Pascal?

Написать программу вычисления суммы натуральных чисел от 1 до n

Turbo Pascal.

Itrofimoff 1 авг. 2020 г., 03:40:26 | 1 - 4 классы

Структура программы на языке turbo pascal?

Структура программы на языке turbo pascal.

Dimarasher 14 окт. 2020 г., 15:01:02 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Мяусик1 8 нояб. 2020 г., 20:39:47 | 10 - 11 классы

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно?

Написать программу вычисления значений функции в заданных точках (Turbo Pascal) Очень нужно.

Вы перешли к вопросу Написать программу в Turbo pascal Найти 2 максимума из любой последовательности чисел?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.