Выводится на экран последовательность 20 случайных чисел из промежутка [ - 10, 10]?

Информатика | 1 - 4 классы

Выводится на экран последовательность 20 случайных чисел из промежутка [ - 10, 10].

Определить количество отрицательных чисел больших - 5 в данной последовательности.

Ответить на вопрос
Ответы (2)
Aliya82 6 апр. 2020 г., 08:53:52

Если используется Pascal.

ABC, то строку massiv[i] : = random( - 19) + 10 ; нужно заменить на massiv[i] : = random( - 10, 10) ;

const countOfElements = 20 ;

var i, countOfNumbers, randomNumber : integer ; massiv : array[1.

CountOfElements] of integer ;

begin Randomize ; countOfNumbers : = 0 ; for i : = 1 to countOfElements do begin massiv[i] : = random( - 19) + 10 ; if ( (massiv[i] < ; 0) AND (massiv[i] > ; - 5) ) then countOfNumbers + = 1 ; end ; writeln(countOfNumbers) ;

end.

Пазюра 6 апр. 2020 г., 08:53:58

Вроде 5 отрицательных.

NemOsTOOr230 16 дек. 2020 г., 15:30:50 | 10 - 11 классы

Решите задачу в Паскале?

Решите задачу в Паскале.

Если можно с блок - схемой.

Дана последовательность чисел.

Вывести на экран все отрицательные числа.

Cataleshina 16 февр. 2020 г., 00:34:17 | 10 - 11 классы

Создайте программу, которая выводит на экран последовательность пар чисел каждый раз отличительным цветом, выбранным случайным образом?

Создайте программу, которая выводит на экран последовательность пар чисел каждый раз отличительным цветом, выбранным случайным образом.

Заранее большое спасибо!

Я112яя 23 июл. 2020 г., 22:35:13 | 5 - 9 классы

Дана последовательность чисел?

Дана последовательность чисел.

Найти произведение всех четных отрицательных чисел.

Zhenk2011 20 июн. 2020 г., 10:41:16 | 10 - 11 классы

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел?

Напишите программу, запрашивающую у пользователя N целых чисел и выводящую на экран : а) количество нулей в последовательности ; б) количество положительных чисел ; в) количество отрицательных чисел.

( На языке Паскаль С + + ).

Pasha5430246 14 янв. 2020 г., 02:11:12 | 10 - 11 классы

На экран вводится последовательность натуральных чисел, не превышающих 1000?

На экран вводится последовательность натуральных чисел, не превышающих 1000.

Последовательность заканчивается числом 0.

Количество чисел в последовательности не превышает 100.

Выведите на экран количество чисел в последовательности (не считая 0), а потом сами числа.

Chudo9725 26 авг. 2020 г., 16:37:12 | 10 - 11 классы

На экран вводится последовательность натуральных чисел, не превышающих 1000?

На экран вводится последовательность натуральных чисел, не превышающих 1000.

Последовательность заканчивается числом 0.

Количество чисел в последовательности не превышает 100.

Выведите на экран количество чисел в последовательности (не считая 0), а потом сами числа.

Пример ввода : 1 3 5 0.

Zenkova929 24 июл. 2020 г., 13:36:47 | 10 - 11 классы

Pascal?

Pascal.

Дана последовательность чисел .

Вывести на экран суммы положительных и отрицательных чисел данной последовательности.

ZlataFox 23 дек. 2020 г., 17:19:43 | 5 - 9 классы

Дана последовательность из n целых чисел?

Дана последовательность из n целых чисел.

Определить, есть ли в ней число, равное первому из этой последовательности.

Gp1950 21 дек. 2020 г., 04:24:54 | 10 - 11 классы

Дана последовательность целых чисел?

Дана последовательность целых чисел.

Найти количество различных чисел в этой последовательности.

Помогите с блок схемой через цикл while.

AndreyKOdonezk 26 сент. 2020 г., 05:17:08 | 10 - 11 классы

Дана числовая последовательность случайных натуральных чисел не превышающих число 255?

Дана числовая последовательность случайных натуральных чисел не превышающих число 255.

Конец последовательности число ноль.

Проанализировать последовательность и вывести на экран количество, в этой последовательности, нечетных чисел, которые лежат в диапазоне от 1 до 9 включительно.

Это программирование паскаль 8 класс.

На этой странице находится вопрос Выводится на экран последовательность 20 случайных чисел из промежутка [ - 10, 10]?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 1 - 4 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.