На экран вводится последовательность натуральных чисел, не превышающих 1000?

Информатика | 10 - 11 классы

На экран вводится последовательность натуральных чисел, не превышающих 1000.

Последовательность заканчивается числом 0.

Количество чисел в последовательности не превышает 100.

Выведите на экран количество чисел в последовательности (не считая 0), а потом сами числа.

Пример ввода : 1 3 5 0.

Ответить на вопрос
Ответы (1)
WolfiFeeD 26 авг. 2020 г., 16:37:14

Var a : array[1.

100] of integer ;

b, i : integer ;

begin

b : = 0 ;

for i : = 1 to 100 do begin read(a[i]) ;

if a[i]< ; > ; 0 then b : = b + 1 else break ;

end ;

for i : = 1 to b do

write(a[i], ' ') ;

writeln ;

writeln('Количество чисел в последовательности = ', b) ;

end.

Asasin007 8 дек. 2020 г., 18:06:28 | 5 - 9 классы

Программа в Паскале?

Программа в Паскале!

"Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

" Отдал все пункты что есть!

Помогите!

Denchar 2 сент. 2020 г., 21:55:40 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 5.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Паскаль.

Nic1000 22 мая 2020 г., 05:14:03 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, кратное 3.

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести одно число - количество чисел, кратных 3.

Rewmos 1 апр. 2020 г., 02:12:20 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных?

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех четных чисел чисел и количество нечетных.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Pasha5430246 14 янв. 2020 г., 02:11:12 | 10 - 11 классы

На экран вводится последовательность натуральных чисел, не превышающих 1000?

На экран вводится последовательность натуральных чисел, не превышающих 1000.

Последовательность заканчивается числом 0.

Количество чисел в последовательности не превышает 100.

Выведите на экран количество чисел в последовательности (не считая 0), а потом сами числа.

Vut 12 февр. 2020 г., 23:03:03 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4?

Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число : количество трёхзначных чисел, кратных 4.

Напишите программу в паскале пожайлуста.

Никита20022 5 окт. 2020 г., 07:16:23 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO)?

Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO).

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100.

Введённые числа не превышают 300.

Программа должна вывести среднее арифметическое трёхзначных чисел или вывести «NO», если таких чисел нет.

Azatkhairullov 15 дек. 2020 г., 07:32:12 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет количество трехзначных чисел, кратных 7?

Напишите программу, которая в последовательности целых чисел определяет количество трехзначных чисел, кратных 7.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Про - грамма должна вывести одно число : количество трехзначных чисел, кратных 7.

Ewgeni199 8 июл. 2020 г., 07:09:51 | 1 - 4 классы

Напишите программу Кумире, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4?

Напишите программу Кумире, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.

Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа не превышают 30.

Дашка754 11 сент. 2020 г., 10:56:42 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0?

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0.

Программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности).

Количество чисел не превышает 1000.

Введеные числа по модулю не превышают 30000.

Программа должна вывести число : количество чисел, кратных 4 и оканчивающихся на 0.

На этой странице сайта размещен вопрос На экран вводится последовательность натуральных чисел, не превышающих 1000? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.