Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов?

Информатика | 10 - 11 классы

Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов.

Ответить на вопрос
Ответы (1)
Дарья1508 12 авг. 2020 г., 05:01:53

Program jfe3 ;

const n = 10 ; {Это будет кол - во элементов массива}

var a : array [1.

N] of integer ; i, s : integer ;

begin

for i : = 1 to n do begin a[i] : = random(100) ; {элемент выбирается случайно от 0 до 100} s : = s + a[i] ; {Когда эл.

Присвоился, его значение плюсуется к общ сумме} end ;

for i : = 1 to n do

writeln(a[i], ' ') ; {показать сам массив}

writeln(s) ; {показать сумму}

readln ; {чтобы окно сразу не закрывалось}

end.

Если есть вопросы по программе, пиши в личку.

Если надо что - то еще - тоже = )

Удачи).

Asema198448 6 авг. 2020 г., 09:32:32 | 5 - 9 классы

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран?

Составить программу которая заполняет массив из 10 элементов случайными целыми числами из положительные, отрицательные и нулевые числа и выводит на экран.

Fonsov99 6 дек. 2020 г., 06:31:53 | 5 - 9 классы

Cоставить программу, которая формирует массив из 16 случайных целых чисел от - 20 до 20 и выводит элементы, кратные 3?

Cоставить программу, которая формирует массив из 16 случайных целых чисел от - 20 до 20 и выводит элементы, кратные 3.

На экран выводится исходный массив и найденные элементы.

245678988vk 21 авг. 2020 г., 17:39:21 | 5 - 9 классы

Срочно?

Срочно!

Составить программу, которая создает массив случайных чисел R[4, 5], выводит его на экран и вычисляет сумму всех его элементов.

Срочно.

Срочно.

Срочно.

Hasenovsultan 15 июн. 2020 г., 12:35:49 | 10 - 11 классы

Составить программу, которая генерирует 10 случайных чисел в диапазоне от - 20 до 30, выводит эти числа на экран и вычисляет сумму отрицательных?

Составить программу, которая генерирует 10 случайных чисел в диапазоне от - 20 до 30, выводит эти числа на экран и вычисляет сумму отрицательных.

Matveu001 7 июл. 2020 г., 12:38:44 | 5 - 9 классы

Паскаль АВС составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива?

Паскаль АВС составить программу, которая создает массив случайных чисел размером (N x M), выводит его на экран и вычисляет произведение ненулевых элементов массива.

12345678даша 18 нояб. 2020 г., 19:42:57 | 5 - 9 классы

3)Дан массив из 15 целых чисел (вводятся случайным образом в диапазоне от 1 до 100)?

3)Дан массив из 15 целых чисел (вводятся случайным образом в диапазоне от 1 до 100).

Составить программу, вычисляющую и выводящую на экран сумму шести первых элементов.

AiavodYanova 13 окт. 2020 г., 17:56:55 | 10 - 11 классы

Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)?

Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio).

Feshen 30 июл. 2020 г., 12:40:12 | 5 - 9 классы

Напишите программу которая генерирует 10 случайных чисел в диапазоне от 1 до 20 выводит эти числа на экран и вычисляет их среднее арефмитическое?

Напишите программу которая генерирует 10 случайных чисел в диапазоне от 1 до 20 выводит эти числа на экран и вычисляет их среднее арефмитическое.

Zhdanov1805 17 июл. 2020 г., 09:48:40 | 5 - 9 классы

Составьте программу, которая вычисляет сумму натуральных чисел от 10 до 15 и выводит на экран результат?

Составьте программу, которая вычисляет сумму натуральных чисел от 10 до 15 и выводит на экран результат.

Lenaaruda 30 сент. 2020 г., 14:24:55 | 5 - 9 классы

Составить программу, которая вычисляет сумму вводимых с клавиатуры целых чисел до ввода отрицательного числа и выводит на экран значение вычисленной суммы?

Составить программу, которая вычисляет сумму вводимых с клавиатуры целых чисел до ввода отрицательного числа и выводит на экран значение вычисленной суммы.

Вы находитесь на странице вопроса Составить программу которая создаёт массив случайных чисел, выводит его на экран и вычисляет сумму всех его элементов? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.