Дан фрагмент программыY = 0FOR K : = 15 DOWNTO 1 DO ;beginY = Y * K ;end ;напишите запись фрагмента программы, реализирующего алгоритм циклической структуры?

Информатика | 10 - 11 классы

Дан фрагмент программы

Y = 0

FOR K : = 15 DOWNTO 1 DO ;

begin

Y = Y * K ;

end ;

напишите запись фрагмента программы, реализирующего алгоритм циклической структуры.

Напишите пожалуйста полный ответ.

)).

Ответить на вопрос
Ответы (1)
Arinasaveleva 14 мая 2020 г., 16:17:47

Тут надо выбрать правильно записанный фрагмент, в А нет ошибок, в Б (Y = Y * K ; ), а оператор присваивания это ( : = ).

В С точка с запятой не ставится после Do и после Begin.

В D K : = 1 do 50(будет 50 повторений, а надо 15) и Y = Y * K.

Inna13 14 авг. 2020 г., 12:50:39 | 5 - 9 классы

Что будет выведенно на экран монитора после выполнения следующего фрагмента программы : с решением, пожалуйста For i : = 4 downto 1 do Begin For j : = 1 to i do write (j) ; WriteLn ; End ?

Что будет выведенно на экран монитора после выполнения следующего фрагмента программы : с решением, пожалуйста For i : = 4 downto 1 do Begin For j : = 1 to i do write (j) ; WriteLn ; End ;

Yasinsemik 1 янв. 2020 г., 14:08:23 | 5 - 9 классы

Какое значение будет принемать значение Y после выполнения фрагментов программы : 1?

Какое значение будет принемать значение Y после выполнения фрагментов программы : 1.

Var x, y : INTEGER ; BEGIN y : = 0 ; for x : = 1 to 9 do y : = y + x ; writeln(y = , y) ; END.

2. var x, y : INTEGER ; BEGIN y : = 0 ; for x : = 10 downto 5 do y : = y + 1 writeln(y = , y) ; END 3.

Var x, y : INTEGER ; BEGIN y : = 1 ; x : = 15 ; while x> ; 5 do begin x : = x - 3 ; y : = y * x ; end ; writeln(y = , y) END.

4. var x, y : INTEGER ; begin y : = 1 ; x : = 10 ; repeat y : = y * x + x ; x : = x - 2 ; until x< ; 0 ; writeln(y = , y) ; end.

Пожалуйста напишите подробное решение и как получаются ответы.

Ведьм 5 окт. 2020 г., 05:21:21 | 5 - 9 классы

Определить какое значение будет принимать переменная y после выполнения фрагментов программы Var x, y : integer ; Begin y : = 0 ; x : = 10 While x> ; 0 do begin x : = x - 2 ; y : = y + x end ; Write?

Определить какое значение будет принимать переменная y после выполнения фрагментов программы Var x, y : integer ; Begin y : = 0 ; x : = 10 While x> ; 0 do begin x : = x - 2 ; y : = y + x end ; Writeln(`y = ` , y ) end.

Подробно плииз до завтра.

Polovinko66 7 нояб. 2020 г., 13:28:35 | 5 - 9 классы

Определить значение переменной y после выполнения следующего фрагмента программы : Y : = 3 ; For n : = 1 downto 5 do y : = y + n ; С объснением?

Определить значение переменной y после выполнения следующего фрагмента программы : Y : = 3 ; For n : = 1 downto 5 do y : = y + n ; С объснением.

Крутыха 18 мар. 2020 г., 15:37:41 | 5 - 9 классы

9. В данном фрагменте программы : progra?

9. В данном фрагменте программы : progra.

M error ; begin SuMmA : = 25 - 14 ; end ; ошибкой является : а) некорректное имя программы Б) не определённое имя переменной в) некорректное имя переменной Г) запись арифметического выражения.

Mashamax1 30 авг. 2020 г., 07:57:01 | 5 - 9 классы

Какое значение примет переменная y после выполнения фрагмента программы?

Какое значение примет переменная y после выполнения фрагмента программы?

Y : = 1 ; while y< ; 100 do Begin y : = y * 2 ; end ;

Maleke1910 25 окт. 2020 г., 01:55:45 | 5 - 9 классы

Определить значение переменной у после выполнения следующих фрагментов программы :a) у : = 1?

Определить значение переменной у после выполнения следующих фрагментов программы :

a) у : = 1.

5 ; for i : = 1 to 4 do у : = у - i ;

b) у : = 2 ; for k : = 4 downto 1 do у : = у * k ;

c) у : = 5 ; for n : = 1 downto 4 do у : = у + n ;

d) у : = 1 ; for i : = 1 to 3 do begin у : = у + 1 ; у : = у + i ; end ;

e) у : = 0 ; for i : = 4 to 6 do у : = у + i ; у : = у / 10 ;

f) у : = 1 ; for i : = 0 downto - 2 do у : = у - i ; у : = у * 10 ;

g) y : = 0 ; for n : = 4 downto 2 do begin y : = y + n ; y : = y * 10 ; end

Заранее спасибо.

Katya284 22 мая 2020 г., 22:41:49 | 5 - 9 классы

В данном фрагменте программы : program error ; begin SuMmA : = 25 - 14 ; end?

В данном фрагменте программы : program error ; begin SuMmA : = 25 - 14 ; end.

Ошибкой является : а)некорректное имя программы б) не определённое имя переменной в) некорректное имя переменной г) запись арифметического выражения?

P. S.

Мне кажется, что это ответ б).

Superblack 11 апр. 2020 г., 11:44:24 | 5 - 9 классы

Дан фрагмент программы (использующий цикл с предусловием) : K : = 0 ; While k< ; 10 do begin K : = k + 1 ; P : = k * k ; Writeln(p) ; End Что выводится на экран в результате выполнения данного фрагм?

Дан фрагмент программы (использующий цикл с предусловием) : K : = 0 ; While k< ; 10 do begin K : = k + 1 ; P : = k * k ; Writeln(p) ; End Что выводится на экран в результате выполнения данного фрагмента?

Напишите полный текст программы вычисляющей произведение натуральных чисел от 1 до n значение n программа запрашивает у пользователя.

Atzabfkrf 2 дек. 2020 г., 18:44:48 | 5 - 9 классы

Определите, что будет выведено на экран после выполнения фрагмента программы : x : = 0 ; y : = 5 ; While y больше 0 do begin y : = y - 2 ; x : = x + y ; end ; writeln (‘x = ’, x) ; Ответ : х = 5 3 х =?

Определите, что будет выведено на экран после выполнения фрагмента программы : x : = 0 ; y : = 5 ; While y больше 0 do begin y : = y - 2 ; x : = x + y ; end ; writeln (‘x = ’, x) ; Ответ : х = 5 3 х = 3 5.

На странице вопроса Дан фрагмент программыY = 0FOR K : = 15 DOWNTO 1 DO ;beginY = Y * K ;end ;напишите запись фрагмента программы, реализирующего алгоритм циклической структуры? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.