Определить количество трёхзначных цыфр , сумма цыфр которого равна заданному числу N?

Информатика | 10 - 11 классы

Определить количество трёхзначных цыфр , сумма цыфр которого равна заданному числу N.

Ответить на вопрос
Ответы (1)
Анастасія13 17 нояб. 2020 г., 09:13:57

Const m = 999 ;

var i, N, count : integer ;

begin write('N = ') ; readln(N) ; count : = 0 ; for i : = 100 to m do begin if (i mod 10) + (i div 10) mod 10 + (i div 100) mod 10 = N then inc(count) ; end ; writeln('Count = ', count) ; readln ;

end.

Jimova 20 июл. 2020 г., 08:21:01 | 5 - 9 классы

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N?

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N.

VOLAN97 27 июл. 2020 г., 16:21:50 | 5 - 9 классы

1)найти количесво делителей натурального числа, сколько из них чётных?

1)найти количесво делителей натурального числа, сколько из них чётных?

2) дано натуральное число : найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа, которые состоят из разных цыфр, а их сумма равна А(А вводится с клавиатуры) 4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры).

Wera11 19 мар. 2020 г., 03:41:26 | 10 - 11 классы

В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов, сумма модулей которых равна модулю заданного числа М?

В числовой последовательности из N произвольных целых чисел определить количество пар соседних элементов, сумма модулей которых равна модулю заданного числа М.

Спасибо).

Chinianin 30 окт. 2020 г., 16:19:10 | 5 - 9 классы

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N?

Определить количество натуральных трехзначных чисел сумма цифр которых равна заданному числу N.

Xalilovadilbar 7 февр. 2020 г., 13:09:56 | 5 - 9 классы

Составить программу которая находит количество двух значных чисел у которых цыфры упарядачены по взрастанию?

Составить программу которая находит количество двух значных чисел у которых цыфры упарядачены по взрастанию.

НАстик1111 10 нояб. 2020 г., 08:04:40 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые.

Kolok2016 5 нояб. 2020 г., 15:08:51 | 10 - 11 классы

Вводится число от 1 до 15?

Вводится число от 1 до 15.

Вывести данное число, записанное римскими цыфрами.

Бикенов 15 нояб. 2020 г., 21:33:57 | 5 - 9 классы

Помогите составить программу Вычислите количество всех трёхзначных чисел , сумма которых равна 12?

Помогите составить программу Вычислите количество всех трёхзначных чисел , сумма которых равна 12.

( при помощи цикла ).

MarcoReusBVB09 23 сент. 2020 г., 12:12:30 | 5 - 9 классы

Среди всех двузначных чисел найти и вывести числа которые содержит цыфру 7?

Среди всех двузначных чисел найти и вывести числа которые содержит цыфру 7.

Арут2 4 окт. 2020 г., 13:19:28 | 5 - 9 классы

Дано натуральное число n найти произведение нечетных цыфр заданного числа?

Дано натуральное число n найти произведение нечетных цыфр заданного числа.

Пожалуйста Срооочно .

Если можно схeму тоже составьте и сфоткайте.

Вы находитесь на странице вопроса Определить количество трёхзначных цыфр , сумма цыфр которого равна заданному числу N? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.