Дан массив вещественных чисел : Все элементы с нечетными номерами заменить на их квадратный корень?

Информатика | 10 - 11 классы

Дан массив вещественных чисел : Все элементы с нечетными номерами заменить на их квадратный корень.

Ответить на вопрос
Ответы (1)
Мери00 29 дек. 2020 г., 02:37:05

Var a : array[1.

100] of real ; i, n : integer ;

begin write('Введите количество элементов ') ; readln(n) ; for i : = 1 to n do begin write('a[', i , '] = ') ; readln(a[i]) ; end ; writeln ; writeln('Исходный массив : ') ; for i : = 1 to n do begin write(a[i], ' ') ; if i mod 2 = 1 then a[i] : = sqrt(a[i]) ; end ; writeln ; writeln ; writeln('Преобразованный массив : ') ; for i : = 1 to n do write(a[i] : 0 : 2, ' ') ; writeln ;

end.

Tabarenzeva 31 мар. 2020 г., 17:07:40 | 5 - 9 классы

Дан массив из целых чисел X[1?

Дан массив из целых чисел X[1.

5]. Заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов.

LeXaNiCH777 21 окт. 2020 г., 20:28:32 | 10 - 11 классы

Дан массив целых чисел А(10)?

Дан массив целых чисел А(10).

Все нечетные элементы удвоить.

Sweetday1109 16 окт. 2020 г., 21:27:33 | 5 - 9 классы

1) дан массив Р(N), состоящий из N вещественных чисел?

1) дан массив Р(N), состоящий из N вещественных чисел.

Заменить отрицательные элементы массива их квадратами, и новый массив переписать в S(N).

ПОМОГИТЕЕЕ СРОЧНОО : *.

Настя6462 6 нояб. 2020 г., 06:22:34 | 10 - 11 классы

Дан массив целых чисел (заполнить случайными числами от 20 до 99)?

Дан массив целых чисел (заполнить случайными числами от 20 до 99).

Найти номер первого нечетного элемента.

Если нечетных элементов в массиве нет, то напечатать соответствующее сообщение.

Vika26082 4 апр. 2020 г., 16:57:47 | 5 - 9 классы

Написать программу на языке с + +дан массив вещественных чисел?

Написать программу на языке с + +

дан массив вещественных чисел.

Среди них есть равные.

Найти его первый максимальный элемент и заменить его нулем.

Loloshechka 9 дек. 2020 г., 16:07:01 | 10 - 11 классы

Дан одномерный массив, который содержит не более 50 вещественных чисел?

Дан одномерный массив, который содержит не более 50 вещественных чисел.

Найти сумму элементов, которые расположены на местах с нечетными номерами.

Yusufbek 16 мар. 2020 г., 22:47:12 | 5 - 9 классы

Массив содержит N случайных двузначных чисел?

Массив содержит N случайных двузначных чисел.

Определить сколько в данном массиве четных чисел.

Вывести все его элементы с нечетными номерами.

Lolla11 25 нояб. 2020 г., 05:52:52 | 5 - 9 классы

Дан массив вещественных чисел из 11 элементов?

Дан массив вещественных чисел из 11 элементов.

Найти произведение элементов, которые меньше 9.

Romchik13 3 сент. 2020 г., 17:31:37 | 10 - 11 классы

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов?

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов.

Fricasso 21 нояб. 2020 г., 02:46:06 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти сумму элементов с четными номерами и отдельно – с нечетными номерами.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дан массив вещественных чисел : Все элементы с нечетными номерами заменить на их квадратный корень?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.