ГДЕ ОШИБКА В КОДЕ?

Информатика | 10 - 11 классы

ГДЕ ОШИБКА В КОДЕ?

ЯЗЫК СИ.

#include #include int main() { system ("chcp 1251 > ; nul") ; printf(" \ n Условие : Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух.

") ; int a, b, c, d ; printf(" \ n \ t Введите 1 число - > ; ") ; scanf("%i", & ; a) ; printf(" \ n \ t Введите 2 число - > ; ") ; scanf("%i", & ; b) ; printf(" \ n \ t Введите 3 число - > ; ") ; scanf("%i", & ; c) ; printf(" \ n \ t Введите 4 число - > ; ") ; scanf("%i", & ; d) ; int chislo(int a, int b) {if (a> ; b) return a ; else return b ; } printf(chislo(chislo(chislo(a, b), c), d)) ; return 0 ; }.

Ответить на вопрос
Ответы (1)
Danatmusin 26 янв. 2020 г., 11:05:46

В printf не задана строка формата вывода.

Сначала должна быть строка, типа printf ("%d" , chislo.

)

и ещё не указано что #include.

Компилятор не поймёт, наверное, если в директиве #include ничего не указано.

Олег199965 20 нояб. 2020 г., 23:54:40 | 10 - 11 классы

Здравствуйте?

Здравствуйте.

Программа на си.

#include "stdio.

H" int main(void) { float a, b ; char s ; printf ("Vvedite chicla \ n") ; scanf("%f %f %c", & ; a, & ; b, & ; s) ; switch(s){ case' + ' : printf(" = %f \ n", a + b) ; break ; case' - ' : printf(" = %f \ n", a - b) ; break ; case' * ' : printf(" = %f \ n", a * b) ; break ; case' / ' : printf(" = %f \ n", a / b) ; break ; default : printf("ERROR \ n") ; return 0 ; } Потом, что бы получить ответ надо ввести два числа (ну на черный экран), далее знак ( + или - или / ).

Но вот вопрос.

Разве мы не должны, вводить , что в скобочках ' ' после "case" ?

Viktoriyabosko 15 авг. 2020 г., 21:38:20 | 10 - 11 классы

Помогите плиииз = ))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива?

Помогите плиииз = ))) у меня есть программа но вней 2 ошибки нужно сделать с помощью динамического массива.

/ / laba4_2.

Cpp : Defines the entry point for the console application.

/ / #include "stdafx.

H"

#include "stdio.

H" / / #include "math.

H"

using namespace std ;

int main ( )

{ float * a ; int i, n ; printf("n = ") ; scanf("%i", & ; n) ; a = (float * )malloc(N * sizeof(float)) ; for( i = 0 ; i< ; = n - 1 ; i + + ) { printf("a[%i] = ", i ) ; scanf("%i", & ; a[i]) ; } for (i = 0 ; i< ; = N - 1 ; i + + ) { if (a[i]< ; 0) { printf("oshibka \ n") ; } else { if (a[i] / 2 = = 0) { printf("chetnoe \ n") ; } else { printf("nechetnoe \ n") ; } } } return 1 ;

}.

Cristina2000 26 дек. 2020 г., 22:09:37 | 10 - 11 классы

Что выведет программа?

Что выведет программа?

#include main() { int x = 2, y = 2, z = 1 ; x - = y + = z ; printf (“%d ”, x < ; y ?

X - - : y + + ) ; printf (“x = %d y = %d”, x, y) ; }.

Koloverdova87 28 окт. 2020 г., 19:50:09 | 10 - 11 классы

Объясните пожалуйста как такой ответ выходит?

Объясните пожалуйста как такой ответ выходит?

#include< ; stdio.

H> ; #include< ; conio.

H> ; int main() { int i = 0 ; int s = 0 ; while(i< ; 4) { s + = i ; i + + ; printf("%d", i) ; } getch() ; } что программа выводит на экран?

Ответ : 6.

Kristinaberestenko 3 окт. 2020 г., 07:16:51 | 5 - 9 классы

1. Написать функцию, которая вычисляет минимум из четырёх чисел?

1. Написать функцию, которая вычисляет минимум из четырёх чисел.

2. Написать функцию, которая вычисляет минимум из двух чисел.

В чём ошибка?

1. / / public static int min(int a, int b, int c, int d) {

int m4 ;

if ( a < ; b & ; & ; a < ; c & ; & ; a < ; d) m4 = a ;

else if (b < ; a & ; & ; b < ; c & ; & ; b < ; d)

m4 = b ;

else if (c < ; a & ; & ; c < ; b & ; & ; c < ; d)

m4 = c ;

else if (d < ; a & ; & ; d < ; b & ; & ; d < ; c)

m4 = d ;

else

m4 = 0 ;

System.

Out. println("Use different numbers") ;

return m4 ;

}

2.

/ / public static int min(int a, int b)

{

int m2 ; if (a < ; b)

m2 = a ;

else

m2 = b ;

return m2 ;

}.

Begimot34 8 апр. 2020 г., 08:28:05 | 5 - 9 классы

Дан массив n элементов, найти кол - во чётных и нечётных чисел в массив Программирование С Правильно ли я сделал?

Дан массив n элементов, найти кол - во чётных и нечётных чисел в массив Программирование С Правильно ли я сделал?

#include #include int main() { int n ; printf ("Vvedite kol - vo elementov massiva") ; scanf ("%d", & ; n) ; int mass[n], i, a = 0, b = 0 ; for (i = 0 ; i { scanf("%d", & ; i) ; } for (i = 0 ; i { if (mass[i]%2 = = 0) { a + = 1 ; } else { b + = 1 ; } } printf("a = %d", a) ; printf("b = %d", b) ; system("pause") ; return(0) ; }.

Vladkyashtorniy 1 окт. 2020 г., 19:07:29 | 10 - 11 классы

Как решать такие задания?

Как решать такие задания.

#include int main(void){ int n, s ; n = 0 ; s = 0 ; while (s < ; = 256 ) { s = s + 25 ; n = n + 1 } printf(″%d″, n) ;

Даша1951 24 нояб. 2020 г., 05:58:09 | 5 - 9 классы

#include int main(void) { int A, B, count ; printf("Vvedite chislo A i chislo B : \ n") ; scanf("%d%d", & ; A, & ; B) ; for(B = 2 ; B count = 0 ; for(A = 2 ; A> ; B ; A + + ) if(A%B = = 0) cou?

#include int main(void) { int A, B, count ; printf("Vvedite chislo A i chislo B : \ n") ; scanf("%d%d", & ; A, & ; B) ; for(B = 2 ; B count = 0 ; for(A = 2 ; A> ; B ; A + + ) if(A%B = = 0) count + + ; if(count = = 0) printf("%d", A) ; } return 0 ; } Что неправильно в программе?

Помогите пожалуйста Вот условие Напишите программу, которая получает натуральные числа A и B (A.

Klepininaa 7 авг. 2020 г., 07:12:50 | 10 - 11 классы

ЯЗЫК СИ?

ЯЗЫК СИ!

ПОМОГИТЕ, ПОЖАЛУЙСТА, ИСПРАВИТЬ КОД.

НЕ МОГУ ПОНЯТЬ ПОЧЕМУ НЕ РАБОТАЕТ.

Написать функцию, умножающую все элементы массива на число.

Параметрами функции является массив и число, на которое нужно умножить его элементы.

#include #include int fun1(int b[], int k) { b[] = b[] * k ; } int main() { system ("chcp 1251 > ; nul") ; printf(" \ n Условие : Написать функцию, умножающую все элементы массива на число.

Параметрами функции является массив и число, на которое нужно умножить его элементы.

") ; int i ; int k ; int n ; printf(" \ n \ t Введите n - > ; ") ; scanf("%i", & ; n) ; printf(" \ n \ t Введите k - > ; ") ; scanf("%i", & ; k) ; int mas[n] ; printf(" \ n \ t Исходный массив : ") ; printf(" ") ; for(i = 0 ; i < ; n ; i + + ) mas[i] = rand()%10 ; for(i = 0 ; i < ; n ; i + + ) printf("%i ", mas[i]) ; printf(" \ n") ; printf("Преобразованный массив : \ n") ; for (i = 0 ; i printf("%i ", fun1(mas[i]) ; return 0 ;

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Вы перешли к вопросу ГДЕ ОШИБКА В КОДЕ?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.