Помогите, пожалуйста, очень срочно Сколько элементов массива размерностью N на M больше заданного числа R?

Информатика | 5 - 9 классы

Помогите, пожалуйста, очень срочно Сколько элементов массива размерностью N на M больше заданного числа R.

Подсчитать среднее арифметическое этих элементов.

Ответить на вопрос
Ответы (1)
Hilyak 23 мая 2020 г., 18:17:32

Const N = 5 ; M = 10 ;

var a : array [1.

N, 1.

M] of real ; s, R : real ; kol, i, j : integer ; / / kol - количество чисел

begin writeln('Введите R') ; readln(R) ; for i : = 1 to N do for j : = 1 to M do begin writeln('Введите a[', i, ', ', j, ']') ; readln(a[i, j]) ; if a[i, j] > ; R then begin kol : = kol + 1 ; s : = s + a[i, j] ; end ; end ; s : = s / kol ; writeln(kol, ' чисел > ; ', R) ; writeln('Среднее арифметическое равно ', s) ;

end.

Zemkafr 24 мар. 2020 г., 01:18:15 | 10 - 11 классы

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры?

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры.

Найти их среднее арифметическое значение.

Софигрэйт 26 июн. 2020 г., 05:32:27 | 5 - 9 классы

Задача?

Задача.

Подсчитать количество элементов одномерного массива, заданного генератором случайных чисел, больших среднеарифметического всех элементов массива.

Margo2335 25 сент. 2020 г., 12:23:22 | 5 - 9 классы

Пожалуйста помогите задачу умоляю))) Пожалуйста помогите задачу решить?

Пожалуйста помогите задачу умоляю))) Пожалуйста помогите задачу решить!

Размерность массива вводится с клавиатуры.

Элементы целочисленного массива - числа из [ - 30 ; 70].

Есть ли среди чисел массива числа кратыне 7 - и?

Если да то сколько их?

Сколько элементов массива находятся на позициях, кратных 7 - и.

Напечатайте на экране и количество таких элементов и сами эти элементы.

Annagusakova1999 16 мая 2020 г., 16:59:46 | 10 - 11 классы

В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк?

В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк.

Dilya36 13 дек. 2020 г., 18:33:19 | 10 - 11 классы

Задано массив из N элементов?

Задано массив из N элементов.

Найти среднее арифметическое элементов массива, превышающих число M.

Плюшевый1 12 февр. 2020 г., 21:58:14 | 10 - 11 классы

Задан одномерный массив?

Задан одномерный массив.

Найти наименьший по модулю элемент массива.

Задан двухмерный массив.

Найти среднее арифметическое всех отрицательных элементов массива.

Задания 38 и 39.

Очень срочно надо!

Заранее большое пребольшое спасибо!

Peterr 12 нояб. 2020 г., 02:36:38 | 5 - 9 классы

Написать программу для формирования массива размерности 15, составленного из минимальных элементов двух массивов размерности 15, заданных на диапазоне от 0 до 50?

Написать программу для формирования массива размерности 15, составленного из минимальных элементов двух массивов размерности 15, заданных на диапазоне от 0 до 50.

Помогите пожалуйста!

Оксана248 25 окт. 2020 г., 03:10:27 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

Очень срочно!

1. Введите с клавиатуры целочисленный массив из 8 элементов, найти среднее арифметическое всех элементов массива.

2. Заполнить массив из 10 элементов случайными числами в интервале [0 ; 20] и вывести его в столбец.

Подсчитать количество всех элементов, которые меньше 7.

Turenko80 10 сент. 2020 г., 16:57:05 | 5 - 9 классы

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8?

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8.

228256654 23 окт. 2020 г., 12:35:52 | 5 - 9 классы

Задан массив размером 10 на 10 элементов каждый элемент случайное число в диапазоне от - 20 до 20 с шагом 1Определить в этом массиве среднее арифметическое отрицательных элементов?

Задан массив размером 10 на 10 элементов каждый элемент случайное число в диапазоне от - 20 до 20 с шагом 1

Определить в этом массиве среднее арифметическое отрицательных элементов.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите, пожалуйста, очень срочно Сколько элементов массива размерностью N на M больше заданного числа R?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.