• Помогите на паскале?

Информатика | 10 - 11 классы

• Помогите на паскале.

Дан целочисленный массив.

Удалить из массива все одинаковые элементы оставив их последние вхождения.

Ответить на вопрос
Ответы (1)
Anuta68 10 мар. 2020 г., 03:05:44

Const n = 30 ;

var a : array[1.

N] of integer ; tek, k, i, j : integer ;

begin

{ заполнение массива и вывод на экран }

for j : = 1 to n do

begin a[j] : = Random(20) ; write(a[j], ' ') ; if (j mod 10 = 0) then writeln ;

end ;

writeln ;

{ цикл обработки массива }

for i : = 1 to n do

begin tek : = a[i] ; k : = i ;

{ просмотр на повторные } for j : = i + 1 to n do begin if (a[j] = tek) then begin a[k] : = 0 ; k : = j ; end ; end ; end ; { конец обработки массива }

{ вывод итогового массива на экран } for i : = 1 to n do begin

write(a[i], ' ') ; if (i mod 10 = 0) then writeln ; end ;

end.

Alekseigodovik 18 янв. 2020 г., 13:43:22 | 10 - 11 классы

Дан целочисленный линейный массив?

Дан целочисленный линейный массив.

Удалить из него последний четный элемент.

Lerunchik2001 18 янв. 2020 г., 18:22:07 | 10 - 11 классы

Дан целочисленный массив из 10 целых чисел?

Дан целочисленный массив из 10 целых чисел.

Преобразуйте его, прибавив к нечетным числам значение последнего элемента.

Последний элемент массива оставьте без изменений.

(В Паскале).

Vikunm 24 февр. 2020 г., 07:05:47 | 10 - 11 классы

Дан целочисленный массив размера N?

Дан целочисленный массив размера N.

Преобразовать его, прибавив к нечетным числам последний элемент.

Первый и последний элемент массива не изменять.

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

Borivec83 22 февр. 2020 г., 11:21:51 | 10 - 11 классы

Дан целочисленный массив A?

Дан целочисленный массив A.

Найти в нем два наименьших элемента.

ПАСКАЛЬ!

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Vanilka14 28 янв. 2020 г., 08:07:27 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

Удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.

Если таких элементов несколько , удалить последний из найденных.

Помогите решить в паскале.

(вычислить средн.

Ариф.

Номер э - та, .

).

Matveypomoz 20 мар. 2020 г., 15:38:56 | 10 - 11 классы

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём?

Помогите оставить программу в Паскале : Дан одномерный массив заменить все чётные элементы массива нулём.

Elenashmeleva1 14 апр. 2020 г., 00:10:59 | 5 - 9 классы

Дан целочисленный массив из 50 элементов?

Дан целочисленный массив из 50 элементов.

Элементы массива могут приннимать целые значения от 0 до 1000.

Найти и вывести номер элемента массива, имеющего максимальное значение среди элементов массива, которые больше, чем 4 и меньше , чем 9.

Гарантируется , что в исходном массиве есть хотя бы один такой элемент.

На паскале , помогите пожалуйста.

LoveMashaa 26 нояб. 2020 г., 19:07:56 | 10 - 11 классы

40 баллов за простую задачу, помогите пожалуйста, иформатика, Паскаль?

40 баллов за простую задачу, помогите пожалуйста, иформатика, Паскаль!

Дан целочисленный массив из 20 чисел.

Найти сумму и произведение элементов массива.

Перед вами страница с вопросом • Помогите на паскале?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.