Даны натуральное число n и последовательность целых чисел а1, а2, … аn?

Информатика | 10 - 11 классы

Даны натуральное число n и последовательность целых чисел а1, а2, … аn.

Из наибольшего элемента извлечь квадратный корень.

Составить блок - схему алгоритма, написать программу.

Ответить на вопрос
Ответы (1)
PYX593 21 сент. 2020 г., 11:52:22

Program xxx ; var i, n, max : integer ; s : real ; a : array [1.

20] of integer ;

begin write ('введите n = ') ; readln(n) ; for i : = 1 to n do readln (a[i]) ; max : = a[1] ; for i : = 1 to n do if a[i] > ; max then max : = a[i] ; s : = sqrt(max) ; write ('корень из наибольшего эл - та = ', s)

end.

Galinatitova48 23 нояб. 2020 г., 07:17:13 | 10 - 11 классы

Помогите с паскалем?

Помогите с паскалем!

Написать программу.

Составить блок схему.

Вставить заданное число в массив целых чисел перед последним четным элементом.

Viktoria257 31 авг. 2020 г., 02:28:56 | 10 - 11 классы

1)Составить алгоритм нахождения количества положительных элементов с последовательностью целых чисел b1, b2, b3, ?

1)Составить алгоритм нахождения количества положительных элементов с последовательностью целых чисел b1, b2, b3, .

, bn 2)Составить алгоритм и блок - схему нахождения произведения отрицательных чисел с последовательностью a1, a2, a3, .

, an.

Zaykaevm 2 июл. 2020 г., 18:34:58 | 10 - 11 классы

Помогите построить блок схему для VBA Дана последовательность целых чисел a1, …a45?

Помогите построить блок схему для VBA Дана последовательность целых чисел a1, …a45.

Получить число отрицательных элементов последовательности a1, …a35 и число нулевых элементов всей последовательности.

Наталия1611 8 янв. 2020 г., 10:35:08 | 10 - 11 классы

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn?

Даны натуральное число n и последовательность целых чисел а1, а2, …, аn.

Определить количество тех членов последовательности, которые нечетны .

Найти сумму членов последовательности, кратных 11.

Составить блок - схему алгоритма, написать программу.

Ivasishina2002 14 июн. 2020 г., 04:17:57 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

Нужно составит блок - схему алгоритма.

Задание : в последовательности целых чисел определить максимальное четное число и его порядковый номер.

P. S.

Мне не нужна программа, которая вычисляет это(Паскаль или еще какая - нибудь).

Мне нужна блок - схема!

Pool658 18 июл. 2020 г., 00:28:34 | 5 - 9 классы

Написать программу в Паскале?

Написать программу в Паскале.

Даны два числа.

Меньшее из них замените полусуммой этих чисел, а большее - их произведением.

Составить блок - схему.

АннаГлобенко 2 июн. 2020 г., 14:12:38 | 5 - 9 классы

Составить блок - схему алгоритма и программу, которая подсчитывает сумму 10 целых чисел, введенных с клавиатуры?

Составить блок - схему алгоритма и программу, которая подсчитывает сумму 10 целых чисел, введенных с клавиатуры.

Данную программу делать в Qbasic.

ЛерочкаВ 21 июн. 2020 г., 07:32:22 | 10 - 11 классы

Составить программу и блок - схему к задаче : Вводится последовательность из N целых чисел?

Составить программу и блок - схему к задаче : Вводится последовательность из N целых чисел.

Найти сумму отрицательных.

Пожалуйста помогите.

Ogromania 1 сент. 2020 г., 17:16:52 | 10 - 11 классы

Написать программу для решения следующей задачи : найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности?

Написать программу для решения следующей задачи : найти среднее арифметическое наибольшего и наименьшего элементов данной конечной числовой последовательности.

+ блок - схема.

Только блок - схему!

Denavotar200041 17 мая 2020 г., 12:16:03 | 5 - 9 классы

Составьте блок - схему алгоритма и программу вычисления произведения нечетных чисел, меньших 16?

Составьте блок - схему алгоритма и программу вычисления произведения нечетных чисел, меньших 16.

Можете просто код написать без блок схемы.

Вы перешли к вопросу Даны натуральное число n и последовательность целых чисел а1, а2, … аn?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.