Массив А(N, M)?

Информатика | 10 - 11 классы

Массив А(N, M).

В каждом столбце найти среднее арифметическое нечетных элементов.

Из полученных значений сформировать одномерный массив.

Ответить на вопрос
Ответы (1)
Snezhanohka2003 2 мая 2020 г., 20:21:48

Uses Crt ;

const

n = 5 ; m = 7 ;

var

a : array[1.

N, 1.

M]of integer ;

b : array[1.

M]of real ;

i, j, k, c : integer ;

s : real ;

begin

clrScr ; for i : = 1 to n do begin writeln ; for j : = 1 to m do begin a[i, j] : = random(30) ; write(a[i, j] : 4) ; end ; end ;

writeln ;

for j : = 1 to m do begin s : = 0 ; k : = 0 ; for i : = 1 to n do if a[i, j]mod 2< ; > ; 0 then begin s : = s + a[i, j] ; k : = k + 1 ; end ; if k< ; > ; 0 then begin c : = c + 1 ; b[c] : = s / k ; end ; end ;

for i : = 1 to c do write(b[i] : 8 : 2) ;

readkey ;

end.

Zemkafr 24 мар. 2020 г., 01:18:15 | 10 - 11 классы

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры?

Сформировать массив, подсчитать количество элементов не превосходящих заданного числа n - задано с клавиатуры.

Найти их среднее арифметическое значение.

Kashetay 27 февр. 2020 г., 07:31:35 | 5 - 9 классы

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры?

Сформировать одномерный массив из 6 целых чисел, элементы которого вводятся с клавиатуры.

Подсчитать среднее арифметическое элементов с нечетными номерами.

Muselp 9 мар. 2020 г., 11:35:17 | 10 - 11 классы

Дан массив X(N, M)?

Дан массив X(N, M).

Найти произведение элементов тех столбцов массива, в которых все элементы положительные.

Из полученных значений сформировать одномерный массив.

Помогите пожалуйста!

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Julia8282 3 дек. 2020 г., 11:36:00 | 5 - 9 классы

Дан одномерный массив, состоящий из N элементов?

Дан одномерный массив, состоящий из N элементов.

Найти максимальный из нечетных элементов массива.

Ovsyanikovanas 28 мар. 2020 г., 18:53:34 | 5 - 9 классы

Дан одномерный массив чисел?

Дан одномерный массив чисел.

Определить среднее арифметическое элементов массива.

Pinirob 14 дек. 2020 г., 08:01:44 | 10 - 11 классы

Сформировать одномерный массив из 10 целых элементов?

Сформировать одномерный массив из 10 целых элементов.

Найти сумму положительных и четных элементов массива.

Losemyselft1 22 окт. 2020 г., 23:13:40 | 10 - 11 классы

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем)?

Сформировать одномерный массив из 20 элементов (значения элементов задаются пользователем).

Увеличить каждый элемент на 1.

Вывести на экран исходный и итоговый массивы.

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Romchik13 3 сент. 2020 г., 17:31:37 | 10 - 11 классы

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов?

Дан одномерный массив вещественных чисел найти средняя арифметическая положительных элементов.

На этой странице вы найдете ответ на вопрос Массив А(N, M)?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.