Напишите программу, удаляющую из слова i - ю букву?

Информатика | 10 - 11 классы

Напишите программу, удаляющую из слова i - ю букву.

В алгоритмическом языке и блок схему.

Ответить на вопрос
Ответы (1)
Veravrn 19 дек. 2020 г., 10:24:36

Вариант с процедурой Delete

var s : string ; k : integer ;

begin Write('Введите слово : ') ; Readln(s) ; Write('Какую по порядку букву удалить?

') ; Read(k) ; Delete(s, k, 1) ; Writeln('Результат : ', s)

end.

Вариант с функцией Copy

var s : string ; k, n : integer ;

begin Write('Введите слово : ') ; Readln(s) ; Write('Какую по порядку букву удалить?

') ; Read(k) ; n : = Length(s) ; s : = Copy(s, 1, k - 1) + Copy(s, k + 1, n - k) ; Writeln('Результат : ', s)

end.

Вариант с циклами

var s, s1 : string ; k, i, n : integer ;

begin Write('Введите слово : ') ; Readln(s) ; Write('Какую по порядку букву удалить?

') ; Read(k) ; n : = Length(s) ; s1 : = '' ; for i : = 1 to k - 1 do s1 : = s1 + s[i] ; for i : = k + 1 to n do s1 : = s1 + s[i] ; Writeln('Результат : ', s1)

end.

Тестовое решение (одинаково для всех вариантов) :

Введите слово : Таракан

Какую по порядку букву удалить?

4

Результат : Таркан

Блок - схемы всех вариантов находятся во вложениях.

TumblrBoy 24 февр. 2020 г., 11:49:48 | 10 - 11 классы

Составить блок - схему алгоритма и программу на алгоритмическом языке?

Составить блок - схему алгоритма и программу на алгоритмическом языке.

Язык Паскаль ( любой ).

Olga22111 14 дек. 2020 г., 13:28:04 | 5 - 9 классы

Срочно?

Срочно!

Запишите на языке Паскаль в виде участка программы следующую блок - схему.

Dtnf 4 дек. 2020 г., 02:00:07 | 10 - 11 классы

Алгоритмическая структура какого типа изображена на блок - схеме?

Алгоритмическая структура какого типа изображена на блок - схеме.

Nyancat132 28 апр. 2020 г., 13:16:16 | 5 - 9 классы

Запишите на языке ПАСКАЛЬ программу, соответствующую приведенной ниже блок - схеме и определить, что вычисляет данная программа?

Запишите на языке ПАСКАЛЬ программу, соответствующую приведенной ниже блок - схеме и определить, что вычисляет данная программа!

Basovvova96 10 июн. 2020 г., 23:10:42 | 5 - 9 классы

Помогите пожалуйста составить фрагмент блок - схемы и фрагмент программы на языке VB?

Помогите пожалуйста составить фрагмент блок - схемы и фрагмент программы на языке VB.

= ).

Fir601 10 июл. 2020 г., 06:34:38 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО?

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО!

Начертите блок схему алгоритмической структуры выбор.

Deamon198624 18 мар. 2020 г., 01:40:14 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ!

Запишите на алгоритмическом языке алгоритм, представленный блок - схемой.

Дашуля2200 18 июл. 2020 г., 11:04:04 | 10 - 11 классы

Используя класс string написать программу на языке с + + и блок - схему по которой написана программа помогите, пожалуйста?

Используя класс string написать программу на языке с + + и блок - схему по которой написана программа помогите, пожалуйста!

Нацу43 10 дек. 2020 г., 18:53:55 | 5 - 9 классы

Помогите пожалуйста, нужно создать программу на языке pascal, на фото блок схема?

Помогите пожалуйста, нужно создать программу на языке pascal, на фото блок схема.

Nonella12 22 дек. 2020 г., 23:34:24 | 10 - 11 классы

Запишите на языке Паскаль в виде участка программы следующую блок - схему ?

Запишите на языке Паскаль в виде участка программы следующую блок - схему :

Вы зашли на страницу вопроса Напишите программу, удаляющую из слова i - ю букву?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.