Дан массив N ?

Информатика | 10 - 11 классы

Дан массив N .

Найти количество всех неотрицательных элементов .

При этом N должно вводится с клавиатуры , а числа должны быть рандомными.

Программа должна быть на С + +.

Ответить на вопрос
Ответы (2)
Coolnurka 9 нояб. 2020 г., 02:43:11

Красивенький вывод уж сам.

#include < ; iostream> ;

using namespace std ;

int main() { cout < ; < ; "n = " ; int n, not_null ; cin > ; > ; n ; int * mass = new int [n] ; / / Заполнение и вывод массива for (int i = 1 ; i < ; = n ; i + + ) { mass[i] = rand() - rand() ; cout < ; < ; "mass["< ; < ; i < ; < ; "] = "< ; < ; mass[i] < ; < ; endl ; / / Определяем положительные числа и считаем их if (mass[i] > ; 0) { not_null + + ; } ; } cout < ; < ; "n > ; 0 = " < ; < ; not_null < ; < ; endl ; system("pause") ; return 0 ;

}.

Hika1 9 нояб. 2020 г., 02:43:14

#include < ; stdio.

H> ; / * printf, scanf, puts, NULL * /

#include < ; stdlib.

H> ; / * srand, rand * /

#include < ; time.

H> ; / * time * /

#include < ; iostream> ;

using namespace std ;

int main (){

int i, n, c ;

printf ("Введите n : ") ;

scanf ("%d", & ; n) ;

int digit[n] ;

srand (time(NULL)) ;

c = 0 ;

for(i = 1 ; i< ; = n ; i + + ) {

digit[i] = (int)(rand() - rand()) ;

cout< ; < ; "Число "< ; < ; i< ; < ; " = "< ; < ; digit[i]< ; < ; ' \ n' ;

if(digit[i]> ; = 0)c + + ;

}

cout< ; < ; "Количество всех неотрицательных элементов : "< ; < ; c< ; < ; " \ n" ;

return 0 ;

}.

Настя3254 1 мая 2020 г., 01:49:08 | 10 - 11 классы

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превосходит 100 (каждое число – с новой строки), и выводит на экран число, р?

С1. Составьте программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превосходит 100 (каждое число – с новой строки), и выводит на экран число, равное произведению максимального и минимального из них, если минимальное число отрицательно ; или сумме максимального и минимального из них, если минимальное число неотрицательно.

Ничего, кроме указанного числа, программа выводить не должна.

С2. Составьте программу, которая вводит с клавиатуры натуральное число N, не превосходящее 12, а затем N целых неотрицательных чисел ( каждое чисол - с новой строки), записывает эти N чисел в массив, выводит на экран сначала в обратном порядке все, без исключения, элементы массива, затем, в прямом порядке относительно следования в массиве, все элементы, остаток которых от деления на 8 равен 3.

Каждое число программа должна выводить в отдельной строке ; ничего, кроме чисел, программа выводить не должна.

С3. См.

Фото.

Tima010010 3 июл. 2020 г., 08:54:38 | 10 - 11 классы

Имеется четыре произвольных числа ABCD, которые вводятся с клавиатуры?

Имеется четыре произвольных числа ABCD, которые вводятся с клавиатуры.

Программа должна давать ответ на вопрос правда ли что : первое число самое большое?

AlinaDoloman 21 янв. 2020 г., 06:28:16 | 5 - 9 классы

Массив из 10 элементов вводится с клавиатуры?

Массив из 10 элементов вводится с клавиатуры.

Составить программу расчёта среднего арифметического любых двух элементов массива (номера элементов вводятся с клавиатуры).

Abzalarapbaev 24 мая 2020 г., 10:26:45 | 10 - 11 классы

10. Составьте программу, которая вводит с клавиатуры три целых числа : a, b, c (каждое число с новой строки) и выводит на экран максимальное из них?

10. Составьте программу, которая вводит с клавиатуры три целых числа : a, b, c (каждое число с новой строки) и выводит на экран максимальное из них.

Ничего кроме этого числа, программа выводить не должна.

Smakatov 16 мар. 2020 г., 07:55:30 | 5 - 9 классы

Заполнить массив из 15 элементов целыми числами с клавиатуры, и найти количество отрицательных элементов?

Заполнить массив из 15 элементов целыми числами с клавиатуры, и найти количество отрицательных элементов.

Программа Паскаль.

Sahilchik82 5 мар. 2020 г., 18:40:30 | 10 - 11 классы

Составьте программу для угадывания числа от 1 до 15?

Составьте программу для угадывания числа от 1 до 15.

Число с клавиатуры можно вводить 3 раза.

В ответ на наше число реакция ПК должна быть больше, меньше, угадал.

MRcoffee 14 мар. 2020 г., 08:36:28 | 5 - 9 классы

Помогите решить задачи на паскаль?

Помогите решить задачи на паскаль.

1) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти произведение всех элементов массива.

2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти сумму четных элементов массива.

3) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива.

4) Дан массив случайных чисел (количество элементов вводите с клавиатуры).

Найти максимальный элемент массива среди элементов, кратных 3.

Monstepilya 28 мар. 2020 г., 08:26:14 | 10 - 11 классы

Дан массив из n чисел?

Дан массив из n чисел.

Найти номер первого чётного элемента массива ; если чётных элементов нет, то ответом должно быть число 0.

Помогите написать программу в паскаль.

Муххаммед 11 июл. 2020 г., 07:06:39 | 10 - 11 классы

Даны 2 действительных числа?

Даны 2 действительных числа.

Возвести в квадрат те из них, значение которых неотрицательны.

Числа вводятся пользователям с клавиатуры.

Результат работы программы вводится на экран.

Оелсврксов 12 сент. 2020 г., 09:39:55 | 10 - 11 классы

1)Дан одномерный массив?

1)Дан одномерный массив.

Найти сумму элементов принадлежащих промежутку от А до В (А и В вводятся с клавиатуры) 2)одномерный массив заполнить n случайными целыми числами находящимися в интервале от 0 до 15.

Найти произведение максимального и минимального элемента массива.

Вывести массив, числа должны распологатся в строке.

3)Составить программу используя оператор WHILE Вывести на экран , кратные К из промежутка (А, В).

Числа К, А, В задаёт пользователь 4)Составить программу используя оператор FOR Дана последовательность из N целых чисел.

Определить произведение элементов этой последовательности.

На этой странице сайта вы найдете ответы на вопрос Дан массив N ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.