Сортировка элементов первого столбца с помощью прямого обмена?

Информатика | 10 - 11 классы

Сортировка элементов первого столбца с помощью прямого обмена.

Программа Паскаль.

Ответить на вопрос
Ответы (1)
У2002 4 нояб. 2020 г., 10:46:27

Const m1 = 10 ; n1 = 8 ;

var x : array[1.

M1, 1.

N1] of integer ; i, j, m, n, t : integer ;

begin Write('Введите через пробел число строк и столбцов матрицы : ') ; Read(m, n) ; Randomize ; Writeln('Исходная матрица') ; for i : = 1 to m do begin for j : = 1 to n do begin x[i, j] : = Random(50) + 1 ; Write(x[i, j] : 3) end ; Writeln end ; { простая обменная сортировка первого столбца } for i : = 1 to m - 1 do for j : = 1 to m - 1 do if x[j, 1]> ; x[j + 1, 1] then begin t : = x[j, 1] ; x[j, 1] : = x[j + 1, 1] ; x[j + 1, 1] : = t end ; Writeln('Результирующая матрица') ; for i : = 1 to m do begin for j : = 1 to n do Write(x[i, j] : 3) ; Writeln end

end.

Тестовое решение :

Введите через пробел число строк и столбцов матрицы : 10 8

Исходная матрица

44 28 35 45 28 21 24 31

39 10 1 27 33 3 7 39

22 8 45 4 33 11 23 37

18 50 48 12 45 28 1 32 3 25 45 11 40 49 47 17

28 16 46 43 11 13 22 18

27 24 45 33 44 44 34 34 6 49 27 28 24 13 37 12 9 19 25 8 8 47 49 24

11 29 26 18 16 30 27 6

Результирующая матрица 3 28 35 45 28 21 24 31 6 10 1 27 33 3 7 39 9 8 45 4 33 11 23 37

11 50 48 12 45 28 1 32

18 25 45 11 40 49 47 17

22 16 46 43 11 13 22 18

27 24 45 33 44 44 34 34

28 49 27 28 24 13 37 12

39 19 25 8 8 47 49 24

44 29 26 18 16 30 27 6.

Slender2774 30 янв. 2020 г., 19:21:30 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ!

Задан целочисленный массив из 10 случайных целых чисел.

Выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

АlexеY 5 авг. 2020 г., 14:15:35 | 10 - 11 классы

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора?

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора.

Milana2003m 20 нояб. 2020 г., 19:20:06 | 5 - 9 классы

Составить программу на Паскале сортировки массива по возрастанию?

Составить программу на Паскале сортировки массива по возрастанию.

Apvapavpva00 1 мар. 2020 г., 05:47:45 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

Ivansmirnov0201 30 апр. 2020 г., 21:36:19 | 10 - 11 классы

Заполнить массив из 10 элементов случайными числами от - 10 до 5?

Заполнить массив из 10 элементов случайными числами от - 10 до 5.

Произвести сортировку методом прямого обмена по возрастанию.

(Код нужен на паскаль).

Polina2101203 23 дек. 2020 г., 10:22:02 | 10 - 11 классы

Pascal?

Pascal.

Паскаль.

Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом.

Андрей30062002 2 июн. 2020 г., 16:39:27 | 10 - 11 классы

Сортировка данных?

Сортировка данных.

Алгоритм прямого обмена при сортировке массива.

Ntv1978 2 окт. 2020 г., 11:05:37 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

Kris656 29 мая 2020 г., 11:19:10 | 10 - 11 классы

Написать программу и блок - схему для решения следующей задачи?

Написать программу и блок - схему для решения следующей задачи.

В двумерном массиве, состоящем из целочисленных элементов, поменять местами : в каждом столбце первый и последний отрицательные элементы ;

(Паскаль).

Yanabrizhasheva 2 июн. 2020 г., 22:39:42 | 10 - 11 классы

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы?

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы.

Если такого столбца нет выводится сообщение.

Вы перешли к вопросу Сортировка элементов первого столбца с помощью прямого обмена?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.