Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста!

Нужно сделать программу перевода чисел из 8 - ой системы счисления в 2 - ую систему счисления.

На Pascal.

Ответить на вопрос
Ответы (1)
Sharlottacharli 14 нояб. 2020 г., 13:15:26

Function f8t2(s8 : string) : string ;

const m : array['0'.

'7'] of string = ('000', '001', '010', '011', '100', '101', '110', '111') ; m1 : array['1'.

'7'] of string = ('1', '10', '11', '100', '101', '110', '111') ;

var s : string ; i : integer ;

begin s : = m1[s8[1]] ; for i : = 2 to Length(s8) do s : = s + m[s8[i]] ; f8t2 : = s

end ;

var s : string ;

begin Write('Введите восьмеричное число : ') ; Readln(s) ; Writeln('В двоичной системе : ', f8t2(s))

end.

Тестовое решение :

Введите восьмеричное число : 15740

В двоичной системе : 1101111100000.

Irinniko 18 мая 2020 г., 04:44:13 | 10 - 11 классы

Выполнить перевод из десятичной системы счисления в двоичную систему счисления 445(10)?

Выполнить перевод из десятичной системы счисления в двоичную систему счисления 445(10).

Uvlad 6 нояб. 2020 г., 04:21:32 | 10 - 11 классы

Как перевести число 1112 из 10 системы счисления в 8 систему счисления, в 16 систему счисления, в 5 систему счисления?

Как перевести число 1112 из 10 системы счисления в 8 систему счисления, в 16 систему счисления, в 5 систему счисления.

Сделать проверку.

Помогите очень срочно!

Аринарнр 29 окт. 2020 г., 10:57:02 | 10 - 11 классы

Помогите пожалуйста а = 343 в = 85 найти (а - в), ( - в - а), ( - а - в) этих чисел в двоичной системе счисления с использованием кодов чисел?

Помогите пожалуйста а = 343 в = 85 найти (а - в), ( - в - а), ( - а - в) этих чисел в двоичной системе счисления с использованием кодов чисел.

Полученные результаты проверить переводом в 10 - ю систему счисления.

Линусик15 18 апр. 2020 г., 10:39:45 | 10 - 11 классы

Ужно сделать перевод чисел из десятичной системы счисления в двоичную, восьмиричную и шестнадцатеричную систему исчисления : чисел 1035 и 756?

Ужно сделать перевод чисел из десятичной системы счисления в двоичную, восьмиричную и шестнадцатеричную систему исчисления : чисел 1035 и 756.

Мпьип 2 июл. 2020 г., 02:22:19 | 10 - 11 классы

Друзья, помогите пожалуйста решить?

Друзья, помогите пожалуйста решить!

Перевести число из восьмеричной системы счисления в систему счисления с основанием .

Перевести число из десятичной системы в систему счисления с основанием .

NARUTA200303 20 окт. 2020 г., 18:21:18 | 10 - 11 классы

Перевод чисел из одной системы счисления в другую?

Перевод чисел из одной системы счисления в другую.

Alelsandrailin 14 мар. 2020 г., 01:42:41 | 5 - 9 классы

1. Представление числовой информации с помощью систем счисления?

1. Представление числовой информации с помощью систем счисления.

Перевод чисел из десятичной системы счисления в двоичную и обратно.

Mashatiffany 24 янв. 2020 г., 07:18:54 | 5 - 9 классы

Как переводить число из десятичной системы счисления в двоичную систему счисления?

Как переводить число из десятичной системы счисления в двоичную систему счисления?

(в данном случае число 1010).

Sergeytrofimen 25 июн. 2020 г., 03:37:11 | 5 - 9 классы

Помогите написать программу на языке программирования Pascal перевода из десятичной системы счисления в двоичную?

Помогите написать программу на языке программирования Pascal перевода из десятичной системы счисления в двоичную.

1234554321123321 17 нояб. 2020 г., 06:05:27 | 5 - 9 классы

. Осуществите перевод : а) из двоичной системы счисления в шестнадцатеричную систему счисления (11101101011010, 01111)2 = ( )16 б) из восьмеричной системы счисления в двоичную систему счисления (5321,?

. Осуществите перевод : а) из двоичной системы счисления в шестнадцатеричную систему счисления (11101101011010, 01111)2 = ( )16 б) из восьмеричной системы счисления в двоичную систему счисления (5321, 422)8 = ( )2.

На этой странице находится вопрос Помогите пожалуйста?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.