Напиши значение змінної S, которого она набудет после выполнения таких операторов :1) s : = 0 ; for i : = 10 downto 6 do s : = s + 1 ;2)s : = 0 ; for i : = 8 to 3 do s : = s + 1 ;3)s : = 1 ; for i : =?

Информатика | 5 - 9 классы

Напиши значение змінної S, которого она набудет после выполнения таких операторов :

1) s : = 0 ; for i : = 10 downto 6 do s : = s + 1 ;

2)s : = 0 ; for i : = 8 to 3 do s : = s + 1 ;

3)s : = 1 ; for i : = 2 downto 10 dо s : = s + 1 ;

ДАЮ 40 БАЛЛОВ.

ПОЖАЛУЙСТА, ОЧЕНЬ НУЖНО♥️.

Ответить на вопрос
Ответы (1)
Зухрушка111 2 февр. 2024 г., 23:00:38

Ответ :

1) 5

2) 0

3) 1

Объяснение :

в 2) и 3) цикл не выполняется ни разу.

Habibullaeva199 17 февр. 2024 г., 04:31:11 | 5 - 9 классы

Каким будет конечное значение переменной ѕпосле выполнения программы :1?

Каким будет конечное значение переменной ѕ

после выполнения программы :

1.

S = 0

2.

For x in range (3, 6) :

3.

S = S + X

4.

Print(s)

7

0

12

3​.

89235609398 24 февр. 2024 г., 07:41:34 | 5 - 9 классы

ПОМОГИТЕ?

ПОМОГИТЕ!

1) Определите , сколько раз будет выполняться тело следующего оператора цикла :

k : = 0 ;

for i : = 1 to k + 4 do

k : = k + 2 ;

2) Напишите программу вычисления суммы натуральных чисел : S = 1 + 2 + 3 + .

+ N. .

Тим38 6 апр. 2024 г., 11:22:18 | студенческий

Как работает цикл for ?

Как работает цикл for .

To? .

Baktigul1 9 янв. 2024 г., 03:17:51 | 5 - 9 классы

ВЫЧИСЛИТЕ С ПОМОЩЬЮ ЦИКЛА FOR?

ВЫЧИСЛИТЕ С ПОМОЩЬЮ ЦИКЛА FOR.

Nastya1357935 13 янв. 2024 г., 01:13:23 | 5 - 9 классы

Вывод на экран кубов чисел от 13 до 3?

Вывод на экран кубов чисел от 13 до 3.

Var

?

: integer ;

begin

for i : = ?

Downto?

Do

writeln (i * i * i) ;

readln ;

end.

Катринулька 8 мар. 2024 г., 14:15:14 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Напишите программу, которая находит сумму его цифр.

(Python.

С командой for) ​.

Вика336 8 мар. 2024 г., 13:53:29 | 5 - 9 классы

Чему будет равна переменная sum после выполнения фрагмента программы :sum : = 0 ;for i : = 2 to 7 dosum : = sum + i ?

Чему будет равна переменная sum после выполнения фрагмента программы :

sum : = 0 ;

for i : = 2 to 7 do

sum : = sum + i ;

Dimasik24cm 30 янв. 2024 г., 11:29:19 | студенческий

Организуйте цикл for, счетчик которого изменяется от 100 до 200 сшагом 3?

Организуйте цикл for, счетчик которого изменяется от 100 до 200 с

шагом 3.

Рианна18122006 19 мар. 2024 г., 20:59:59 | 10 - 11 классы

Помогите найти ошибку в программеЗадача :Вставить число k (число вводится с клавиатуры) после всех элементов, больших заданного числа, а число t – перед всеми элементами, кратными 3?

Помогите найти ошибку в программе

Задача :

Вставить число k (число вводится с клавиатуры) после всех элементов, больших заданного числа, а число t – перед всеми элементами, кратными 3.

Программа :

Const n = 10 ;

Type myarray = Array[1.

30] Of Integer ;

Var m : myarray ; x, k, i, d, c, w : Integer ;

Procedure Init2(Var m : myarray) ;

Var i : Integer ;

Begin For i : = 1 To n Do begin m[i] : = random(100) ; write(m[i], ' ') end ; writeln ;

End ;

Procedure Insert2(k1, x1 : Integer ; Var m : myarray) ;

Var i : Integer ;

Begin For i : = n + k Downto k1 + 1 Do m[i + 1] : = m[i] ; m[k1 + 1] : = k ;

End ;

Procedure Insert3(k1, x1 : Integer ; Var m : myarray) ;

Var i, c : Integer ;

Begin c : = 10 ; For i : = k1 + k to c Do m[i + 1] : = m[i] ; m[k1 - 1] : = w ; c : = c + 1 ;

End ;

Procedure Print(n1 : Integer ; m : myarray) ; Var i : Integer ;

Begin For i : = 1 To n Do Write(m[i] : 3) ; Writeln ;

End ;

Begin Init2 (M) ; Writeln(' Введите число для вставки : ') ; Readln(k) ; Writeln(' Введите заданное число : ') ; Readln(d) ; For i : = n Downto 1 Do If M[i]> ; d Then Insert2(i, x, M) ; Writeln(' Введите второе заданное число : ') ; Readln(w) ; For i : = 1 to n Do If M[i]mod 3 = 0 Then Insert3(i, x, M) ; Print(n + k, M) ; {вывод массива после вставки всех элементов}

End.

Mihailova99Eleonora 28 мар. 2024 г., 12:09:12 | студенческий

В какой конструкции цикла не требуется использование составного оператора (begin…end ; ) при написании программы на языке Паскаль?

В какой конструкции цикла не требуется использование составного оператора (begin…end ; ) при написании программы на языке Паскаль?

Repeat until

for to do

for downto do

while.

Вы перешли к вопросу Напиши значение змінної S, которого она набудет после выполнения таких операторов :1) s : = 0 ; for i : = 10 downto 6 do s : = s + 1 ;2)s : = 0 ; for i : = 8 to 3 do s : = s + 1 ;3)s : = 1 ; for i : =?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.