Дан массив состоящий из 15 целых случайных чисел из промежутка от 10 до 30?

Информатика | 5 - 9 классы

Дан массив состоящий из 15 целых случайных чисел из промежутка от 10 до 30.

Провести сортировку методом пузырька по убыванию.

Ответить на вопрос
Ответы (1)
Манарша 8 сент. 2020 г., 19:47:40

Program enot ;

const m = 15 ;

var a : array[1.

M] of integer ; i, j, k : integer ;

begin for i : = 1 to m do a[i] : = random(21) + 10 ; for i : = 1 to m - 1 do for j : = 1 to m - i do if a[j] < ; a[j + 1] then begin k : = a[j] ; a[j] : = a[j + 1] ; a[j + 1] : = k end ; write ('Отсортированный массив : ') ; for i : = 1 to m do write (a[i] : 4) ;

end.

Slender2774 30 янв. 2020 г., 19:21:30 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ!

Задан целочисленный массив из 10 случайных целых чисел.

Выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

АlexеY 5 авг. 2020 г., 14:15:35 | 10 - 11 классы

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора?

Отсортировать в двумерном массиве целых случайных чисел чётные столбцы методом сортировки прямого выбора.

KR2002 25 янв. 2020 г., 18:51:06 | 5 - 9 классы

Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5?

Дан массив состоящий из 10 целых чисел, заданных случайным образом из промежутка [5.

25] найти минимальное и максимальное значения, их сумму.

Iliea0033 10 нояб. 2020 г., 02:33:37 | 5 - 9 классы

Помогите пожалуйста составить программуЗаполнить массив из 500 элементов случайными числами в интервале [0?

Помогите пожалуйста составить программу

Заполнить массив из 500 элементов случайными числами в интервале [0.

100].

Отсортировать его по возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

Вывести на экран число перестановок элементов массива в том и в другом случае.

Массив выводить на экран не нужно.

Canqez2002 17 окт. 2020 г., 09:21:28 | 10 - 11 классы

Сортировка по возрастания и по убыванию 15 чисел на паскаль?

Сортировка по возрастания и по убыванию 15 чисел на паскаль.

Бес4 13 июн. 2020 г., 06:17:03 | 10 - 11 классы

Дан массив целых чисел?

Дан массив целых чисел.

Пользователь вводит с экрана кол - во элементов в массиве.

Элементы в массиве генерируются случайно (диапазон чисел от - 100 до + 100).

Отсортировать исходный массив с помощью различных алгоритмов сортировки.

C + +.

Vika3006 20 мар. 2020 г., 19:30:55 | 10 - 11 классы

Массив целых чисел из 15 элементов?

Массив целых чисел из 15 элементов.

Заполнить случайным образом.

Упорядочить массив по убыванию.

Подсчитать количество элементов больше 10, вывести результат.

Annaborash2003 19 сент. 2020 г., 13:21:30 | 10 - 11 классы

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов?

Помогите решить задачу в Pascal Дан массив целых чисел, состоящий из 30 элементов.

Заполнить его датчиком случайных чисел.

Найти сумму отрицательных элементов.

Chislin2013 24 нояб. 2020 г., 13:42:51 | 10 - 11 классы

Объединить два случайным образом созданных массива в один упорядочить новый массив по убыванию Pascal ABC по теме : сортировка массива?

Объединить два случайным образом созданных массива в один упорядочить новый массив по убыванию Pascal ABC по теме : сортировка массива.

Girl4783 19 сент. 2020 г., 20:30:14 | 10 - 11 классы

Заполните массив С (30) случайными числами от 0 до 55 и распечатайте егоНайдите сумму элементов данного массива, больших 153?

Заполните массив С (30) случайными числами от 0 до 55 и распечатайте его

Найдите сумму элементов данного массива, больших 15

3.

Найдите максимальный элемент данного массива

4.

Отсортируйте массив С (300 по убыванию методом «пузырька».

На этой странице вы найдете ответ на вопрос Дан массив состоящий из 15 целых случайных чисел из промежутка от 10 до 30?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.