Ввести слово?

Информатика | 5 - 9 классы

Ввести слово.

Определить является ли оно палиндромом.

(Используя div)

Pascal Turbo.

Ответить на вопрос
Ответы (1)
Marksurzhenko 22 янв. 2022 г., 17:14:40

Var s : string ; l, i, k : integer ;

begin

readln(s) ;

l : = length(s) ;

k : = 0 ;

for i : = 1 to l div 2 do

if s[i] = s[l - i + 1] then k : = k + 1 ;

if k = l div 2 then writeln(s, ' - палиндром')

else writeln(s, ' - не палиндром') ;

end.

Пример :

kazak

kazak - палиндром.

Vlad211003 28 янв. 2022 г., 00:02:38 | 5 - 9 классы

1. Дано натуральное число?

1. Дано натуральное число.

Определить :

а) является ли оно чётным

б) оканчивается ли оно цифрой 7.

Дано двухзначное число.

Определить :

а) кратна ли трём его сумма цифр

б) кратна ли сумма его чисел числу а.

ПОМОГИТЕ РЕБЯТАААА!

ООЙЙ КАК СРОЧНО НАДОО.

Katiushaivanov 7 мар. 2022 г., 16:40:10 | студенческий

Написать на Pascal программу?

Написать на Pascal программу.

Определить , являеться ли число N четным двузначным числом.

Gnomik1231 8 мар. 2022 г., 13:09:47 | 10 - 11 классы

Ввести шестизначное число с клавиатуры?

Ввести шестизначное число с клавиатуры.

Проверить, является ли оно счастливым (суммы первых трех цифр равна сумме последних трех).

Yanashishee 21 апр. 2022 г., 18:50:06 | 10 - 11 классы

В Pascal ввести с клавиатуры 20 чисел?

В Pascal ввести с клавиатуры 20 чисел.

Найти среднее арифметическое отрицательных.

Mi616 27 февр. 2022 г., 04:27:02 | 10 - 11 классы

Помогите пожалуйста123 mod 10 + 123 div 10 mod 10 + 123 div 10 div 10 mod 10 =?

Помогите пожалуйста

123 mod 10 + 123 div 10 mod 10 + 123 div 10 div 10 mod 10 =.

Линка43 18 апр. 2022 г., 06:02:39 | 10 - 11 классы

Дано трехзначное число?

Дано трехзначное число.

Определить, является ли сумма его цифр кратна 3 и 5.

Написать программу на C + + и Pascal.

Liamonka 14 февр. 2022 г., 00:41:20 | 10 - 11 классы

Решение для Pascal ABCuses GraphABC ;vara : integer ;beginreadln(a) ;moveto(a, 1) ;circle(a + a div 2, 1, a div 4) ;lineto(a + a div 4, 1) ;moveto(a + (a div 4) * 3, 1) ;lineto (2 * a, 1) ;lineto(2 * ?

Решение для Pascal ABC

uses GraphABC ;

var

a : integer ;

begin

readln(a) ;

moveto(a, 1) ;

circle(a + a div 2, 1, a div 4) ;

lineto(a + a div 4, 1) ;

moveto(a + (a div 4) * 3, 1) ;

lineto (2 * a, 1) ;

lineto(2 * a, 1 + a) ;

lineto (a, 1 + a) ;

lineto (a, 1) ;

moveto (a, 1 + a) ;

lineto (a - (a div 2), 1 + 2 * a) ;

lineto(2 * a + a div 2, 1 + 2 * a) ;

lineto(2 * a, 1 + a) ;

end.

Можете рассказать пожалуйста откуда что взялось , описать что за чем, чтобы объяснить как делать!

То что вверху написано, спасибо вам большое заранее.

Predator52 16 янв. 2022 г., 00:46:27 | 10 - 11 классы

Pascal?

Pascal.

Найти все трехзначные числа - палиндромы.

Задача с использованием repeat (обязательно).

Троль27 23 мар. 2022 г., 08:12:09 | 10 - 11 классы

Написать на С + + ?

Написать на С + + .

Дано трехзначное число.

Выяснить, является ли оно палиндромом ( «оборотнем»).

Таким числом, десятичная запись которого читается одинаково слева направо и справа налево.

Севетик 24 февр. 2022 г., 09:06:12 | 5 - 9 классы

Какая из переменных может не является целой ?

Какая из переменных может не является целой ?

A : = 2 ;

b : = 4 div 7 ;

c : = - 25 ;

d : = d / 6 ;

На этой странице вы найдете ответ на вопрос Ввести слово?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 5 - 9 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.