Помогите с инфой, плесДАН МАССИВ, ПОМЕНЯТЬ МЕСТАМИ ЭЛЕМЕНТЫ, СТОЯЩИЕ НА ЧЕТНЫХ И НЕЧЕТНЫХ МЕСТАХ, КОМАНДУ ВЕТВЛЕНИЯ НЕ ИСПОЛЬЗУЕМ?

Информатика | 5 - 9 классы

Помогите с инфой, плес

ДАН МАССИВ, ПОМЕНЯТЬ МЕСТАМИ ЭЛЕМЕНТЫ, СТОЯЩИЕ НА ЧЕТНЫХ И НЕЧЕТНЫХ МЕСТАХ, КОМАНДУ ВЕТВЛЕНИЯ НЕ ИСПОЛЬЗУЕМ.

Программа для обычного паскаля.

Ответить на вопрос
Ответы (1)
Klimenkoanna87 19 сент. 2021 г., 20:54:06

Const n = 10 ;

var a : array[1.

N] of integer ;

i, h : integer ;

begin

Randomize ;

for i : = 1 to n do begin

a[i] : = random(51) ;

write(a[i], ' ') ;

end ;

writeln ;

for i : = 1 to n div 2 do

begin

h : = a[2 * i - 1] ; a[2 * i - 1] : = a[2 * i] ; a[2 * i] : = h

end ;

for i : = 1 to n do write(a[i], ' ') ;

writeln ;

end.

Пример :

8 7 12 28 22 50 15 36 6 40

7 8 28 12 50 22 36 15 40 6.

Dkdhbdmf 7 мар. 2021 г., 10:40:50 | 5 - 9 классы

Сформировать массив случайным образом вывести на экран элементы, стоящие на четных местах?

Сформировать массив случайным образом вывести на экран элементы, стоящие на четных местах.

SlavaMuhin 18 февр. 2021 г., 19:57:11 | 10 - 11 классы

Информатика?

Информатика!

Помогите написать листинг программы!

Задан одномерный массив Z(N) (N< ; = 60).

Сформировать два одномер - ных массива X и Y.

Массив Х получен делением на 2 элементов массива Z, стоящих на четных местах, а массив Y – делением на 3 элементов массива Z, стоящих на нечетных местах.

В массивах Х и У поменять местами первый и последний элементы.

Karasal1994dia 9 авг. 2021 г., 21:32:22 | 5 - 9 классы

Поменять местами элементы массива стоящие на чётных и нечетных местах (1и2, 3и 4 и тд)Решить спомощью кумира?

Поменять местами элементы массива стоящие на чётных и нечетных местах (1и2, 3и 4 и тд)

Решить спомощью кумира.

Olga0501 28 апр. 2021 г., 19:14:49 | 10 - 11 классы

Дан массив B(N), N = 7?

Дан массив B(N), N = 7.

Найти сумму значений элементов, стоящих в массиве на четных местах.

SerafimRus 16 сент. 2021 г., 20:58:08 | 5 - 9 классы

Дан массив из N элементов?

Дан массив из N элементов.

Найти сумму элементов с четными номерами и отдельно – с нечетными номерами.

В программе Pascal.

Daria20044thenicorn 22 мая 2021 г., 21:26:18 | 10 - 11 классы

ПаскальИмеется массив на 10 элементов ?

Паскаль

Имеется массив на 10 элементов .

Все элементы - натуральные числа .

Каждый четный элемент поменять местами с предыдущим .

Вывести полученный массив.

НатальяDhajdj 30 апр. 2021 г., 19:44:47 | 10 - 11 классы

(задачу решить на языка Паскаля)В заданном одномерном массиве поменять местами соседние элементы, стоящие на четных местах, с элементами, стоящими на нечетных местах?

(задачу решить на языка Паскаля)

В заданном одномерном массиве поменять местами соседние элементы, стоящие на четных местах, с элементами, стоящими на нечетных местах.

Hadasa0687 8 июл. 2021 г., 03:21:46 | 5 - 9 классы

Составьте программу вычисления суммы элементов массива , стоящих на четных местах?

Составьте программу вычисления суммы элементов массива , стоящих на четных местах.

Lanusic 6 сент. 2021 г., 23:17:00 | 5 - 9 классы

Срочно?

Срочно.

Дан массив s из n чисел, значения элементов которых находится на интервале от 0 до 400.

Заменить все четные элементы стоящие на нечетных местах на противоположные.

Igor38 23 июл. 2021 г., 04:00:48 | 5 - 9 классы

Помогите решить 2 задачи по инфе1?

Помогите решить 2 задачи по инфе

1.

Дан массив из N элементов, вывести минимальней элемент массива.

2. Дан массив из 30 элементов, поменять местами макс.

И мин.

Элемент массива.

На этой странице находится вопрос Помогите с инфой, плесДАН МАССИВ, ПОМЕНЯТЬ МЕСТАМИ ЭЛЕМЕНТЫ, СТОЯЩИЕ НА ЧЕТНЫХ И НЕЧЕТНЫХ МЕСТАХ, КОМАНДУ ВЕТВЛЕНИЯ НЕ ИСПОЛЬЗУЕМ?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.