В каждом столбце матрицы найти минимальный элемент и вычислить сумму этих элементов?

Информатика | 10 - 11 классы

В каждом столбце матрицы найти минимальный элемент и вычислить сумму этих элементов.

Двумерный массив.

Pascal ABC.

Ответить на вопрос
Ответы (1)
Pushkerskiy 10 окт. 2021 г., 01:21:37

Const ns = 20 ;

var a : array[1.

Ns, 1.

Ns] of integer ; m, n, i, j : byte ; min, sum : integer ;

begin

randomize ;

readln(m, n) ;

writeln('Исходная матрица : ') ;

for i : = 1 to m do

begin for j : = 1 to n do begin a[i, j] : = random(20) ; write(a[i, j] : 3) ; end ; writeln ;

end ;

writeln('Минимальные элементы столбцов : ') ;

sum : = 0 ;

for j : = 1 to n do

begin min : = a[1, j] ; for i : = 1 to m do if a[i, j].

Loskutnic 5 февр. 2021 г., 03:18:00 | 10 - 11 классы

Pascal : Дан двумерный массив, который содержит не более 10 строк и не более 10 столбцов?

Pascal : Дан двумерный массив, который содержит не более 10 строк и не более 10 столбцов.

Найти сумму элементов, которые расположены за максимальным элементом.

Irinadiger 1 июн. 2021 г., 04:19:04 | 5 - 9 классы

Дана матрица размера m×n?

Дана матрица размера m×n.

Найти ее максимальный элемент.

Pascal ABC.

Apt1 9 апр. 2021 г., 15:17:47 | 10 - 11 классы

Cделать программу в Pascal по заданию : "Найти в двумерном массиве сумму массива, сумму элементов по столбцам и среднее арифметическое по строкам"?

Cделать программу в Pascal по заданию : "Найти в двумерном массиве сумму массива, сумму элементов по столбцам и среднее арифметическое по строкам".

Anastasiayolik 7 апр. 2021 г., 23:48:03 | 10 - 11 классы

Дан двумерный массив?

Дан двумерный массив.

В каждой его строке найти координаты минимального элемента.

Если элементов с минимальным значением в строке несколько, то должны быть найдены координаты самого правого из них.

Heda24s 24 янв. 2021 г., 09:22:48 | 10 - 11 классы

Pascal :Дан двумерный массив, который содержит не более 10 строк и не более 10 столбцов?

Pascal :

Дан двумерный массив, который содержит не более 10 строк и не более 10 столбцов.

Найти суммы отрицательных элементов каждого столбца.

Coraline328 3 июл. 2021 г., 20:17:31 | 10 - 11 классы

Дана матрица C(X, Y)?

Дана матрица C(X, Y).

Найти в каждом столбце отдельно количество элементов кратных 7 и среднее арифметическое значение этих элементов.

Tot04062000ttor 23 апр. 2021 г., 00:29:15 | 10 - 11 классы

Pascal?

Pascal.

Составить программу для вычисления суммы элементов < ; 3 в каждом столбце матрицы Z(6х3).

Alena98 18 июн. 2021 г., 04:38:04 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Пользователь вводит двумерный массив, количество строк 3 , 3 столбцов.

Определить сумму всех элементов массива ; Определить сумму элементов 2 строки.

Написать программу в Pascal.

Petrenckovaler 23 июн. 2021 г., 22:21:43 | 10 - 11 классы

Дан двумерный массив?

Дан двумерный массив.

В каждом его столбце найти сумму отрицательных элементов.

Помогите пожайлуста помогите, нужно срочно.

Паскаль.

Princes81 28 июл. 2021 г., 22:06:05 | 10 - 11 классы

Python?

Python!

Нужно составить программы к задачам.

Тема : "Двумерные массивы"

1) Даны три матрицы разных порядков.

Найти среди них матрицу с наибольшим количеством чётных элементов.

2) В двумерном массиве натуральных случайных чисел от 0 до 199 найти количество всех трехзначных чисел, сумма которых кратна 6.

3) Дан массив из n x m элементов (т.

Е. n и m указываем свои значения), найти сумму элементов каждого столбца.

Любую одну какую нибудь.

На этой странице находится вопрос В каждом столбце матрицы найти минимальный элемент и вычислить сумму этих элементов?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.