Задача 2?

Информатика | 5 - 9 классы

Задача 2.

Замечательная игра Вот Уже N дней подряд Руслан играет в замечательную игру .

Каждый день у него получаться сыграть ровно 7 раз .

В конце каждой игры он набирает от 0 до 10 очков .

Игра считается результативной если в ней было набрано более 3 очков Помогите подсчитать Руслану сумму очков всех результативных игр для каждого дня.

Формат ввода :

N(1.

Ответить на вопрос
Ответы (1)
Maksim295 17 мая 2022 г., 17:44:08

Const m = 7 ;

var

a : array of array of integer ;

ans : array of integer ;

n, i, j : integer ;

begin

readln(n) ;

SetLength(a, n) ;

for i : = 0 to n - 1 do SetLength(a[i], m) ;

SetLength(ans, n) ;

for i : = 0 to n - 1 do

begin

for j : = 0 to m - 1 do read(a[i, j]) ;

readln ;

end ;

for i : = 0 to n - 1 do

for j : = 0 to m - 1 do if a[i, j]>3 then ans[i] : = ans[i] + a[i, j] ;

for i : = 0 to n - 1 do writeln(ans[i] : 4) ;

writeln ;

end.

Пример :

3

0 1 2 3 4 5 6

7 7 7 7 7 7 7

0 1 2 3 3 2 10 15 49 10.

380665208994 14 янв. 2022 г., 14:06:51 | 5 - 9 классы

Создать текстовую игру в PythonНаписать код данной игры в программе PythonИгрок перемещается по комнатам замка?

Создать текстовую игру в Python

Написать код данной игры в программе Python

Игрок перемещается по комнатам замка.

В каждой комнате находится три двери.

Одна дверь ведет в комнату

с драконом, другая - в комнату с живой водой, третья - пустая комната.

Если игрок попадает в комнату с дракном - жизнь отнимается.

Если игрок попадает в комнату с живой водой - жизнь добавляется.

Если игрок попадает в пустую комнату - ничего не происходит.

Игра продолжается до тех пор, пока у игрока есть жизни.

Переход из одной команты в другую добавляет 100 баллов.

Игра начинается с 3 жизнями и 0 баллами.

Задача игры - набрать наибольшее количество баллов.

Olga8104 19 янв. 2022 г., 12:46:29 | 5 - 9 классы

В летнем лагере отдыхало 90 семиклассников?

В летнем лагере отдыхало 90 семиклассников.

8 из них не любят компьютерные игры.

52 семиклассника предпочитают квесты, 63 — симуляторы.

Сколько ребят с одинаковым удовольствием играют и в квесты, и в симуляторы?

Ивсё 17 февр. 2022 г., 04:06:53 | 5 - 9 классы

Известны очки (3, 1 или 0), полученные футбольной командой за ряд игр в порядке их проведения?

Известны очки (3, 1 или 0), полученные футбольной командой за ряд игр в порядке их проведения.

Что было раньше : первый выигрыш (3 очка) или первый проигрыш (0 очков)?

В первой строке вводится количество проведенны командой игр (не более 15)

Во второй строке вводятся очки за каждую проведенную игру

Если выигрыш встретился раньше, то вывести слово WIN

Если проигрыш встретился раньше, то вывести слово LOSE

НА С + +.

Angelina8586 22 янв. 2022 г., 04:01:39 | 5 - 9 классы

Когда следует выполнить архивациу?

Когда следует выполнить архивациу?

А. Когда не хватает место на диске.

В. Когда файлов много.

Г. Когда файлов мало.

Е. Когда играете в игры.

ПОМОГИТЕ ПОЖАЛУЙСТА!

Zqk 6 апр. 2022 г., 18:26:54 | 5 - 9 классы

Нужна ваша помощь!Кто изобрел игру“Тетравекс”??

Нужна ваша помощь!Кто изобрел игру“Тетравекс”?.

Skarllett 16 мая 2022 г., 15:33:38 | 5 - 9 классы

Коля и Вася играют в следующую игру : они одновременно показываютнесколько пальцев одной руки , еслисуммарное количествопоказанныхпальцев чётно , то выигрывает Коля, в противном случае - Вася?

Коля и Вася играют в следующую игру : они одновременно показываютнесколько пальцев одной руки , еслисуммарное количествопоказанныхпальцев чётно , то выигрывает Коля, в противном случае - Вася.

Требуетсяопределить, выйграл ли вася.

Stfnj 11 февр. 2022 г., 04:13:20 | 5 - 9 классы

В игре море фантазии корабль движется только по цветным линиям?

В игре море фантазии корабль движется только по цветным линиям.

Fedi221 11 мар. 2022 г., 02:19:32 | 5 - 9 классы

Куда закачиваются игры на ноутбуке на оперативную память или на собственную?

Куда закачиваются игры на ноутбуке на оперативную память или на собственную.

Zazmievadg 15 мар. 2022 г., 14:56:24 | 5 - 9 классы

Игра «Sounder Crike» требует для установки на жёсткий диск 4 Гбайт свободного места?

Игра «Sounder Crike» требует для установки на жёсткий диск 4 Гбайт свободного места.

На жёстком диске сейчас 800 Мбайт свободного места.

Какое пространство необходимо освободить на жёстком диске, чтобы игра поместилась?

Mark20021 6 февр. 2022 г., 07:12:26 | 5 - 9 классы

В каталоге зарегистрированы файлы : ball?

В каталоге зарегистрированы файлы : ball.

Exe, ball.

Txt, ball.

Bmp, ball.

Mid. а)​Какой файл нужно запустить на выполнение, чтобы начать игру BALL?

Б)​В каком файле может храниться инструкция к игре?

В)​В каком файле может храниться заставка к игре?

Г) В каком файле может храниться музыкальное сопровождение к игре?

Ball.

Exe 35600 10.

05. 93 10 : 30 ball.

Txt 2050 12.

05 : 93 18.

50 ball.

Rez 1700 25.

09. 96 14.

25.

Перед вами страница с вопросом Задача 2?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.