С + +СРОЧНО?

Информатика | 5 - 9 классы

С + +

СРОЧНО!

Один из методов криптографии заключается в измерении частоты появляения буквы в тексте.

Необходимо написать программу, вычисляющую какую часть текста составляет указанная буква.

Т. е.

Отношения количества встречания одной буквы к количеству букв в тексте.

Ответить на вопрос
Ответы (2)
Dadsasda 3 мая 2022 г., 08:39:34

/ / на вход в командной строке нужно подать название файла с текстом, в стандартном потоке указанный символ

#include

int

main(int argc, char * * argv)

{ char g_ch = getchar() ; FILE * fin = fopen(argv[1], "rt") ; int count = 0 ; int count_all = 0 ; char ch = 0 ; while ((ch = fgetc(fin)) !

= EOF) { if (ch = = g_ch) { count + + ; } count_all + + ; } printf("%f \ n", 1.

* count / count_all) ; return fclose(fin) ;

}.

Elor228 3 мая 2022 г., 08:39:41

#include

#include

using namespace std ;

int main()

{ string text = { "hello my name is paperman" } ; / / наш текст string word = { "" } ; / / слово для сравнения cin >> word ; / / просим ввести сравниваемую букву map key_map ; for(auto i : text) { if (word.

Find(tolower(i)) !

= string : : npos) { + + key_map[tolower(i)] ; } } for(auto &pair : key_map) { cout.

Ksubum 6 февр. 2022 г., 13:40:46 | 5 - 9 классы

Помогите, пожалуйста, найти ошибку в программе?

Помогите, пожалуйста, найти ошибку в программе.

Не все тесты проходит на сайте.

Текст задачи :

Текст на английском языке записан в массиве a[1.

1000] of char.

Помимо английских букв, в нем могут встречаться пробелы и знаки препинания.

В массиве b['A'.

'Z'] of integer получите сведения о том, сколько каких букв встречается в этом тексте.

При подсчете строчные и прописные буквы не различать.

Входные данные

На вход программе сначала подается значение n1000 — количество букв в тексте.

В следующей строке входных данных расположены сами буквы (без разделителей).

Выходные данные

Выдайте 26 чисел — значения элементов массива b.

Сама программа :

#include

using namespace std ;

int main()

{ int b[26], N, i, k ; char a[1000], m ; cin>>N ; for(i = 0 ; i { cin>>a[i] ; a[i] = toupper(a[i]) ; } for(m = 'A' ; m.

ЯТоТДуРаК 28 февр. 2022 г., 12:33:44 | 5 - 9 классы

Определите текст радиограммы?

Определите текст радиограммы.

В радиограмме есть только эти буквы :

Е .

В . - -

И .

Н - .

Л . - .

Т -

Вот сама радиограмма :

.

- - .

- . - - .

- . - .

Megosport1994 21 мар. 2022 г., 05:27:58 | 5 - 9 классы

Какое количество информации​ несет сообщение состоящее из 25, символов записанное буквами из 64 - символьного алафитаСРОЧНО ПОМОГИТЕ?

Какое количество информации​ несет сообщение состоящее из 25, символов записанное буквами из 64 - символьного алафита

СРОЧНО ПОМОГИТЕ!

Vladimircevaul 6 февр. 2022 г., 21:20:22 | 5 - 9 классы

Текст составленный буквами из 256 - символов алфавита, содержит 46 символов?

Текст составленный буквами из 256 - символов алфавита, содержит 46 символов.

Каков его информационный объем?

Привет404 15 мар. 2022 г., 11:33:28 | 10 - 11 классы

В некоторой стране автомобильный номер длиной 6 символов составляют из заглавных букв (используются только 20 различных букв) и десятичных цифр в любом порядке?

В некоторой стране автомобильный номер длиной 6 символов составляют из заглавных букв (используются только 20 различных букв) и десятичных цифр в любом порядке.

Каждый такой номер в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит).

Определите объем памяти, отводимый этой программой для записи 30 номеров.

Nikalav2006mailru 5 мая 2022 г., 05:44:12 | 5 - 9 классы

У племени (чичевоков) в алфавите 24 буквы и 84 цифры, знаков припинания и арифметических знаков нет?

У племени (чичевоков) в алфавите 24 буквы и 84 цифры, знаков припинания и арифметических знаков нет.

Какое минимальное количество двоичных разрядов им необходимо для кодирования всех символов ?

Coggoiw 11 мар. 2022 г., 21:26:50 | 5 - 9 классы

Алфавит племени Мумбо - Юмба состоит из 32 стмволов?

Алфавит племени Мумбо - Юмба состоит из 32 стмволов.

Какое количество информации несёт одна буква этого алфавита?

L1zavetaaa 9 мая 2022 г., 15:24:26 | 10 - 11 классы

Сообщение, записанное буквами 32 - символьного алфавита, содержит количество информации в тексте - 30 байтов?

Сообщение, записанное буквами 32 - символьного алфавита, содержит количество информации в тексте - 30 байтов.

Сколько символов в тексте?

Rasist228 26 мар. 2022 г., 03:07:39 | 5 - 9 классы

Какое количество информации в сообщении из 20 символов, записанном буквами из 256 - символического алфавита?

Какое количество информации в сообщении из 20 символов, записанном буквами из 256 - символического алфавита?

Hikaa 5 янв. 2022 г., 23:27:56 | 5 - 9 классы

Сообщение, записанное буквами 32 - х символьного алфавита, выглядит как одно слово :ИНФОРМАТИКАКакое количество информации оно несёт?

Сообщение, записанное буквами 32 - х символьного алфавита, выглядит как одно слово :

ИНФОРМАТИКА

Какое количество информации оно несёт?

Вопрос С + +СРОЧНО?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.