1) Задан массив из N чисел?

Информатика | 10 - 11 классы

1) Задан массив из N чисел.

Найти среднее арифметическое.

2) Найти номер наибольшего элемента массива размером МхN.

Ответить на вопрос
Ответы (1)
Lmolog1205 3 янв. 2022 г., 08:45:20

1) Задан массив из N чисел.

Найти среднее арифметическое.

Var a : array[1.

99999] of integer ;

i, n, summa : integer ;

srednee : real ;

begin

writeln('Введите размерность массива') ; readln(n) ;

for i : = 1 to n do

Begin

Writeln('Введите ', i, ' элемент массива : ') ; readln(a[i]) ;

summa + = a[i] ;

end ;

srednee : = summa / n ;

Writeln('Среднее арифметическое : ', srednee) ;

end.

2) Найти номер наибольшего элемента массива размером МхN.

Var a : array[1.

99999, 1.

9999] of integer ;

m, n, i, i2, max, n1, n2 : integer ;

begin

writeln('Введите длину массива M : ') ; readln(m) ;

writeln('Введите ширину массива N : ') ; readln(n) ;

for i : = 1 to m do

Begin

for i2 : = 1 to n do

Begin

Writeln('Введите элемент массива : ') ; readln(a[i, i2]) ;

If a[i, i2]>max then

Begin

max : = a[i, i2] ;

n1 : = m ;

n2 : = n ;

end ;

end ;

end ;

Writeln('Номер максимального элемента массива : ', n1, ' столбец ', n2, ' строка') ;

end.

Daria006 22 янв. 2022 г., 16:14:21 | 5 - 9 классы

Как найти в двумерном массиве наибольшее число этого массива?

Как найти в двумерном массиве наибольшее число этого массива?

Паскаль(.

Макс12908478985 26 янв. 2022 г., 16:34:04 | 10 - 11 классы

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива?

В одномерном массиве на 10 элементов, сформированном через генератор случайных чисел, найти средне - арифметическое среди наибольшего и наименьшего элемента массива.

Начертить алгоритм и написать программу.

Bal1 2 мар. 2022 г., 03:03:21 | 5 - 9 классы

СРОЧНОО 1?

СРОЧНОО 1.

НАйти произведение элементов с нечетными номерами(паскаль, массивы)

2.

Найти сумму четных элементов массива(паскаль, массивы).

AlinaMarks 27 апр. 2022 г., 10:14:26 | 5 - 9 классы

Задан целочисленный массив размера N?

Задан целочисленный массив размера N.

Определить число элементов в массиве кратных 2 (написать на pascal).

Alicka762 30 янв. 2022 г., 23:07:20 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

1)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти среднее арифметическое нечетных трехзначных чисел, записанных в этом массиве.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

2)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 100.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести произведение элементов массива, которые имеют четное значение и не оканчиваются на 0.

Dan34111 7 янв. 2022 г., 10:14:06 | студенческий

Помогите пожалуйста задание, надо код для паскали?

Помогите пожалуйста задание, надо код для паскали.

Дан одномерный массив, найти сумму всех четных элемент массива, кратных заданному числу.

Максим146464647447 6 апр. 2022 г., 04:28:08 | 10 - 11 классы

В паскаль АВСЗаполнить массив А[1?

В паскаль АВС

Заполнить массив А[1.

8] числами, вводимыми с клавиатуры.

Найти среднее арифметическое четных элементов.

Марина1806 19 июн. 2022 г., 02:37:13 | 5 - 9 классы

C + +найти наибольший отрицательный элемент массива n(x) и его порядковый номерПомогите, пожалуйста?

C + +

найти наибольший отрицательный элемент массива n(x) и его порядковый номер

Помогите, пожалуйста!

Котик428 26 мар. 2022 г., 21:03:39 | 5 - 9 классы

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10)?

Задан целочисленный одномерный массив с именем А, размером N с помощью датчика случайных чисел на промежутке (0 ; 10).

1. Найти минимальные элементы в массиве.

2. Найти порядковый номер этого элемента.

7vlad2003 14 мар. 2022 г., 04:43:21 | 5 - 9 классы

Даю 25 баллов?

Даю 25 баллов!

Дан массив из 20 вещественных чисел.

Найти среднее арифметическое чисел элементов массива и заменить на него максимум и минимум элементов массива стоящие на местах кратных 5.

Вопрос 1) Задан массив из N чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.