Используйте одномерный массив для решения следующей задачи?

Информатика | 5 - 9 классы

Используйте одномерный массив для решения следующей задачи.

Прочитайте 20 чисел, каждое из которых находится в диапазоне от 10 до 100 включительно.

После того, как прочли очередное число, напечатайте его, но только в том случае, если оно не дублирует ранее прочитанные числа.

Предусмотрите "наихудший" случай, когда все 20 чисел различны.

Используйте наименьший возможный массив для решения этой задачи.

Паскаль!

Дам 20 баллов.

Ответить на вопрос
Ответы (1)
Meowgirl23 25 янв. 2022 г., 04:50:41

Для того, чтобы узнать, не встречалось ли 20 - е число раньше, надо помнить, какие числа были до этого.

Так что без массива с меньшим размером, чем 19, не обойтись (на самом деле это так, только если в каждом элементе массива хранить только одно число.

Но мы так и будем делать).

Алгоритм для решения задачи выберем простой : записываем все предыдущие числа в массив и для каждого следующего числа проходим по массиву.

Var a : array[1.

19] of byte ; i, j, t : byte ;

begin for i : = 1 to 20 do begin read(t) ; if i < 20 then a[i] : = t ; for j : = 1 to i - 1 do if a[j] = t then t : = 0 ; if t > 0 then write(t, ' ') ; end ;

end.

Пример ввода :

1 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 10

Пример вывода :

1 2 3 4 5 6 7 8 9 10.

Sony1111111 2 янв. 2022 г., 16:10:51 | 5 - 9 классы

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент вмассиве, размерностью N, сформированном пользователем?

Задача №1 : Вывести на экран сообщение, есть ли хотя бы 1 отрицательный элемент в

массиве, размерностью N, сформированном пользователем.

Задача №2 : Дан одномерный массив вещественных чисел в диапазоне от 0 до 1.

Определите сумму и среднее арифметическое его элементов.

Задача №3 : Дан целочисленный одномерный массив, сформированный случайными

числами от 0 до 50.

Подсчитайте, сколько раз встречается в этой таблице число, заданное

пользователем.

Goha12 4 янв. 2022 г., 03:35:24 | 5 - 9 классы

Записать задачи на языке Паскаль (используются циклы)1?

Записать задачи на языке Паскаль (используются циклы)

1.

Дан массив А имеющий 100 элементов.

Заполнен в интервале - 400 до 70.

Заменить числа в массиве большие К на само число К

2.

Дан массив А, имеющий 50 элементов.

Заполнен в интервале от - 100 до 10.

Посчитать количество положительных чисел.

Kostolom9904 8 янв. 2022 г., 13:45:37 | 10 - 11 классы

Помогите решить задачу в Delhi?

Помогите решить задачу в Delhi.

Дано трехзначное число, в котором все цифры различны.

Получить шесть чисел, образованных при перестановке цифр заданного числа.

Adelina5d 21 янв. 2022 г., 07:00:01 | 5 - 9 классы

Просуммировать все нечётные числа в диапазоне, который введет пользователь с клавиатуры?

Просуммировать все нечётные числа в диапазоне, который введет пользователь с клавиатуры.

Используйте цикл с предусловием(Паскаль ).

Срочно.

Littlesong2 17 февр. 2022 г., 15:11:12 | 10 - 11 классы

В паскале?

В паскале.

Изменить программу так, что бы она находила : 1)сумму четырёх чисел

2)произведения чисел

3)квадрат каждого числа.

MARINABARDYMOV 25 янв. 2022 г., 02:50:21 | 5 - 9 классы

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль?

Дан одномерный массив [ - 50 : 50], нужно вывести числа больше 7, программа на Паскаль.

Sergo2001 2 мар. 2022 г., 16:36:34 | 5 - 9 классы

Дано несколько чисел?

Дано несколько чисел.

Вычислите их сумму.

Сначала вводите количество чисел N, затем вводится ровно N целых чисел.

Какое наименьшее число переменных нужно для решения этой задачи?

Входные данные

В первой строке вводится натуральное число N - количество чисел.

В следующих N строках вводится по одному целому числу.

Выходные данные

Выведите ответ на задачу.

Примеры

входные данные

2

235

56

выходные данные

291

решение для паскаля.

Магаме 18 апр. 2022 г., 18:20:28 | 5 - 9 классы

Cоставьте блок - схему алгоритма решения задачи?

Cоставьте блок - схему алгоритма решения задачи.

Введите число X, если оно меньше нуля, то умножьте его на 3, в противном случае увеличьте его в два раза.

Желательно скинте фотку).

Аноним216 9 янв. 2022 г., 16:00:15 | 10 - 11 классы

Чисел не принадлежащих промежутку[X, Y), подсчитать количество отрицательных чисел, стоящих на четных местах?

Чисел не принадлежащих промежутку[X, Y), подсчитать количество отрицательных чисел, стоящих на четных местах.

Паскаль, одномерный массив.

Coolgirlgroup 12 апр. 2022 г., 17:54:54 | 5 - 9 классы

Программная реализация ветвящихся алгоритмов?

Программная реализация ветвящихся алгоритмов.

Задание 1.

Создать программу для решения задачи согласно варианту :

Заданы числа a и b.

Если a положительное, то найти их произведение и вывести в формате «Произведение чисел … и … равно …», в остальных случаях найти сумму и вывести в формате «Сумма чисел … и … равна …».

На этой странице находится вопрос Используйте одномерный массив для решения следующей задачи?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.