Дано N (N - натуральное число) целых чисел от 1 до 255?

Информатика | студенческий

Дано N (N - натуральное число) целых чисел от 1 до 255.

Определить среди них числа, запись которых состоит только из одинаковых цифр.

(с циклом нужно сделать).

Ответить на вопрос
Ответы (1)
Jekamaximum 22 янв. 2022 г., 07:23:01

Program odinakov ;

var i, it, il : integer ; t : boolean ;

begin

for i : = 1 to 255 do

begin

t : = true ;

it : = i ;

il : = i mod 10 ;

while it 0 do

begin

if it mod 10 il then

begin

t : = false ;

break ;

end ;

it : = it div 10 ;

end ;

if t then writeln(i) ;

end ;

end.

Poltoratskayan 22 янв. 2022 г., 23:28:30 | 10 - 11 классы

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4?

Написать программу, которая определяет, есть ли среди цифр натуральное число 2236 цифра 4.

Паскаль.

Vlad211003 28 янв. 2022 г., 00:02:38 | 5 - 9 классы

1. Дано натуральное число?

1. Дано натуральное число.

Определить :

а) является ли оно чётным

б) оканчивается ли оно цифрой 7.

Дано двухзначное число.

Определить :

а) кратна ли трём его сумма цифр

б) кратна ли сумма его чисел числу а.

ПОМОГИТЕ РЕБЯТАААА!

ООЙЙ КАК СРОЧНО НАДОО.

Nazeli2121 26 апр. 2022 г., 02:27:36 | 5 - 9 классы

Помогите с задачками по С + +Среди N целых положительных чисел не больше 1000 найти числа снаибольшей суммой цифр и наименьшей?

Помогите с задачками по С + +

Среди N целых положительных чисел не больше 1000 найти числа с

наибольшей суммой цифр и наименьшей.

Если таких чисел несколько,

то следует выбирать те, что идут в перечне первыми.

В первой строке дано число N (N.

12364578 12 янв. 2022 г., 08:39:57 | 5 - 9 классы

Нужно на C + +Дано число?

Нужно на C + +

Дано число.

В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным.

В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.

Программа получает на вход одно длинное натуральное число.

Длина числа может достигать 100 цифр.

Программа должна вывести другое натуральное число, удовлетворяющее условиям :

1)Новое число должно отличаться от данного ровно одной цифрой.

2)Новое число должно делиться на 3.

3)Новое число должно быть максимально возможным из всех таких чисел.

Kristinaplotni2 28 мар. 2022 г., 08:53:01 | 5 - 9 классы

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр?

Вася подсчитал сумму цифр натурального числа N , а затем сумму цифр у полученной суммы цифр.

Какое число он получил?

Входные данные

Вводится одно натуральное число N , меньшее 10 000 .

Выходные данные

Выведите одно натуральное число — ответ в задаче.

НУЖНО СДЕЛАТЬ НА PASCAL ABC.

Anonimno228 5 янв. 2022 г., 09:14:52 | 5 - 9 классы

Помогите решить?

Помогите решить.

Всё в с + + , для code blocks.

1. Вычислите сумму данных 100 натуральных чисел.

Вводятся 100 чисел, сумму которых необходимо посчитать.

2. Вводится число N, а затем N чисел.

Подсчитайте, сколько среди данных N чисел нулей.

3. Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел.

Вводится число N, а затем N чисел.

Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.

Coollyudmila202 11 апр. 2022 г., 05:34:32 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

Panin1 12 февр. 2022 г., 09:03:01 | 10 - 11 классы

Написать программу в С + + Дано натуральное число?

Написать программу в С + + Дано натуральное число.

Определить, сколько раз в нём встречается максимальная цифра.

Assertivee 1 февр. 2022 г., 23:09:51 | 5 - 9 классы

Дано натуральное число n (n < 9999)?

Дано натуральное число n (n < 9999).

Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр).

Например, в числе 3678 все цифры различны, в числе 0023 — нет.

Vasinsasha92 23 мая 2022 г., 15:45:55 | 10 - 11 классы

35 балов?

35 балов!

Помогите пожалуйста с информатикой, решить задачи в бейсике.

1)дано целое число, определить оканчивается ли оно чётной цифрой.

2) проверить.

Принадлежит ли число , введённое с клавиатуры.

Интервалу ( - 5, 3).

3) дано двузначное число.

Определить является ли его сумма цифр двузначным числом.

4) дано двузначное число, определить больше ли числа А сумма его цифр.

5) дано двузначное число, определить кратна ли трём сумма его цифр.

6) дано двузначное число.

Определить кратна ли сумма его цифр числу А.

7)дано двузначное число.

Определить водит ли в него цифра 3.

8)дано двузначное число определить какая из его цифр больше : первая или вторая.

9)даны 4 вещественных числа.

Определить сколько из них отрицательных.

Вы находитесь на странице вопроса Дано N (N - натуральное число) целых чисел от 1 до 255? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся студенческий. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.