Напишите программу сложения, вычитания и умножения двух двоичных чисел?

Информатика | 5 - 9 классы

Напишите программу сложения, вычитания и умножения двух двоичных чисел.

Предложите способ проверки результата : 1011 и 110.

Ответить на вопрос
Ответы (1)
Antube99 18 дек. 2021 г., 10:48:04

Const Rn : String[36] = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ' ;

Function DecToN(a : Longint ; Raz : Byte) : String ;

Begin If a>Raz - 1 then DecToN : = DecToN(a div Raz, Raz) + Rn[(a mod Raz) + 1] else DecToN : = Rn[a + 1] ;

end ;

Function NToDec(a : String ; Raz : Byte) : Longint ;

Begin If Length(a)>0 then NToDec : = Pos(a[Length(a)], Rn) - 1 + Raz * NToDec(Copy(a, 1, Length(a) - 1), Raz) else NToDec : = 0 ;

end ;

Var a, b : String ;

Begin a : = '1011' ; b : = '110' ; Writeln('a = ', a, ' (bin) = ', NToDec(a, 2), ' (dec)') ; Writeln('b = ', b, ' (bin) = ', NToDec(b, 2), ' (dec)') ; Writeln(a + ' + ' + b + ' = ', DecToN(NToDec(a, 2) + NToDec(b, 2), 2), ' (bin) ', NToDec(a, 2) + NToDec(b, 2), ' (dec)') ; Writeln(a + ' - ' + b + ' = ', DecToN(NToDec(a, 2) - NToDec(b, 2), 2), ' (bin) ', NToDec(a, 2) - NToDec(b, 2), ' (dec)') ; Writeln(a + ' * ' + b + ' = ', DecToN(NToDec(a, 2) * NToDec(b, 2), 2), ' (bin) ', NToDec(a, 2) * NToDec(b, 2), ' (dec)') ;

end.

Antonovaluu 30 мая 2021 г., 06:36:04 | 10 - 11 классы

Выполнить операцию сложения и вычитания для двоичных чисел (101110101 и IOIII)?

Выполнить операцию сложения и вычитания для двоичных чисел (101110101 и IOIII).

Проверить вычисления в десятичной системе.

Alusik2000 20 июн. 2021 г., 00:45:14 | 10 - 11 классы

Помогите решить Выполните сложение двух двоичных двухбайтных знаковых чисел и представьте результат в виде шестнадцатеричного двухбайтного знакового числа : 11111100101111112 + 00001011110101112?

Помогите решить Выполните сложение двух двоичных двухбайтных знаковых чисел и представьте результат в виде шестнадцатеричного двухбайтного знакового числа : 11111100101111112 + 00001011110101112.

Tsaturyayan51 28 янв. 2021 г., 15:41:15 | 5 - 9 классы

Произаедите сложение вычитание умножение и деление двоичныз чисел 101010(2) и 10(2)?

Произаедите сложение вычитание умножение и деление двоичныз чисел 101010(2) и 10(2).

Вася611 25 мар. 2021 г., 16:20:00 | 5 - 9 классы

Написать программу умножения двух целых чисел?

Написать программу умножения двух целых чисел.

123456317 5 мар. 2021 г., 22:16:29 | 5 - 9 классы

Как сделать программу в кумире сложение двух чисел на клавиатуре?

Как сделать программу в кумире сложение двух чисел на клавиатуре?

Помогите!

Donya1717 5 июн. 2021 г., 22:06:13 | 5 - 9 классы

Чему равен результат сложения чисел 1000 и 111 в двоичной системе?

Чему равен результат сложения чисел 1000 и 111 в двоичной системе?

Jnwalker 27 июн. 2021 г., 14:15:01 | 5 - 9 классы

Выполните сложение двоичных чисел и произведите проверку результатов , переведя их в десятичную систему а)10 + 101?

Выполните сложение двоичных чисел и произведите проверку результатов , переведя их в десятичную систему а)10 + 101.

Б)1011 + 10.

С)11101 + 101.

Yaybildan 17 окт. 2021 г., 07:15:13 | 5 - 9 классы

Задание : Даны десятичные числа ?

Задание : Даны десятичные числа .

1. Перевести эти числа в двоичную , восьмеричную и шестнадцать рисую системы счисления ( с проверкой)

2.

Выполните сложения полученных двоичных чисел.

Полученный результат перевести в десятичную , восьмеричную и шестнадцатиричную системы счисления.

3. Выполните вычитание полученных двоичных чисел.

Полученный результат перевести в десятичную, восьмеричную и шестнадцатиричную системы счисления.

Числа : 29 и 31 .

Помогите пожалуйста оооочень срочно.

Завтра сдать надо.

И с проверкой обязательно, без нее работы не принимают.

Умоляю помогите буду благодарна).

Nsnsnskkskskska 6 июн. 2021 г., 13:54:32 | студенческий

Необходима ваша помощь?

Необходима ваша помощь.

Я не в зуб ногой.

Выполните сложение, вычитание и умножение чисел 10102 и 1011012 в двоичной системе счисления.

Требования : Ответы на вопросы контрольного задания должны быть развернутыми и полными.

Pepsika1 24 июн. 2021 г., 16:21:56 | студенческий

Помогите?

Помогите!

Выполните сложение, вычитание и умножение чисел 10102 и 1011012 в двоичной системе счисления.

Просьба сделать полностью и подробно.

Вы зашли на страницу вопроса Напишите программу сложения, вычитания и умножения двух двоичных чисел?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.