Записать задачи на языке Паскаль (используются циклы)1?

Информатика | 5 - 9 классы

Записать задачи на языке Паскаль (используются циклы)

1.

Дан массив А имеющий 100 элементов.

Заполнен в интервале - 400 до 70.

Заменить числа в массиве большие К на само число К

2.

Дан массив А, имеющий 50 элементов.

Заполнен в интервале от - 100 до 10.

Посчитать количество положительных чисел.

Ответить на вопрос
Ответы (1)
Pchelkinnikosh 4 янв. 2022 г., 03:35:28

1)

const n = 100 ;

var a : array[1.

N] of integer ;

i, k : integer ;

begin

Randomize ;

writeln('Массив A : ') ;

for i : = 1 to n do

begin

a[i] : = random(471) - 400 ;

write(a[i] : 5) ;

end ;

writeln ;

write('k = ') ;

readln(k) ;

for i : = 1 to n do

if a[i]>k then a[i] : = k ;

writeln('Измененный массив : ') ;

for i : = 1 to n do write(a[i] : 5) ;

writeln ;

end.

Пример (для n = 10) :

Массив A : - 294 - 223 - 187 51 - 79 - 288 - 367 38 21 - 25

k = Измененный массив : - 294 - 223 - 187 5 - 79 - 288 - 367 5 5 - 25

2)

const n = 50 ;

var a : array[1.

N] of integer ;

i, k : integer ;

begin

Randomize ;

writeln('Массив A : ') ;

for i : = 1 to n do

begin

a[i] : = random(111) - 100 ;

write(a[i] : 5) ;

end ;

writeln ;

k : = 0 ;

for i : = 1 to n do

if a[i]>0 then k : = k + 1 ;

writeln('k = ', k) ;

end.

Пример (для n = 10) :

Массив A : - 92 - 93 - 84 - 77 - 9 - 3 8 - 68 - 25 - 89

k = 1.

Tplotitsin 10 янв. 2022 г., 22:54:45 | 10 - 11 классы

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива?

Заполнить массив из 20 элементов случайными числами, определить количество нулевых элементов массива.

Севиля91 13 янв. 2022 г., 10:24:35 | 5 - 9 классы

1. Задать массив из 10 элементов с пом?

1. Задать массив из 10 элементов с пом.

Генератора случ.

Чисел из интервала (10, 30).

Увеличить каждое число в массиве три раза.

Вывести на экран оба массив(результат и исходный)

2.

Дано 2 массива из 80 элементов.

Заполнить первый с помощью генератора случ.

Чисел на интервале (50, 100) и заполнить второй массив корнями квадратными из чисел исходного массива.

SOLNZETIM 1 мар. 2022 г., 14:15:41 | 5 - 9 классы

Дано неотрицательное число N - количество элементов массива (N?

Дано неотрицательное число N - количество элементов массива (N.

Ignor73 2 янв. 2022 г., 06:40:05 | 10 - 11 классы

Дан массив вставить число k после первого отрицательного элемента?

Дан массив вставить число k после первого отрицательного элемента.

Паскаль.

Напишите, пожалуйста.

Name505 11 мар. 2022 г., 14:58:45 | 10 - 11 классы

Программа на с + +Дан массив, состоящий из целых чисел?

Программа на с + +

Дан массив, состоящий из целых чисел.

Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).

Входные данные

Сначала задано число N — количество элементов в массиве (1N10000).

Далее через пробел записаны N чисел — элементы массива.

Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры

входные данные

5

1 2 3 4 5

выходные данные

4.

Alicka762 30 янв. 2022 г., 23:07:20 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

1)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти среднее арифметическое нечетных трехзначных чисел, записанных в этом массиве.

Если ни одного такого числа нет, нужно вывести сообщение об этом.

2)дан целочисленный массив из 30 элементов.

Элементы массива могут принимать целые значения от 0 до 100.

Опишите на русском языке или на одном из языков программирования алгоритм, позволяющий найти и вывести произведение элементов массива, которые имеют четное значение и не оканчиваются на 0.

СнежанаСноу 16 февр. 2022 г., 12:53:17 | 5 - 9 классы

В массиве случайных чисел посчитать количество положительных элементов?

В массиве случайных чисел посчитать количество положительных элементов.

Максим146464647447 6 апр. 2022 г., 04:28:08 | 10 - 11 классы

В паскаль АВСЗаполнить массив А[1?

В паскаль АВС

Заполнить массив А[1.

8] числами, вводимыми с клавиатуры.

Найти среднее арифметическое четных элементов.

AidBag 6 апр. 2022 г., 06:38:49 | 10 - 11 классы

Помогите с паскалем : описать числовой массив на 5 элементов изаполнить его присваиванием любыми числами,распечатать содержимое элементов массива?

Помогите с паскалем : описать числовой массив на 5 элементов и

заполнить его присваиванием любыми числами,

распечатать содержимое элементов массива.

7vlad2003 14 мар. 2022 г., 04:43:21 | 5 - 9 классы

Даю 25 баллов?

Даю 25 баллов!

Дан массив из 20 вещественных чисел.

Найти среднее арифметическое чисел элементов массива и заменить на него максимум и минимум элементов массива стоящие на местах кратных 5.

На этой странице находится вопрос Записать задачи на языке Паскаль (используются циклы)1?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.