Решить в паскале с While?

Информатика | 5 - 9 классы

Решить в паскале с While!

Какой цифрой оканчивается сумма всех двузначных чисел, в записи которых имеется хотя бы одна цифра 3.

Ответить на вопрос
Ответы (1)
Vadim1255455 19 июн. 2021 г., 01:08:51

Var number, sum : integer ; begin sum : = 0 ; number : = 10 ; while (number < 100) do begin if (number div 10 = 3) or (number mod 10 = 3) then begin sum : = sum + number ; end ; number : = number + 1 ; end ; writeln('Сумма всех двухзначных цифр с цифрой "три" : ' + sum) ; writeln('Последняя цифра суммы : ' + (sum mod 10)) ;

end.

Wabonuzab 27 июл. 2021 г., 23:05:00 | 1 - 4 классы

Составьте программу на языке Паскаль для определения количества цифр в записи произвольного натурального числа?

Составьте программу на языке Паскаль для определения количества цифр в записи произвольного натурального числа.

( оператор while).

Bike1 23 июн. 2021 г., 05:53:03 | 5 - 9 классы

Найдите количество двузначных чисел, которые делятся на сумму своих цифр?

Найдите количество двузначных чисел, которые делятся на сумму своих цифр.

Это информатика.

Ника0918 26 янв. 2021 г., 13:16:56 | 10 - 11 классы

Дана последовательность символов, оканчивающаяся точкой?

Дана последовательность символов, оканчивающаяся точкой.

Выяснить, имеется ли в ней хотя бы одна цифра.

10022005kai 27 мар. 2021 г., 22:00:03 | 5 - 9 классы

Как решить такую задачу в паскале?

Как решить такую задачу в паскале?

Дано двузначное число.

Найти сумму его цифр.

Nikola2014 2 мая 2021 г., 11:16:59 | 5 - 9 классы

Как решить такую задачу в паскале?

Как решить такую задачу в паскале?

Дано двузначное число.

Найти сумму его цифр.

Ddvpenza 10 мая 2021 г., 11:28:20 | 5 - 9 классы

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К?

Среди всех двузначных чисел указать те, сумма цифр которых равна числу К.

Роллсп 7 окт. 2021 г., 02:26:48 | 5 - 9 классы

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр?

Найти количество четырехзначных натуральных чисел до N у которых сумма двух средних цифр равна хотя бы одной из крайних цифр.

Selmonella 30 мар. 2021 г., 01:50:55 | 5 - 9 классы

Помогите решить задачи в С + +1)Вывести на экран все двузначные числа в которых есть цифра n или само число делится на n?

Помогите решить задачи в С + +

1)Вывести на экран все двузначные числа в которых есть цифра n или само число делится на n.

N вводится с клавиатуры.

2)Вывести все трехзначные числа, которые являются палиндромами (одинаково читаются слева направо и наоборот 232, 454)

3)Найти сумму всех двузначных чисел, которые чётные или последняя цифра которых равна 7.

4)Найти количество всех трехзначных чисел, которые в своей записи имеют хотя бы 2 одинаковые цифры.

Sivach142 22 июл. 2021 г., 10:16:43 | 5 - 9 классы

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal)?

Среди двузначных чисел найти те, сумма цифр которых равна 10 (pascal).

Angelagabi 20 апр. 2021 г., 23:41:19 | 5 - 9 классы

Найти сумму квадратов неотрицательных двузначных чисел с разными цифрами?

Найти сумму квадратов неотрицательных двузначных чисел с разными цифрами.

На этой странице находится ответ на вопрос Решить в паскале с While?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.