Паскаль?

Информатика | 10 - 11 классы

Паскаль!

Дан массив A(n).

Определите количество четных элементов с четными индексами, кратных 7.

Выведите на экран исходный массив и полученное количество.

Ответить на вопрос
Ответы (1)
Artem042 1 окт. 2021 г., 07:00:47

Const n = 10 ;

var a : array[1.

N] of integer ;

i, k : integer ;

begin

Randomize ;

writeln('Массив A : ') ;

for i : = 1 to n do

begin

a[i] : = random(51) ;

write(a[i] : 4) ;

end ;

writeln ;

k : = 0 ;

for i : = 1 to n do

if (a[i] mod 2 = 0)and(a[i] mod 7 = 0)and(i mod 2 = 0) then k : = k + 1 ;

writeln('k = ', k) ;

end.

Пример :

Массив A :

25 29 13 39 9 14 27 16 12 45

k = 1.

Rainbowcat201519 2 янв. 2021 г., 17:38:59 | 5 - 9 классы

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел?

СРОЧНООООО задайте массив из 10 элементов с помощью датчика случайных чисел.

Найдите сумму индексов элементов, которые больше среднего арифметического.

Выведите на экран исходный массив и полученную сумму.

Kolya1986198741 10 мар. 2021 г., 20:55:58 | 5 - 9 классы

Дан массив из n элементов?

Дан массив из n элементов.

Найти сумму отрицательных элементов с четными индексами и отдельно с нечетными.

(Паскаль) 9 класс.

SKYFALL008 6 июн. 2021 г., 12:18:54 | 1 - 4 классы

Дан массив из 10 элементов найти количество четных элементов?

Дан массив из 10 элементов найти количество четных элементов.

Ks5555 31 янв. 2021 г., 14:50:44 | 5 - 9 классы

Составить программу, которая заполняет массив А[1?

Составить программу, которая заполняет массив А[1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Вывести на экран исходный и полученный массив.

Soupchikpab 10 янв. 2021 г., 22:07:01 | 10 - 11 классы

Помогите решить?

Помогите решить.

Напишите программу формирования массива размером 5х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки.

Выведите на экран исходный и измененный массив.

(Паскаль абс) С объяснением.

Sasha200229 4 февр. 2021 г., 21:07:49 | 5 - 9 классы

"массив в состоит из 15 элементов заполненными от 0 до 50 радномно, вычислите количество четных элементов" Напишите программу Паскаля?

"массив в состоит из 15 элементов заполненными от 0 до 50 радномно, вычислите количество четных элементов" Напишите программу Паскаля.

Inkognito211 25 апр. 2021 г., 00:47:11 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Найти сумму элементов с четными индексами.

Jika08 2 июл. 2021 г., 02:16:06 | 5 - 9 классы

Получить и вывести в строку на экран массив из 10 чисел с помощью генератора случайных чисел?

Получить и вывести в строку на экран массив из 10 чисел с помощью генератора случайных чисел.

Вывести на экран все элементы массива с четным индексом.

Daria20044thenicorn 22 мая 2021 г., 21:26:18 | 10 - 11 классы

ПаскальИмеется массив на 10 элементов ?

Паскаль

Имеется массив на 10 элементов .

Все элементы - натуральные числа .

Каждый четный элемент поменять местами с предыдущим .

Вывести полученный массив.

Volkovanadyshka 15 июн. 2021 г., 21:10:29 | 1 - 4 классы

1. Дан целочисленный массив найти количество элементов кратных пяти2?

1. Дан целочисленный массив найти количество элементов кратных пяти

2.

Найти количество элементов четных и больше 20.

На этой странице находится вопрос Паскаль?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.