Помогите пожалуйста написать массив(паскаль) первое задание?

Информатика | 10 - 11 классы

Помогите пожалуйста написать массив(паскаль) первое задание.

Ответить на вопрос
Ответы (1)
Ьфтлу 23 апр. 2021 г., 03:48:47

Знать бы, какой ввод данных

пусть он будет с клавиатуры, массив А из оценок N учеников

for i : = 1 to N do begin

sum : = sum + A[i] ; {это для среднего балла}

if (A[i] = 4) or (A[i] = 5) then

k1 : = k1 + 1 ; {счетчик отличников - хорошистов}

if A[i] = 2 then

k2 : = k2 + 1 ; {счетчик двоечников}

end ;

writeln('Количество учеников, написавших на 4 и 5 : ', k1) ;

if k2>0 then

writeln('Двоечники есть')

else writeln('Двоечников нет') ;

writeln('Средний балл : ', sum / N : 3 : 2) ;

end.

Екатерина513 21 янв. 2021 г., 07:14:51 | 10 - 11 классы

Ребята, помогите пожалуйста?

Ребята, помогите пожалуйста!

Первое, пятое и второе задания в обоих вариантах не надо.

PtPtP 19 июн. 2021 г., 08:55:14 | 5 - 9 классы

Решите, пожалуйста?

Решите, пожалуйста!

Первое задание!

ОЧЕНЬ СРОЧНО!

Nosachevaa 22 янв. 2021 г., 09:47:00 | 5 - 9 классы

Помогите с первым заданием с объяснением?

Помогите с первым заданием с объяснением.

Uto4kina 4 июл. 2021 г., 19:29:59 | 10 - 11 классы

Помогите решить первые 3 задания, пожалуйста?

Помогите решить первые 3 задания, пожалуйста!

Cuh12 30 янв. 2021 г., 06:09:52 | 10 - 11 классы

Написать алгоритм действий первого задания?

Написать алгоритм действий первого задания.

Алина200413 19 авг. 2021 г., 19:18:31 | 5 - 9 классы

Пожалуйста, помогите мне?

Пожалуйста, помогите мне!

Задание по паскалю абс

НАПЕЧАТАТЬ НОМЕРА ЭЛЕМЕНТОВ МАССИВА, МЕНЬШИХ ПЕРВОГО.

Такияки 18 окт. 2021 г., 19:44:56 | 1 - 4 классы

Помогите?

Помогите!

Нарисуйте рисунок к первому заданию!

Не понимаю.

Sieri 23 июн. 2021 г., 00:32:14 | 1 - 4 классы

Первые два задания, пожалуйста?

Первые два задания, пожалуйста.

Помогите пляз.

YuliaBad 3 дек. 2021 г., 20:44:39 | 10 - 11 классы

Помогите написать программу в паскале?

Помогите написать программу в паскале.

Задание 2.

RoseChernykh 5 сент. 2021 г., 13:48:46 | 5 - 9 классы

Помоги решить первое задание?

Помоги решить первое задание.

Вы перешли к вопросу Помогите пожалуйста написать массив(паскаль) первое задание?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.