Составьте программу, вычеркивающую из слова Х буквы, встречающиеся при написании слова Х ровно три раза?

Информатика | 10 - 11 классы

Составьте программу, вычеркивающую из слова Х буквы, встречающиеся при написании слова Х ровно три раза.

(паскаль).

Ответить на вопрос
Ответы (2)
2014юля 20 нояб. 2021 г., 22:57:43

Var s : string ; c : char ; i, j, k : integer ;

begin

write('Слово : ') ;

readln(s) ;

writeln(s) ;

i : = 1 ;

while i0 do delete(s, pos(c, s), 1) ; i : = i - 1 ; end ;

i : = i + 1 ;

end ;

writeln(s) ;

end.

Пример :

Слово : pnbouipobnpongnf

pnbouipobnpongnf

nbuibnngnf.

Алексей631 20 нояб. 2021 г., 22:57:48

/ / Паскаль / / Программа поддерживает латиницу, кириллицу и дефисы

const / / Первая буквы, англ.

"a" - 65, но может быть дефис #45 first_letter = #45 ; / / Последняя буквы, рус.

"я" last_letter = #1103 ;

var x : string ; i : integer ; c : char ; / / Сколько раз встречает буква в слове count : array[first_letter.

Last_letter] of integer ;

begin readln(x) ; / / Обнуляем массив for c : = first_letter to last_letter do count[c] : = 0 ; / / Подсчитываем буквы в слове for i : = 1 to length(x) do inc(count[x[i]]) ; / / Выводим слово без букв, встречающихся 3 раза for i : = 1 to length(x) do if count[x[i]] 3 then write(x[i])

end.

KarinaKarina352 17 янв. 2021 г., 04:36:52 | 5 - 9 классы

Составьте программу в системе паскаль №11?

Составьте программу в системе паскаль №11.

Kamyshnikovav 16 янв. 2021 г., 14:33:43 | 5 - 9 классы

Составьте программу , которая опеделяет , какая из букв 'и' или 'ы' встречается чаще в введенной с клавиатуры строке ?

Составьте программу , которая опеделяет , какая из букв 'и' или 'ы' встречается чаще в введенной с клавиатуры строке .

AlenaSe05 10 авг. 2021 г., 19:52:45 | 5 - 9 классы

Ваня составляет 5 - буквенные слова, в которых встречаются только буквы А, Б, В, Г,причём буква А появляется ровно 2 раза?

Ваня составляет 5 - буквенные слова, в которых встречаются только буквы А, Б, В, Г,

причём буква А появляется ровно 2 раза.

Каждая из других допустимых букв может

встречаться в слове любое количество раз или не встречаться совсем.

Словом считается любая

допустимая последовательность букв, не обязательно осмысленная.

Сколько существует таких

слов, которые может написать Ваня?

Isarama 16 февр. 2021 г., 01:33:49 | 5 - 9 классы

ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ?

ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ!

Составьте программу, которая позволяет удалить из слова X те буквы, которые встречаются в слове Z.

Слова X и Z введите с клавиатуры.

Anateis 10 июн. 2021 г., 17:13:28 | 5 - 9 классы

В слово сок нужно вставить букву и чтобы получилось новое слово сток?

В слово сок нужно вставить букву и чтобы получилось новое слово сток.

По программе Паскаль.

Рома0729 2 авг. 2021 г., 02:01:52 | 5 - 9 классы

ПАСКАЛЬ Составьте программу, определяющую длину слов" я ученик "?

ПАСКАЛЬ Составьте программу, определяющую длину слов

" я ученик ".

Alinochka171 25 дек. 2021 г., 12:49:25 | 10 - 11 классы

Пожалуйста составьте программу в паскалеДан массив, состоящий из 100 целых чисел?

Пожалуйста составьте программу в паскале

Дан массив, состоящий из 100 целых чисел.

Выведите все числа, которые встречаются в этом массиве :

а) несколько раз ;

б) только по одному разу.

Sashashabashov228 26 окт. 2021 г., 10:06:38 | 5 - 9 классы

В Паскале, подробно?

В Паскале, подробно.

Составьте программу.

Matyuhin1 21 сент. 2021 г., 04:44:15 | 5 - 9 классы

Запишите на языке паскаль программу которая вычисляет сумму кодов букв в слове память?

Запишите на языке паскаль программу которая вычисляет сумму кодов букв в слове память.

Schultz0arina 29 окт. 2021 г., 20:48:57 | студенческий

Запишите на языке Паскаль программу, которая вычисляет сумму кодов букв в слове '' память''?

Запишите на языке Паскаль программу, которая вычисляет сумму кодов букв в слове '' память''.

На этой странице находится вопрос Составьте программу, вычеркивающую из слова Х буквы, встречающиеся при написании слова Х ровно три раза?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.